CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2013-1862

mod_rewrite.c in the mod_rewrite module in the Apache HTTP Server 2.2.x before 2.2.25 writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to execute arbitrary commands via an HTTP request containing an escape sequence for a terminal emulator.
Publish Date : 2013-06-10 Last Update Date : 2014-03-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 310

- Related OVAL Definitions

Title Definition Id Class Family
Apache HTTP vulnerability from 2.2.x before 2.2.25 in VisualSVN Server (CVE-2013-1862) oval:org.mitre.oval:def:18790 windows
DEPRECATED: ELSA-2013:0815: httpd security update (Moderate) oval:org.mitre.oval:def:23465 unix
ELSA-2013:0815: httpd security update (Moderate) oval:org.mitre.oval:def:24116 unix
HP-UX Apache Web Server, Remote Execution of Arbitrary Code, Denial of Service (DoS) oval:org.mitre.oval:def:19534 unix
RHSA-2013:0815: httpd security update (Moderate) oval:org.mitre.oval:def:21067 unix
RHSA-2013:0815: httpd security update (Moderate) oval:com.redhat.rhsa:def:20130815 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2013-1862

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Http Server 2.2 Version Details Vulnerabilities
2 Application Apache Http Server 2.2.0 Version Details Vulnerabilities
3 Application Apache Http Server 2.2.1 Version Details Vulnerabilities
4 Application Apache Http Server 2.2.2 Version Details Vulnerabilities
5 Application Apache Http Server 2.2.3 Version Details Vulnerabilities
6 Application Apache Http Server 2.2.4 Version Details Vulnerabilities
7 Application Apache Http Server 2.2.6 Version Details Vulnerabilities
8 Application Apache Http Server 2.2.8 Version Details Vulnerabilities
9 Application Apache Http Server 2.2.9 Version Details Vulnerabilities
10 Application Apache Http Server 2.2.10 Version Details Vulnerabilities
11 Application Apache Http Server 2.2.11 Version Details Vulnerabilities
12 Application Apache Http Server 2.2.12 Version Details Vulnerabilities
13 Application Apache Http Server 2.2.13 Version Details Vulnerabilities
14 Application Apache Http Server 2.2.14 Version Details Vulnerabilities
15 Application Apache Http Server 2.2.15 Version Details Vulnerabilities
16 Application Apache Http Server 2.2.16 Version Details Vulnerabilities
17 Application Apache Http Server 2.2.17 Version Details Vulnerabilities
18 Application Apache Http Server 2.2.18 Version Details Vulnerabilities
19 Application Apache Http Server 2.2.19 Version Details Vulnerabilities
20 Application Apache Http Server 2.2.20 Version Details Vulnerabilities
21 Application Apache Http Server 2.2.21 Version Details Vulnerabilities
22 Application Apache Http Server 2.2.22 Version Details Vulnerabilities
23 Application Apache Http Server 2.2.23 Version Details Vulnerabilities
24 Application Apache Http Server 2.2.24 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Http Server 24

- References For CVE-2013-1862

http://lists.opensuse.org/opensuse-updates/2013-08/msg00026.html
SUSE openSUSE-SU-2013:1337
http://tools.cisco.com/security/center/content/CiscoSecurityNotice/CVE-2013-1862
CISCO 20130822 Apache HTTP Server mod_rewrite Log File Manipulation Vulnerability
http://lists.opensuse.org/opensuse-updates/2013-08/msg00029.html
SUSE openSUSE-SU-2013:1340
http://rhn.redhat.com/errata/RHSA-2013-0815.html
REDHAT RHSA-2013:0815
http://lists.opensuse.org/opensuse-updates/2013-08/msg00030.html
SUSE openSUSE-SU-2013:1341
http://secunia.com/advisories/55032
SECUNIA 55032
http://rhn.redhat.com/errata/RHSA-2013-1209.html
REDHAT RHSA-2013:1209
http://rhn.redhat.com/errata/RHSA-2013-1208.html
REDHAT RHSA-2013:1208
https://bugzilla.redhat.com/show_bug.cgi?id=953729 CONFIRM
http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html CONFIRM
http://support.apple.com/kb/HT6150 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg21644047 CONFIRM
http://people.apache.org/~jorton/mod_rewrite-CVE-2013-1862.patch CONFIRM
https://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/kb/docDisplay/?spf_p.tpst=kbDocDisplay&spf_p.prp_kbDocDisplay=wsrp-navigationalState%3DdocId%253Demr_na-c03922406-1%257CdocLocale%253D%257CcalledBy%253D&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken
HP SSRT101288
http://rhn.redhat.com/errata/RHSA-2013-1207.html
REDHAT RHSA-2013:1207
http://svn.apache.org/viewvc?view=revision&revision=r1469311 CONFIRM
http://www.securityfocus.com/bid/64758
BID 64758 RETIRED: Oracle January 2014 Critical Patch Update Multiple Vulnerabilities Release Date:2014-09-30
http://www.mandriva.com/security/advisories?name=MDVSA-2013:174
MANDRIVA MDVSA-2013:174
http://www.ubuntu.com/usn/USN-1903-1
UBUNTU USN-1903-1

- Metasploit Modules Related To CVE-2013-1862

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.