CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2013-1685

Use-after-free vulnerability in the nsIDocument::GetRootElement function in Mozilla Firefox before 22.0, Firefox ESR 17.x before 17.0.7, Thunderbird before 17.0.7, and Thunderbird ESR 17.x before 17.0.7 allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via a crafted web site.
Publish Date : 2013-06-25 Last Update Date : 2013-11-02
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceExecute CodeMemory corruption
CWE ID 399

- Related OVAL Definitions

Title Definition Id Class Family
DEPRECATED: ELSA-2013:0982: thunderbird security update (Important) oval:org.mitre.oval:def:23136 unix
DEPRECATED: ELSA-2013:0981: firefox security update (Critical) oval:org.mitre.oval:def:23392 unix
DSA-2716-1 iceweasel - several oval:org.mitre.oval:def:20086 unix
DSA-2720-1 icedove - several oval:org.mitre.oval:def:19998 unix
ELSA-2013-0981 -- firefox security update (critical) oval:org.mitre.oval:def:27613 unix
ELSA-2013-0982 -- thunderbird security update (important) oval:org.mitre.oval:def:27536 unix
ELSA-2013:0981: firefox security update (Critical) oval:org.mitre.oval:def:23822 unix
ELSA-2013:0982: thunderbird security update (Important) oval:org.mitre.oval:def:23481 unix
RHSA-2013:0981: firefox security update (Critical) oval:org.mitre.oval:def:20691 unix
RHSA-2013:0981: firefox security update (Critical) oval:com.redhat.rhsa:def:20130981 unix
RHSA-2013:0982: thunderbird security update (Important) oval:org.mitre.oval:def:20827 unix
RHSA-2013:0982: thunderbird security update (Important) oval:com.redhat.rhsa:def:20130982 unix
SUSE-SU-2013:1152-1 -- Security update for Mozilla Firefox oval:org.mitre.oval:def:25919 unix
SUSE-SU-2013:1153-1 -- Security update for Mozilla Firefox oval:org.mitre.oval:def:25026 unix
Use-after-free vulnerability in the nsIDocument::GetRootElement function in Mozilla Firefox before 22.0, Firefox ESR 17.... oval:org.mitre.oval:def:17330 windows
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2013-1685

# Product Type Vendor Product Version Update Edition Language
1 Application Mozilla Firefox 19.0 Version Details Vulnerabilities
2 Application Mozilla Firefox 19.0.1 Version Details Vulnerabilities
3 Application Mozilla Firefox 19.0.2 Version Details Vulnerabilities
4 Application Mozilla Firefox 20.0 Version Details Vulnerabilities
5 Application Mozilla Firefox 20.0.1 Version Details Vulnerabilities
6 Application Mozilla Firefox 21.0 Version Details Vulnerabilities
7 Application Mozilla Firefox Esr 17.0 Version Details Vulnerabilities
8 Application Mozilla Firefox Esr 17.0.1 Version Details Vulnerabilities
9 Application Mozilla Firefox Esr 17.0.2 Version Details Vulnerabilities
10 Application Mozilla Firefox Esr 17.0.3 Version Details Vulnerabilities
11 Application Mozilla Firefox Esr 17.0.4 Version Details Vulnerabilities
12 Application Mozilla Firefox Esr 17.0.5 Version Details Vulnerabilities
13 Application Mozilla Firefox Esr 17.0.6 Version Details Vulnerabilities
14 Application Mozilla Thunderbird 17.0 Version Details Vulnerabilities
15 Application Mozilla Thunderbird 17.0.1 Version Details Vulnerabilities
16 Application Mozilla Thunderbird 17.0.2 Version Details Vulnerabilities
17 Application Mozilla Thunderbird 17.0.3 Version Details Vulnerabilities
18 Application Mozilla Thunderbird 17.0.4 Version Details Vulnerabilities
19 Application Mozilla Thunderbird 17.0.5 Version Details Vulnerabilities
20 Application Mozilla Thunderbird 17.0.6 Version Details Vulnerabilities
21 Application Mozilla Thunderbird Esr 17.0 Version Details Vulnerabilities
22 Application Mozilla Thunderbird Esr 17.0.1 Version Details Vulnerabilities
23 Application Mozilla Thunderbird Esr 17.0.2 Version Details Vulnerabilities
24 Application Mozilla Thunderbird Esr 17.0.3 Version Details Vulnerabilities
25 Application Mozilla Thunderbird Esr 17.0.4 Version Details Vulnerabilities
26 Application Mozilla Thunderbird Esr 17.0.5 Version Details Vulnerabilities
27 Application Mozilla Thunderbird Esr 17.0.6 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mozilla Firefox 6
Mozilla Firefox Esr 7
Mozilla Thunderbird 7
Mozilla Thunderbird Esr 7

- References For CVE-2013-1685

https://bugzilla.mozilla.org/show_bug.cgi?id=871099 CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00003.html
SUSE openSUSE-SU-2013:1140
http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00005.html
SUSE openSUSE-SU-2013:1142
http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00011.html
SUSE SUSE-SU-2013:1153
http://www.ubuntu.com/usn/USN-1890-1
UBUNTU USN-1890-1
http://www.mozilla.org/security/announce/2013/mfsa2013-50.html CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00004.html
SUSE openSUSE-SU-2013:1141
http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00010.html
SUSE SUSE-SU-2013:1152
http://rhn.redhat.com/errata/RHSA-2013-0981.html
REDHAT RHSA-2013:0981
http://rhn.redhat.com/errata/RHSA-2013-0982.html
REDHAT RHSA-2013:0982
http://www.debian.org/security/2013/dsa-2716
DEBIAN DSA-2716
http://www.debian.org/security/2013/dsa-2720
DEBIAN DSA-2720
http://www.ubuntu.com/usn/USN-1891-1
UBUNTU USN-1891-1
http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00006.html
SUSE openSUSE-SU-2013:1143

- Metasploit Modules Related To CVE-2013-1685

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.