CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-2981

Webmin 1.590 and earlier allows remote authenticated users to execute arbitrary Perl code via a crafted file associated with the type (aka monitor type name) parameter.
Publish Date : 2012-09-11 Last Update Date : 2013-05-29
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 20

- Products Affected By CVE-2012-2981

# Product Type Vendor Product Version Update Edition Language
1 Application Gentoo Webmin 1.140 Version Details Vulnerabilities
2 Application Gentoo Webmin 1.150 Version Details Vulnerabilities
3 Application Gentoo Webmin 1.160 Version Details Vulnerabilities
4 Application Gentoo Webmin 1.170 Version Details Vulnerabilities
5 Application Gentoo Webmin 1.180 Version Details Vulnerabilities
6 Application Gentoo Webmin 1.200 Version Details Vulnerabilities
7 Application Gentoo Webmin 1.210 Version Details Vulnerabilities
8 Application Gentoo Webmin 1.220 Version Details Vulnerabilities
9 Application Gentoo Webmin 1.230 Version Details Vulnerabilities
10 Application Gentoo Webmin 1.240 Version Details Vulnerabilities
11 Application Gentoo Webmin 1.260 Version Details Vulnerabilities
12 Application Gentoo Webmin 1.270 Version Details Vulnerabilities
13 Application Gentoo Webmin 1.280 Version Details Vulnerabilities
14 Application Gentoo Webmin 1.290 Version Details Vulnerabilities
15 Application Gentoo Webmin 1.300 Version Details Vulnerabilities
16 Application Gentoo Webmin 1.310 Version Details Vulnerabilities
17 Application Gentoo Webmin 1.320 Version Details Vulnerabilities
18 Application Gentoo Webmin 1.330 Version Details Vulnerabilities
19 Application Gentoo Webmin 1.340 Version Details Vulnerabilities
20 Application Gentoo Webmin 1.370 Version Details Vulnerabilities
21 Application Gentoo Webmin 1.380 Version Details Vulnerabilities
22 Application Gentoo Webmin 1.390 Version Details Vulnerabilities
23 Application Gentoo Webmin 1.400 Version Details Vulnerabilities
24 Application Gentoo Webmin 1.410 Version Details Vulnerabilities
25 Application Gentoo Webmin 1.420 Version Details Vulnerabilities
26 Application Gentoo Webmin 1.430 Version Details Vulnerabilities
27 Application Gentoo Webmin 1.440 Version Details Vulnerabilities
28 Application Gentoo Webmin 1.450 Version Details Vulnerabilities
29 Application Gentoo Webmin 1.470 Version Details Vulnerabilities
30 Application Gentoo Webmin 1.480 Version Details Vulnerabilities
31 Application Gentoo Webmin 1.500 Version Details Vulnerabilities
32 Application Gentoo Webmin 1.510 Version Details Vulnerabilities
33 Application Gentoo Webmin 1.520 Version Details Vulnerabilities
34 Application Gentoo Webmin 1.530 Version Details Vulnerabilities
35 Application Gentoo Webmin 1.550 Version Details Vulnerabilities
36 Application Gentoo Webmin 1.560 Version Details Vulnerabilities
37 Application Gentoo Webmin 1.570 Version Details Vulnerabilities
38 Application Gentoo Webmin 1.580 Version Details Vulnerabilities
39 Application Gentoo Webmin 1.590 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Gentoo Webmin 39

- References For CVE-2012-2981

http://www.kb.cert.org/vuls/id/788478
CERT-VN VU#788478
http://www.americaninfosec.com/research/dossiers/AISG-12-000.pdf
http://americaninfosec.com/research/index.html
http://www.securitytracker.com/id?1027507
SECTRACK 1027507
http://www.xerox.com/download/security/security-bulletin/16287-4d6b7b0c81f7b/cert_XRX13-003_v1.0.pdf CONFIRM
https://github.com/webmin/webmin/commit/ed7365064c189b8f136a9f952062249167d1bd9e CONFIRM

- Metasploit Modules Related To CVE-2012-2981

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.