CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-4704

libavcodec/vorbis_dec.c in the Vorbis decoder in FFmpeg 0.6.1 and earlier allows remote attackers to cause a denial of service (application crash) via a crafted .ogg file, related to the vorbis_floor0_decode function. NOTE: this might overlap CVE-2011-0480.
Publish Date : 2011-01-22 Last Update Date : 2011-10-25
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 20

- Related OVAL Definitions

Title Definition Id Class Family
DSA-2165-1 ffmpeg-debian -- buffer overflow oval:org.mitre.oval:def:12955 unix
DSA-2306-1 ffmpeg -- several oval:org.mitre.oval:def:15128 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-4704

# Product Type Vendor Product Version Update Edition Language
1 Application Ffmpeg Ffmpeg 0.3 Version Details Vulnerabilities
2 Application Ffmpeg Ffmpeg 0.3.1 Version Details Vulnerabilities
3 Application Ffmpeg Ffmpeg 0.3.2 Version Details Vulnerabilities
4 Application Ffmpeg Ffmpeg 0.3.3 Version Details Vulnerabilities
5 Application Ffmpeg Ffmpeg 0.3.4 Version Details Vulnerabilities
6 Application Ffmpeg Ffmpeg 0.4.0 Version Details Vulnerabilities
7 Application Ffmpeg Ffmpeg 0.4.2 Version Details Vulnerabilities
8 Application Ffmpeg Ffmpeg 0.4.3 Version Details Vulnerabilities
9 Application Ffmpeg Ffmpeg 0.4.4 Version Details Vulnerabilities
10 Application Ffmpeg Ffmpeg 0.4.5 Version Details Vulnerabilities
11 Application Ffmpeg Ffmpeg 0.4.6 Version Details Vulnerabilities
12 Application Ffmpeg Ffmpeg 0.4.7 Version Details Vulnerabilities
13 Application Ffmpeg Ffmpeg 0.4.8 Version Details Vulnerabilities
14 Application Ffmpeg Ffmpeg 0.4.9 Pre1 Version Details Vulnerabilities
15 Application Ffmpeg Ffmpeg 0.5 Version Details Vulnerabilities
16 Application Ffmpeg Ffmpeg 0.6 Version Details Vulnerabilities
17 Application Ffmpeg Ffmpeg 0.6.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Ffmpeg Ffmpeg 17

- References For CVE-2010-4704

http://ffmpeg.mplayerhq.hu/ CONFIRM
http://secunia.com/advisories/43323
SECUNIA 43323
http://www.debian.org/security/2011/dsa-2165
DEBIAN DSA-2165
http://www.debian.org/security/2011/dsa-2306
DEBIAN DSA-2306
http://www.mandriva.com/security/advisories?name=MDVSA-2011:060
MANDRIVA MDVSA-2011:060
http://www.mandriva.com/security/advisories?name=MDVSA-2011:061
MANDRIVA MDVSA-2011:061
http://www.mandriva.com/security/advisories?name=MDVSA-2011:062
MANDRIVA MDVSA-2011:062
http://www.mandriva.com/security/advisories?name=MDVSA-2011:088
MANDRIVA MDVSA-2011:088
http://www.mandriva.com/security/advisories?name=MDVSA-2011:112
MANDRIVA MDVSA-2011:112
http://www.mandriva.com/security/advisories?name=MDVSA-2011:089
MANDRIVA MDVSA-2011:089
http://www.vupen.com/english/advisories/2011/1241
VUPEN ADV-2011-1241
http://www.mandriva.com/security/advisories?name=MDVSA-2011:114
MANDRIVA MDVSA-2011:114
http://www.ubuntu.com/usn/usn-1104-1/
UBUNTU USN-1104-1
http://git.ffmpeg.org/?p=ffmpeg.git;a=commit;h=3dde66752d59dfdd0f3727efd66e7202b3c75078 CONFIRM
https://roundup.ffmpeg.org/issue2322 CONFIRM
http://www.securityfocus.com/bid/46294
BID 46294 FFmpeg Integer Overflow and Denial of Service Vulnerabilities Release Date:2013-10-28

- Metasploit Modules Related To CVE-2010-4704

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.