CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-0733

Integer overflow in src/backend/executor/nodeHash.c in PostgreSQL 8.4.1 and earlier, and 8.5 through 8.5alpha2, allows remote authenticated users to cause a denial of service (daemon crash) via a SELECT statement with many LEFT JOIN clauses, related to certain hashtable size calculations.
Publish Date : 2010-03-19 Last Update Date : 2017-09-18
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
3.5
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Denial Of ServiceOverflow
CWE ID 189

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low
2.7
AV:A/AC:L/Au:S/C:N/I:N/A:P 2009-12-10 2009-12-10
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2010-0733 oval:org.opensuse.security:def:20100733 unix
DEPRECATED: ELSA-2010-0429 -- postgresql security update (moderate) oval:org.mitre.oval:def:27970 unix
ELSA-2010:0429: postgresql security update (Moderate) oval:org.mitre.oval:def:22939 unix
Integer overflow in src/backend/executor/nodeHash.c in PostgreSQL 8.4.1 and earlier, and 8.5 through 8.5alpha2, allows r... oval:org.mitre.oval:def:10691 unix
RHSA-2010:0427: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20100427 unix
RHSA-2010:0428: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20100428 unix
RHSA-2010:0429: postgresql security update (Moderate) oval:org.mitre.oval:def:21774 unix
RHSA-2010:0429: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20100429 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-0733

# Product Type Vendor Product Version Update Edition Language
1 Application Postgresql Postgresql 8.0 Version Details Vulnerabilities
2 Application Postgresql Postgresql 8.0.0 Version Details Vulnerabilities
3 Application Postgresql Postgresql 8.0.1 Version Details Vulnerabilities
4 Application Postgresql Postgresql 8.0.2 Version Details Vulnerabilities
5 Application Postgresql Postgresql 8.0.3 Version Details Vulnerabilities
6 Application Postgresql Postgresql 8.0.4 Version Details Vulnerabilities
7 Application Postgresql Postgresql 8.0.5 Version Details Vulnerabilities
8 Application Postgresql Postgresql 8.0.6 Version Details Vulnerabilities
9 Application Postgresql Postgresql 8.0.7 Version Details Vulnerabilities
10 Application Postgresql Postgresql 8.0.8 Version Details Vulnerabilities
11 Application Postgresql Postgresql 8.0.9 Version Details Vulnerabilities
12 Application Postgresql Postgresql 8.0.10 Version Details Vulnerabilities
13 Application Postgresql Postgresql 8.0.11 Version Details Vulnerabilities
14 Application Postgresql Postgresql 8.0.12 Version Details Vulnerabilities
15 Application Postgresql Postgresql 8.0.13 Version Details Vulnerabilities
16 Application Postgresql Postgresql 8.0.14 Version Details Vulnerabilities
17 Application Postgresql Postgresql 8.0.15 Version Details Vulnerabilities
18 Application Postgresql Postgresql 8.0.16 Version Details Vulnerabilities
19 Application Postgresql Postgresql 8.0.17 Version Details Vulnerabilities
20 Application Postgresql Postgresql 8.0.18 Version Details Vulnerabilities
21 Application Postgresql Postgresql 8.0.19 Version Details Vulnerabilities
22 Application Postgresql Postgresql 8.0.20 Version Details Vulnerabilities
23 Application Postgresql Postgresql 8.0.21 Version Details Vulnerabilities
24 Application Postgresql Postgresql 8.0.22 Version Details Vulnerabilities
25 Application Postgresql Postgresql 8.0.23 Version Details Vulnerabilities
26 Application Postgresql Postgresql 8.0.24 Version Details Vulnerabilities
27 Application Postgresql Postgresql 8.0.317 Version Details Vulnerabilities
28 Application Postgresql Postgresql 8.1 Version Details Vulnerabilities
29 Application Postgresql Postgresql 8.1.0 Version Details Vulnerabilities
30 Application Postgresql Postgresql 8.1.1 Version Details Vulnerabilities
31 Application Postgresql Postgresql 8.1.2 Version Details Vulnerabilities
32 Application Postgresql Postgresql 8.1.3 Version Details Vulnerabilities
33 Application Postgresql Postgresql 8.1.4 Version Details Vulnerabilities
34 Application Postgresql Postgresql 8.1.5 Version Details Vulnerabilities
35 Application Postgresql Postgresql 8.1.6 Version Details Vulnerabilities
36 Application Postgresql Postgresql 8.1.7 Version Details Vulnerabilities
37 Application Postgresql Postgresql 8.1.8 Version Details Vulnerabilities
38 Application Postgresql Postgresql 8.1.9 Version Details Vulnerabilities
39 Application Postgresql Postgresql 8.1.10 Version Details Vulnerabilities
40 Application Postgresql Postgresql 8.1.11 Version Details Vulnerabilities
41 Application Postgresql Postgresql 8.1.12 Version Details Vulnerabilities
42 Application Postgresql Postgresql 8.1.13 Version Details Vulnerabilities
43 Application Postgresql Postgresql 8.1.14 Version Details Vulnerabilities
44 Application Postgresql Postgresql 8.1.15 Version Details Vulnerabilities
45 Application Postgresql Postgresql 8.1.16 Version Details Vulnerabilities
46 Application Postgresql Postgresql 8.1.17 Version Details Vulnerabilities
47 Application Postgresql Postgresql 8.1.18 Version Details Vulnerabilities
48 Application Postgresql Postgresql 8.1.19 Version Details Vulnerabilities
49 Application Postgresql Postgresql 8.1.20 Version Details Vulnerabilities
50 Application Postgresql Postgresql 8.2 Version Details Vulnerabilities
51 Application Postgresql Postgresql 8.2.1 Version Details Vulnerabilities
52 Application Postgresql Postgresql 8.2.2 Version Details Vulnerabilities
53 Application Postgresql Postgresql 8.2.3 Version Details Vulnerabilities
54 Application Postgresql Postgresql 8.2.4 Version Details Vulnerabilities
55 Application Postgresql Postgresql 8.2.5 Version Details Vulnerabilities
56 Application Postgresql Postgresql 8.2.6 Version Details Vulnerabilities
57 Application Postgresql Postgresql 8.2.7 Version Details Vulnerabilities
58 Application Postgresql Postgresql 8.2.8 Version Details Vulnerabilities
59 Application Postgresql Postgresql 8.2.9 Version Details Vulnerabilities
60 Application Postgresql Postgresql 8.2.10 Version Details Vulnerabilities
61 Application Postgresql Postgresql 8.2.11 Version Details Vulnerabilities
62 Application Postgresql Postgresql 8.2.12 Version Details Vulnerabilities
63 Application Postgresql Postgresql 8.2.13 Version Details Vulnerabilities
64 Application Postgresql Postgresql 8.2.14 Version Details Vulnerabilities
65 Application Postgresql Postgresql 8.2.15 Version Details Vulnerabilities
66 Application Postgresql Postgresql 8.2.16 Version Details Vulnerabilities
67 Application Postgresql Postgresql 8.3 Version Details Vulnerabilities
68 Application Postgresql Postgresql 8.3.1 Version Details Vulnerabilities
69 Application Postgresql Postgresql 8.3.2 Version Details Vulnerabilities
70 Application Postgresql Postgresql 8.3.3 Version Details Vulnerabilities
71 Application Postgresql Postgresql 8.3.4 Version Details Vulnerabilities
72 Application Postgresql Postgresql 8.3.5 Version Details Vulnerabilities
73 Application Postgresql Postgresql 8.3.6 Version Details Vulnerabilities
74 Application Postgresql Postgresql 8.3.7 Version Details Vulnerabilities
75 Application Postgresql Postgresql 8.3.8 Version Details Vulnerabilities
76 Application Postgresql Postgresql 8.3.9 Version Details Vulnerabilities
77 Application Postgresql Postgresql 8.3.10 Version Details Vulnerabilities
78 Application Postgresql Postgresql 8.4 Version Details Vulnerabilities
79 Application Postgresql Postgresql 8.4.1 Version Details Vulnerabilities
80 Application Postgresql Postgresql 8.5 Version Details Vulnerabilities
81 Application Postgresql Postgresql 8.5 Alpha2 Version Details Vulnerabilities
82 Application Postgresql Postgresql 8.5 Alpha1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Postgresql Postgresql 82

- References For CVE-2010-0733

https://bugzilla.redhat.com/show_bug.cgi?id=546621 CONFIRM
http://www.vupen.com/english/advisories/2010/1197
VUPEN ADV-2010-1197
http://www.securityfocus.com/bid/38619
BID 38619 PostgreSQL JOIN Hashtable Size Integer Overflow Denial Of Service Vulnerability Release Date:2010-08-02
http://www.redhat.com/support/errata/RHSA-2010-0429.html
REDHAT RHSA-2010:0429
http://www.redhat.com/support/errata/RHSA-2010-0427.html
REDHAT RHSA-2010:0427
http://www.redhat.com/support/errata/RHSA-2010-0428.html
REDHAT RHSA-2010:0428
http://www.openwall.com/lists/oss-security/2010/03/16/10
MLIST [oss-security] 20100316 Re: CVE Request: postgresql integer overflow in hash table size calculation
http://www.openwall.com/lists/oss-security/2010/03/09/2
MLIST [oss-security] 20100309 CVE Request: postgresql integer overflow in hash table size calculation
http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00001.html
SUSE SUSE-SR:2010:014
http://archives.postgresql.org/pgsql-bugs/2009-10/msg00310.php
MLIST [pgsql-bugs] 20091030 Re: BUG #5145: Complex query with lots of LEFT JOIN causes segfault
http://git.postgresql.org/gitweb?p=postgresql.git;a=commit;h=64b057e6823655fb6c5d1f24a28f236b94dd6c54 CONFIRM
http://archives.postgresql.org/pgsql-bugs/2009-10/msg00287.php
MLIST [pgsql-bugs] 20091029 Re: BUG #5145: Complex query with lots of LEFT JOIN causes segfault
http://archives.postgresql.org/pgsql-bugs/2009-10/msg00289.php
MLIST [pgsql-bugs] 20091029 Re: BUG #5145: Complex query with lots of LEFT JOIN causes segfault
http://archives.postgresql.org/pgsql-bugs/2009-10/msg00277.php
MLIST [pgsql-bugs] 20091028 BUG #5145: Complex query with lots of LEFT JOIN causes segfault

- Metasploit Modules Related To CVE-2010-0733

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.