CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2010-0027

The URL validation functionality in Microsoft Internet Explorer 5.01, 6, 6 SP1, 7 and 8, and the ShellExecute API function in Windows 2000 SP4, XP SP2 and SP3, and Server 2003 SP2, does not properly process input parameters, which allows remote attackers to execute arbitrary local programs via a crafted URL, aka "URL Validation Vulnerability."
Publish Date : 2010-01-22 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 94

- Related OVAL Definitions

Title Definition Id Class Family
MS10-007: Vulnerability in Windows Shell Handler Could Allow Remote Code Execution (975713) oval:gov.nist.fdcc.patch:def:11644 windows
URL Validation Vulnerability oval:org.mitre.oval:def:8464 windows
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2010-0027

# Product Type Vendor Product Version Update Edition Language
1 Application Microsoft IE 5.01 SP4 Version Details Vulnerabilities
2 Application Microsoft IE 6 SP1 Version Details Vulnerabilities
3 Application Microsoft IE 6 Version Details Vulnerabilities
4 Application Microsoft IE 7 Version Details Vulnerabilities
5 Application Microsoft IE 7.0 Version Details Vulnerabilities
6 Application Microsoft IE 7.0.5730 Unknown Gold Version Details Vulnerabilities
7 Application Microsoft IE 7.0.5730.11 Version Details Vulnerabilities
8 Application Microsoft IE 7.00.5730.1100 Version Details Vulnerabilities
9 Application Microsoft IE 7.00.6000.16386 Version Details Vulnerabilities
10 Application Microsoft IE 7.00.6000.16441 Version Details Vulnerabilities
11 Application Microsoft IE 8 Version Details Vulnerabilities
12 Application Microsoft IE 8.0.6001 Version Details Vulnerabilities
13 OS Microsoft Windows 2000 SP4 Version Details Vulnerabilities
14 OS Microsoft Windows 2003 Server SP2 Itanium Version Details Vulnerabilities
15 OS Microsoft Windows 2003 Server SP2 Version Details Vulnerabilities
16 OS Microsoft Windows 7 - - X64 Version Details Vulnerabilities
17 OS Microsoft Windows 7 - - X32 Version Details Vulnerabilities
18 OS Microsoft Windows Server 2003 SP2 X64 Version Details Vulnerabilities
19 OS Microsoft Windows Server 2003 SP2 Itanium Version Details Vulnerabilities
20 OS Microsoft Windows Server 2008 X32 Version Details Vulnerabilities
21 OS Microsoft Windows Server 2008 R2 X64 Version Details Vulnerabilities
22 OS Microsoft Windows Server 2008 SP2 X32 Version Details Vulnerabilities
23 OS Microsoft Windows Server 2008 R2 Itanium Version Details Vulnerabilities
24 OS Microsoft Windows Server 2008 X64 Version Details Vulnerabilities
25 OS Microsoft Windows Server 2008 SP2 X64 Version Details Vulnerabilities
26 OS Microsoft Windows Vista SP1 Version Details Vulnerabilities
27 OS Microsoft Windows Vista SP2 Version Details Vulnerabilities
28 OS Microsoft Windows Vista X64 Version Details Vulnerabilities
29 OS Microsoft Windows Vista SP1 X64 Version Details Vulnerabilities
30 OS Microsoft Windows Vista SP2 X64 Version Details Vulnerabilities
31 OS Microsoft Windows Vista Version Details Vulnerabilities
32 OS Microsoft Windows Xp - SP2 X64 Version Details Vulnerabilities
33 OS Microsoft Windows Xp SP2 Version Details Vulnerabilities
34 OS Microsoft Windows Xp SP3 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Microsoft IE 12
Microsoft Windows 2000 1
Microsoft Windows 2003 Server 2
Microsoft Windows 7 2
Microsoft Windows Server 2003 2
Microsoft Windows Server 2008 6
Microsoft Windows Vista 6
Microsoft Windows Xp 3

- References For CVE-2010-0027

http://www.securityfocus.com/archive/1/archive/1/509470/100/0/threaded
BUGTRAQ 20100209 ZDI-10-016: Microsoft Windows ShellExecute Improper Sanitization Code Execution Vulnerability
http://www.zerodayinitiative.com/advisories/ZDI-10-016/
http://technet.microsoft.com/en-us/security/bulletin/ms10-007
Microsoft Security Bulletin MS10-007 Vulnerability in Windows Shell Handler Could Allow Remote Code Execution (975713) This security update resolves a privately reported vulnerability in Microsoft Windows 2000, Windows XP, and Windows Server 2003. Other versions of Windows are not impacted by this security update. The vulnerability could allow remote code execution if an application, such as a Web browser, passes specially crafted data to the ShellExecute API function through the Windows Shell Handler.
http://technet.microsoft.com/en-us/security/bulletin/ms10-002
Microsoft Security Bulletin MS10-002 Cumulative Security Update for Internet Explorer (978207) This security update resolves seven privately reported vulnerabilities and one publicly disclosed vulnerability in Internet Explorer. The more severe vulnerabilities could allow remote code execution if a user views a specially crafted Web page using Internet Explorer. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.
http://xforce.iss.net/xforce/xfdb/55773
XF ie-url-code-execution(55773)
http://www.us-cert.gov/cas/techalerts/TA10-040A.html
CERT TA10-040A

- Metasploit Modules Related To CVE-2010-0027

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.