CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-2993

The JavaScript for Acrobat API in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 does not properly implement the (1) Privileged Context and (2) Safe Path restrictions for unspecified JavaScript methods, which allows remote attackers to create arbitrary files, and possibly execute arbitrary code, via the cPath parameter in a crafted PDF file. NOTE: some of these details are obtained from third party information.
Publish Date : 2009-10-19 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 20

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical
6.8
AV:N/AC:M/Au:N/C:P/I:P/A:P 2009-10-13 2009-10-13
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Adobe Reader and Acrobat cause Multiple Vulnerabilities oval:org.mitre.oval:def:5822 windows
CVE-2009-2993 oval:org.opensuse.security:def:20092993 unix
ELSA-2009:1499: acroread security update (Critical) oval:org.mitre.oval:def:22955 unix
RHSA-2009:1499: acroread security update (Critical) oval:com.redhat.rhsa:def:20091499 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-2993

# Product Type Vendor Product Version Update Edition Language
1 Application Adobe Acrobat 7.0 Version Details Vulnerabilities
2 Application Adobe Acrobat 7.0.1 Version Details Vulnerabilities
3 Application Adobe Acrobat 7.0.2 Version Details Vulnerabilities
4 Application Adobe Acrobat 7.0.3 Version Details Vulnerabilities
5 Application Adobe Acrobat 7.0.4 Version Details Vulnerabilities
6 Application Adobe Acrobat 7.0.5 Version Details Vulnerabilities
7 Application Adobe Acrobat 7.0.6 Version Details Vulnerabilities
8 Application Adobe Acrobat 7.0.7 Version Details Vulnerabilities
9 Application Adobe Acrobat 7.0.8 Version Details Vulnerabilities
10 Application Adobe Acrobat 7.0.9 Version Details Vulnerabilities
11 Application Adobe Acrobat 7.1.0 Version Details Vulnerabilities
12 Application Adobe Acrobat 7.1.1 Version Details Vulnerabilities
13 Application Adobe Acrobat 7.1.3 Version Details Vulnerabilities
14 Application Adobe Acrobat 8.0.0 Version Details Vulnerabilities
15 Application Adobe Acrobat 8.1 Version Details Vulnerabilities
16 Application Adobe Acrobat 8.1.1 Version Details Vulnerabilities
17 Application Adobe Acrobat 8.1.2 Version Details Vulnerabilities
18 Application Adobe Acrobat 8.1.3 Version Details Vulnerabilities
19 Application Adobe Acrobat 8.1.4 Version Details Vulnerabilities
20 Application Adobe Acrobat 8.1.6 Version Details Vulnerabilities
21 Application Adobe Acrobat 9.0 Version Details Vulnerabilities
22 Application Adobe Acrobat 9.1.1 Version Details Vulnerabilities
23 Application Adobe Acrobat 9.1.2 Version Details Vulnerabilities
24 Application Adobe Acrobat 9.1.3 Version Details Vulnerabilities
25 Application Adobe Acrobat Reader 7.0 Version Details Vulnerabilities
26 Application Adobe Acrobat Reader 7.0.1 Version Details Vulnerabilities
27 Application Adobe Acrobat Reader 7.0.2 Version Details Vulnerabilities
28 Application Adobe Acrobat Reader 7.0.3 Version Details Vulnerabilities
29 Application Adobe Acrobat Reader 7.0.4 Version Details Vulnerabilities
30 Application Adobe Acrobat Reader 7.0.5 Version Details Vulnerabilities
31 Application Adobe Acrobat Reader 7.0.6 Version Details Vulnerabilities
32 Application Adobe Acrobat Reader 7.0.7 Version Details Vulnerabilities
33 Application Adobe Acrobat Reader 7.0.8 Version Details Vulnerabilities
34 Application Adobe Acrobat Reader 7.0.9 Version Details Vulnerabilities
35 Application Adobe Acrobat Reader 7.1.0 Version Details Vulnerabilities
36 Application Adobe Acrobat Reader 7.1.1 Version Details Vulnerabilities
37 Application Adobe Acrobat Reader 7.1.3 Version Details Vulnerabilities
38 Application Adobe Acrobat Reader 8.0 Version Details Vulnerabilities
39 Application Adobe Acrobat Reader 8.1 Version Details Vulnerabilities
40 Application Adobe Acrobat Reader 8.1.1 Version Details Vulnerabilities
41 Application Adobe Acrobat Reader 8.1.2 Version Details Vulnerabilities
42 Application Adobe Acrobat Reader 8.1.3 Version Details Vulnerabilities
43 Application Adobe Acrobat Reader 8.1.4 Version Details Vulnerabilities
44 Application Adobe Acrobat Reader 8.1.5 Version Details Vulnerabilities
45 Application Adobe Acrobat Reader 8.1.6 Version Details Vulnerabilities
46 Application Adobe Acrobat Reader 9.0 Version Details Vulnerabilities
47 Application Adobe Acrobat Reader 9.1 Version Details Vulnerabilities
48 Application Adobe Acrobat Reader 9.1.1 Version Details Vulnerabilities
49 Application Adobe Acrobat Reader 9.1.2 Version Details Vulnerabilities
50 Application Adobe Acrobat Reader 9.1.3 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Adobe Acrobat 24
Adobe Acrobat Reader 26

- References For CVE-2009-2993

http://www.adobe.com/support/security/bulletins/apsb09-15.html CONFIRM
http://securitytracker.com/id?1023007
SECTRACK 1023007
http://www.securityfocus.com/bid/36638
BID 36638 RETIRED: Adobe Reader and Acrobat October 2009 Multiple Remote Vulnerabilities Release Date:2009-10-14
http://www.securityfocus.com/bid/36664
BID 36664 Adobe Reader and Acrobat Multiple Input Validation Vulnerabilities Release Date:2009-10-26
http://www.vupen.com/english/advisories/2009/2898
VUPEN ADV-2009-2898
http://www.us-cert.gov/cas/techalerts/TA09-286B.html
CERT TA09-286B
http://www.kb.cert.org/vuls/id/257117
CERT-VN VU#257117

- Metasploit Modules Related To CVE-2009-2993

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.