CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-2048

Cross-site scripting (XSS) vulnerability in the Administration interface in Cisco Customer Response Solutions (CRS) before 7.0(1) SR2 in Cisco Unified Contact Center Express (aka CCX) server allows remote authenticated users to inject arbitrary web script or HTML into the CCX database via unspecified vectors.
Publish Date : 2009-07-16 Last Update Date : 2009-08-12
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
3.5
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Cross Site Scripting
CWE ID 79

- Products Affected By CVE-2009-2048

# Product Type Vendor Product Version Update Edition Language
1 Application Cisco CRS 3.5 Version Details Vulnerabilities
2 Application Cisco CRS 4.0 Version Details Vulnerabilities
3 Application Cisco CRS 4.1 Version Details Vulnerabilities
4 Application Cisco CRS 4.5 Version Details Vulnerabilities
5 Application Cisco CRS 5.0 Version Details Vulnerabilities
6 Application Cisco CRS 6.0 Version Details Vulnerabilities
7 Application Cisco CRS 7.0 Version Details Vulnerabilities
8 Application Cisco Customer Response Applications 3.5 Version Details Vulnerabilities
9 Application Cisco Ip Qm 3.5 Version Details Vulnerabilities
10 Application Cisco Unified Ccx 3.5 Version Details Vulnerabilities
11 Application Cisco Unified Ccx 4.0(5a) Version Details Vulnerabilities
12 Application Cisco Unified Ccx 4.0(5) Version Details Vulnerabilities
13 Application Cisco Unified Ccx 4.0(1) Version Details Vulnerabilities
14 Application Cisco Unified Ccx 4.0(4) Version Details Vulnerabilities
15 Application Cisco Unified Ccx 4.0(3) Version Details Vulnerabilities
16 Application Cisco Unified Ccx 4.5(1) Version Details Vulnerabilities
17 Application Cisco Unified Ccx 4.5(2) Version Details Vulnerabilities
18 Application Cisco Unified Ccx 5.0(1) Version Details Vulnerabilities
19 Application Cisco Unified Ccx 6.0(1) Version Details Vulnerabilities
20 Application Cisco Unified Ccx 7.0(1) Version Details Vulnerabilities
21 Application Cisco Unified Ip Contact Center Express 3.0 Version Details Vulnerabilities
22 Application Cisco Unified Ip Contact Center Express 5.0(1) Version Details Vulnerabilities
23 Application Cisco Unified Ip Contact Center Express 6.0(1) Version Details Vulnerabilities
24 Application Cisco Unified Ip Contact Center Express 7.0 Version Details Vulnerabilities
25 Application Cisco Unified Ip Ivr 3.0 Version Details Vulnerabilities
26 Application Cisco Unified Ip Ivr 3.1 Version Details Vulnerabilities
27 Application Cisco Unified Ip Ivr 4.0 Version Details Vulnerabilities
28 Application Cisco Unified Ip Ivr 4.1 Version Details Vulnerabilities
29 Application Cisco Unified Ip Ivr 4.5 Version Details Vulnerabilities
30 Application Cisco Unified Ip Ivr 5.0 Version Details Vulnerabilities
31 Application Cisco Unified Ip Ivr 6.0 Version Details Vulnerabilities
32 Application Cisco Unified Ip Ivr 7.0 Version Details Vulnerabilities
33 Application Cisco Unified Ip Ivr 7.0(1) Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Cisco CRS 7
Cisco Customer Response Applications 1
Cisco Ip Qm 1
Cisco Unified Ccx 11
Cisco Unified Ip Contact Center Express 4
Cisco Unified Ip Ivr 9

- References For CVE-2009-2048

http://osvdb.org/55937
OSVDB 55937
http://secunia.com/advisories/35861
SECUNIA 35861
http://www.securitytracker.com/id?1022569
SECTRACK 1022569
http://www.vupen.com/english/advisories/2009/1913
VUPEN ADV-2009-1913
http://xforce.iss.net/xforce/xfdb/51730
XF unified-ccx-interface-xss(51730)
http://www.securityfocus.com/bid/35705
BID 35705 Cisco Unified Contact Center Express (CCX) Arbitrary Script Injection Vulnerability Release Date:2009-07-15
http://www.cisco.com/en/US/products/products_security_advisory09186a0080ae04b2.shtml
CISCO 20090715 Vulnerabilities in Unified Contact Center Express Administration Pages

- Metasploit Modules Related To CVE-2009-2048

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.