CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-1956

Off-by-one error in the apr_brigade_vprintf function in Apache APR-util before 1.3.5 on big-endian platforms allows remote attackers to obtain sensitive information or cause a denial of service (application crash) via crafted input.
Publish Date : 2009-06-07 Last Update Date : 2013-10-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.4
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceObtain Information
CWE ID 189

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate
4.3
AV:N/AC:M/Au:N/C:P/I:N/A:N 2009-06-05 2009-04-24
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
APR-util off-by-one overflow oval:org.apache.httpd:def:20091956
CVE-2009-1956 oval:org.opensuse.security:def:20091956 unix
ELSA-2009:1107: apr-util security update (Moderate) oval:org.mitre.oval:def:22801 unix
HP-UX Apache-based Web Server, Local Information Disclosure, Increase of Privilege, Remote Denial of Service (DoS) oval:org.mitre.oval:def:12237 unix
Off-by-one error in the apr_brigade_vprintf function in Apache APR-util before 1.3.5 on big-endian platforms allows remo... oval:org.mitre.oval:def:11567 unix
RHSA-2009:1107: apr-util security update (Moderate) oval:com.redhat.rhsa:def:20091107 unix
RHSA-2009:1108: httpd security update (Moderate) oval:com.redhat.rhsa:def:20091108 unix
USN-786-1 -- apr-util vulnerabilities oval:org.mitre.oval:def:13719 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-1956

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Apr-util 0.9.1 Version Details Vulnerabilities
2 Application Apache Apr-util 0.9.2 Version Details Vulnerabilities
3 Application Apache Apr-util 0.9.3 Version Details Vulnerabilities
4 Application Apache Apr-util 0.9.4 Version Details Vulnerabilities
5 Application Apache Apr-util 0.9.5 Version Details Vulnerabilities
6 Application Apache Apr-util 1.0 Version Details Vulnerabilities
7 Application Apache Apr-util 1.0.1 Version Details Vulnerabilities
8 Application Apache Apr-util 1.0.2 Version Details Vulnerabilities
9 Application Apache Apr-util 1.1.0 Version Details Vulnerabilities
10 Application Apache Apr-util 1.1.1 Version Details Vulnerabilities
11 Application Apache Apr-util 1.1.2 Version Details Vulnerabilities
12 Application Apache Apr-util 1.2.1 Version Details Vulnerabilities
13 Application Apache Apr-util 1.2.2 Version Details Vulnerabilities
14 Application Apache Apr-util 1.2.6 Version Details Vulnerabilities
15 Application Apache Apr-util 1.2.7 Version Details Vulnerabilities
16 Application Apache Apr-util 1.2.8 Version Details Vulnerabilities
17 Application Apache Apr-util 1.3.0 Version Details Vulnerabilities
18 Application Apache Apr-util 1.3.1 Version Details Vulnerabilities
19 Application Apache Apr-util 1.3.2 Version Details Vulnerabilities
20 Application Apache Apr-util 1.3.3 Version Details Vulnerabilities
21 Application Apache Apr-util 1.3.4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Apr-util 21

- References For CVE-2009-1956

https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01173.html
FEDORA FEDORA-2009-6014
http://marc.info/?l=bugtraq&m=129190899612998&w=2
HP HPSBUX02612
http://lists.apple.com/archives/security-announce/2009/Nov/msg00000.html
APPLE APPLE-SA-2009-11-09-1
http://secunia.com/advisories/34724
SECUNIA 34724
http://secunia.com/advisories/35284
SECUNIA 35284
http://secunia.com/advisories/35565
SECUNIA 35565
http://secunia.com/advisories/35395
SECUNIA 35395
http://secunia.com/advisories/35487
SECUNIA 35487
http://secunia.com/advisories/35710
SECUNIA 35710
http://secunia.com/advisories/35797
SECUNIA 35797
http://secunia.com/advisories/35843
SECUNIA 35843
http://secunia.com/advisories/37221
SECUNIA 37221
http://security.gentoo.org/glsa/glsa-200907-03.xml
GENTOO GLSA-200907-03
http://support.apple.com/kb/HT3937 CONFIRM
http://www-01.ibm.com/support/docview.wss?uid=swg1PK99478
AIXAPAR PK99478
http://www-01.ibm.com/support/docview.wss?uid=swg1PK91241
AIXAPAR PK91241
http://www-01.ibm.com/support/docview.wss?uid=swg1PK88341
AIXAPAR PK88341
http://www-01.ibm.com/support/docview.wss?uid=swg27014463 CONFIRM
http://www.apache.org/dist/apr/CHANGES-APR-UTIL-1.3 CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2009:131
MANDRIVA MDVSA-2009:131
http://www.mail-archive.com/dev@apr.apache.org/msg21592.html
MLIST [dev] 20090424 Re: Buffer overflow in apr_brigade_vprintf() ?
http://www.mail-archive.com/dev@apr.apache.org/msg21591.html
MLIST [dev] 20090424 Buffer overflow in apr_brigade_vprintf() ?
http://www.oracle.com/technetwork/topics/security/cpuapr2013-1899555.html CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2013:150
MANDRIVA MDVSA-2013:150
http://www.redhat.com/support/errata/RHSA-2009-1107.html
REDHAT RHSA-2009:1107
http://www.redhat.com/support/errata/RHSA-2009-1108.html
REDHAT RHSA-2009:1108
http://www.vupen.com/english/advisories/2009/1907
VUPEN ADV-2009-1907
http://www.ubuntu.com/usn/usn-787-1
UBUNTU USN-787-1
http://www.ubuntu.com/usn/usn-786-1
UBUNTU USN-786-1
https://bugzilla.redhat.com/show_bug.cgi?id=504390 CONFIRM
http://www.openwall.com/lists/oss-security/2009/06/06/1
MLIST [oss-security] 20090605 CVE Request (apr-util)
http://www.securityfocus.com/bid/35251
BID 35251 Apache APR-util 'apr_brigade_vprintf' Off By One Vulnerability Release Date:2013-04-17
https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01228.html
FEDORA FEDORA-2009-5969
https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01201.html
FEDORA FEDORA-2009-6261
http://svn.apache.org/viewvc?view=rev&revision=768417 CONFIRM
http://www.vupen.com/english/advisories/2009/3184
VUPEN ADV-2009-3184

- Metasploit Modules Related To CVE-2009-1956

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.