CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-1891

The mod_deflate module in Apache httpd 2.2.11 and earlier compresses large files until completion even after the associated network connection is closed, which allows remote attackers to cause a denial of service (CPU consumption).
Publish Date : 2009-07-10 Last Update Date : 2011-09-06
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.1
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 399

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low
2.6
AV:N/AC:H/Au:N/C:N/I:N/A:P 2009-06-26 2009-06-26
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Apache 'mod_deflate' Connection State Denial Of Service Vulnerability oval:org.mitre.oval:def:8632 windows
CVE-2009-1891 oval:org.opensuse.security:def:20091891 unix
DSA-1834 apache2 -- denial of service oval:org.mitre.oval:def:7600 unix
DSA-1834-1 apache2 apache2-mpm-itk - denial of service oval:org.mitre.oval:def:19296 unix
DSA-1834-2 apache2 -- denial of service oval:org.mitre.oval:def:13769 unix
ELSA-2009:1148: httpd security update (Important) oval:org.mitre.oval:def:22875 unix
HP-UX Apache-based Web Server, Local Information Disclosure, Increase of Privilege, Remote Denial of Service (DoS) oval:org.mitre.oval:def:12361 unix
mod_deflate DoS oval:org.apache.httpd:def:20091891
RHSA-2009:1148: httpd security update (Important) oval:com.redhat.rhsa:def:20091148 unix
RHSA-2009:1205: httpd security and bug fix update (Moderate) oval:com.redhat.rhsa:def:20091205 unix
RHSA-2009:1580: httpd security update (Moderate) oval:com.redhat.rhsa:def:20091580 unix
The mod_deflate module in Apache httpd 2.2.11 and earlier compresses large files until completion even after the associa... oval:org.mitre.oval:def:9248 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-1891

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Http Server 0.8.11 Version Details Vulnerabilities
2 Application Apache Http Server 0.8.14 Version Details Vulnerabilities
3 Application Apache Http Server 1.0.2 Version Details Vulnerabilities
4 Application Apache Http Server 1.0.3 Version Details Vulnerabilities
5 Application Apache Http Server 1.0.5 Version Details Vulnerabilities
6 Application Apache Http Server 1.1 Version Details Vulnerabilities
7 Application Apache Http Server 1.1.1 Version Details Vulnerabilities
8 Application Apache Http Server 1.2 Version Details Vulnerabilities
9 Application Apache Http Server 1.2.4 Version Details Vulnerabilities
10 Application Apache Http Server 1.2.9 Version Details Vulnerabilities
11 Application Apache Http Server 1.3.3 Version Details Vulnerabilities
12 Application Apache Http Server 1.3.6 Version Details Vulnerabilities
13 Application Apache Http Server 1.3.7 Version Details Vulnerabilities
14 Application Apache Http Server 1.3.9 Version Details Vulnerabilities
15 Application Apache Http Server 1.3.13 Version Details Vulnerabilities
16 Application Apache Http Server 1.3.14 Version Details Vulnerabilities
17 Application Apache Http Server 1.3.18 Version Details Vulnerabilities
18 Application Apache Http Server 1.3.19 Version Details Vulnerabilities
19 Application Apache Http Server 1.3.20 Version Details Vulnerabilities
20 Application Apache Http Server 1.3.22 Version Details Vulnerabilities
21 Application Apache Http Server 1.3.23 Version Details Vulnerabilities
22 Application Apache Http Server 1.3.27 Version Details Vulnerabilities
23 Application Apache Http Server 1.3.29 Version Details Vulnerabilities
24 Application Apache Http Server 1.3.31 Version Details Vulnerabilities
25 Application Apache Http Server 1.3.33 Version Details Vulnerabilities
26 Application Apache Http Server 1.3.38 Version Details Vulnerabilities
27 Application Apache Http Server 1.99 Version Details Vulnerabilities
28 Application Apache Http Server 2.0.9 Version Details Vulnerabilities
29 Application Apache Http Server 2.0.28 Version Details Vulnerabilities
30 Application Apache Http Server 2.0.34 Beta Version Details Vulnerabilities
31 Application Apache Http Server 2.0.38 Version Details Vulnerabilities
32 Application Apache Http Server 2.0.39 Version Details Vulnerabilities
33 Application Apache Http Server 2.0.40 Version Details Vulnerabilities
34 Application Apache Http Server 2.0.41 Version Details Vulnerabilities
35 Application Apache Http Server 2.0.42 Version Details Vulnerabilities
36 Application Apache Http Server 2.0.45 Version Details Vulnerabilities
37 Application Apache Http Server 2.0.46 Version Details Vulnerabilities
38 Application Apache Http Server 2.0.47 Version Details Vulnerabilities
39 Application Apache Http Server 2.0.48 Version Details Vulnerabilities
40 Application Apache Http Server 2.0.49 Version Details Vulnerabilities
41 Application Apache Http Server 2.0.50 Version Details Vulnerabilities
42 Application Apache Http Server 2.0.51 Version Details Vulnerabilities
43 Application Apache Http Server 2.0.52 Version Details Vulnerabilities
44 Application Apache Http Server 2.0.53 Version Details Vulnerabilities
45 Application Apache Http Server 2.0.54 Version Details Vulnerabilities
46 Application Apache Http Server 2.0.55 Version Details Vulnerabilities
47 Application Apache Http Server 2.0.56 Version Details Vulnerabilities
48 Application Apache Http Server 2.0.57 Version Details Vulnerabilities
49 Application Apache Http Server 2.0.58 Version Details Vulnerabilities
50 Application Apache Http Server 2.0.59 Version Details Vulnerabilities
51 Application Apache Http Server 2.0.60 Version Details Vulnerabilities
52 Application Apache Http Server 2.0.61 Version Details Vulnerabilities
53 Application Apache Http Server 2.1 Version Details Vulnerabilities
54 Application Apache Http Server 2.1.1 Version Details Vulnerabilities
55 Application Apache Http Server 2.1.2 Version Details Vulnerabilities
56 Application Apache Http Server 2.1.3 Version Details Vulnerabilities
57 Application Apache Http Server 2.1.4 Version Details Vulnerabilities
58 Application Apache Http Server 2.1.5 Version Details Vulnerabilities
59 Application Apache Http Server 2.1.6 Version Details Vulnerabilities
60 Application Apache Http Server 2.1.7 Version Details Vulnerabilities
61 Application Apache Http Server 2.1.8 Version Details Vulnerabilities
62 Application Apache Http Server 2.1.9 Version Details Vulnerabilities
63 Application Apache Http Server 2.2 Version Details Vulnerabilities
64 Application Apache Http Server 2.2.0 Version Details Vulnerabilities
65 Application Apache Http Server 2.2.1 Version Details Vulnerabilities
66 Application Apache Http Server 2.2.2 Version Details Vulnerabilities
67 Application Apache Http Server 2.2.3 Version Details Vulnerabilities
68 Application Apache Http Server 2.2.4 Version Details Vulnerabilities
69 Application Apache Http Server 2.2.5 Version Details Vulnerabilities
70 Application Apache Http Server 2.2.6 Version Details Vulnerabilities
71 Application Apache Http Server 2.2.7 Version Details Vulnerabilities
72 Application Apache Http Server 2.2.8 Version Details Vulnerabilities
73 Application Apache Http Server 2.2.9 Version Details Vulnerabilities
74 Application Apache Http Server 2.2.10 Version Details Vulnerabilities
75 Application Apache Http Server 2.2.11 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Http Server 75

- References For CVE-2009-1891

http://marc.info/?l=bugtraq&m=129190899612998&w=2
HP HPSBUX02612
http://marc.info/?l=apache-httpd-dev&m=124661528519546&w=2
MLIST [apache-httpd-dev] 20090703 Re: mod_deflate DoS
http://marc.info/?l=apache-httpd-dev&m=124621326524824&w=2
MLIST [apache-httpd-dev] 20090628 mod_deflate DoS
http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00006.html
SUSE SUSE-SA:2009:050
http://lists.apple.com/archives/security-announce/2009/Nov/msg00000.html
APPLE APPLE-SA-2009-11-09-1
http://marc.info/?l=bugtraq&m=130497311408250&w=2
HP HPSBOV02683
http://osvdb.org/55782
OSVDB 55782
http://secunia.com/advisories/35721
SECUNIA 35721
http://secunia.com/advisories/35781
SECUNIA 35781
http://secunia.com/advisories/35793
SECUNIA 35793
http://support.apple.com/kb/HT3937 CONFIRM
http://security.gentoo.org/glsa/glsa-200907-04.xml
GENTOO GLSA-200907-04
http://secunia.com/advisories/37152
SECUNIA 37152
http://secunia.com/advisories/35865
SECUNIA 35865
http://secunia.com/advisories/37221
SECUNIA 37221
http://wiki.rpath.com/Advisories:rPSA-2009-0142 CONFIRM
http://wiki.rpath.com/wiki/Advisories:rPSA-2009-0142 CONFIRM
http://www.debian.org/security/2009/dsa-1834
DEBIAN DSA-1834
http://www-01.ibm.com/support/docview.wss?uid=swg1PK99480
AIXAPAR PK99480
http://www-01.ibm.com/support/docview.wss?uid=swg1PK91361
AIXAPAR PK91361
http://www.securityfocus.com/archive/1/archive/1/507857/100/0/threaded
BUGTRAQ 20091113 rPSA-2009-0142-2 httpd mod_ssl
http://www.ubuntu.com/usn/USN-802-1
UBUNTU USN-802-1
http://www.securitytracker.com/id?1022529
SECTRACK 1022529
http://www.redhat.com/support/errata/RHSA-2009-1156.html
REDHAT RHSA-2009:1156
http://www.mandriva.com/security/advisories?name=MDVSA-2009:149
MANDRIVA MDVSA-2009:149
https://www.redhat.com/archives/fedora-package-announce/2009-August/msg01363.html
FEDORA FEDORA-2009-8812
http://www.vupen.com/english/advisories/2009/1841
VUPEN ADV-2009-1841
http://www.vupen.com/english/advisories/2009/3184
VUPEN ADV-2009-3184
https://bugzilla.redhat.com/show_bug.cgi?id=509125 CONFIRM
https://rhn.redhat.com/errata/RHSA-2009-1148.html
REDHAT RHSA-2009:1148
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=534712

- Metasploit Modules Related To CVE-2009-1891

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.