CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-0177

vmwarebase.dll, as used in the vmware-authd service (aka vmware-authd.exe), in VMware Workstation 6.5.1 build 126130, 6.5.1 and earlier; VMware Player 2.5.1 build 126130, 2.5.1 and earlier; VMware ACE 2.5.1 and earlier; VMware Server 2.0.x before 2.0.1 build 156745; and VMware Fusion before 2.0.2 build 147997 allows remote attackers to cause a denial of service (daemon crash) via a long (1) USER or (2) PASS command.
Publish Date : 2009-01-20 Last Update Date : 2011-03-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 399

- Related OVAL Definitions

Title Definition Id Class Family
VMware authd Service Lets Remote Users Deny Service oval:org.mitre.oval:def:6433 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-0177

# Product Type Vendor Product Version Update Edition Language
1 Application Vmware ACE 2.5.0 Version Details Vulnerabilities
2 Application Vmware ACE 2.5.1 Version Details Vulnerabilities
3 Application Vmware Fusion 2.0.1 Version Details Vulnerabilities
4 Application Vmware Server 2.0.0 Version Details Vulnerabilities
5 Application Vmware Vmware Player 1.0.0 Version Details Vulnerabilities
6 Application Vmware Vmware Player 1.0.1 Version Details Vulnerabilities
7 Application Vmware Vmware Player 1.0.2 Version Details Vulnerabilities
8 Application Vmware Vmware Player 1.0.3 Version Details Vulnerabilities
9 Application Vmware Vmware Player 1.0.4 Version Details Vulnerabilities
10 Application Vmware Vmware Player 1.0.6 Version Details Vulnerabilities
11 Application Vmware Vmware Player 1.0.7 Version Details Vulnerabilities
12 Application Vmware Vmware Player 1.0.8 Version Details Vulnerabilities
13 Application Vmware Vmware Player 1.0.9 Version Details Vulnerabilities
14 Application Vmware Vmware Player 1.05 Version Details Vulnerabilities
15 Application Vmware Vmware Player 2.0 Version Details Vulnerabilities
16 Application Vmware Vmware Player 2.0.1 Version Details Vulnerabilities
17 Application Vmware Vmware Player 2.0.2 Version Details Vulnerabilities
18 Application Vmware Vmware Player 2.0.3 Version Details Vulnerabilities
19 Application Vmware Vmware Player 2.0.4 Version Details Vulnerabilities
20 Application Vmware Vmware Player 2.0.5 Version Details Vulnerabilities
21 Application Vmware Vmware Player 2.5 Version Details Vulnerabilities
22 Application Vmware Vmware Player 2.5.1 Version Details Vulnerabilities
23 Application Vmware Vmware Workstation 4.5.3 Version Details Vulnerabilities
24 Application Vmware Vmware Workstation 5.0 Version Details Vulnerabilities
25 Application Vmware Vmware Workstation 5.5.0 Version Details Vulnerabilities
26 Application Vmware Vmware Workstation 5.5.1 Version Details Vulnerabilities
27 Application Vmware Vmware Workstation 5.5.2 Version Details Vulnerabilities
28 Application Vmware Vmware Workstation 5.5.3 Version Details Vulnerabilities
29 Application Vmware Vmware Workstation 5.5.4 Version Details Vulnerabilities
30 Application Vmware Vmware Workstation 5.5.5 Version Details Vulnerabilities
31 Application Vmware Vmware Workstation 5.5.6 Version Details Vulnerabilities
32 Application Vmware Vmware Workstation 5.5.7 Version Details Vulnerabilities
33 Application Vmware Vmware Workstation 5.5.8 Version Details Vulnerabilities
34 Application Vmware Vmware Workstation 6.0 Version Details Vulnerabilities
35 Application Vmware Vmware Workstation 6.0.1 Version Details Vulnerabilities
36 Application Vmware Vmware Workstation 6.0.2 Version Details Vulnerabilities
37 Application Vmware Vmware Workstation 6.0.3 Version Details Vulnerabilities
38 Application Vmware Vmware Workstation 6.0.4 Version Details Vulnerabilities
39 Application Vmware Vmware Workstation 6.0.5 Version Details Vulnerabilities
40 Application Vmware Vmware Workstation 6.5 Version Details Vulnerabilities
41 Application Vmware Vmware Workstation 6.51 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Vmware ACE 2
Vmware Fusion 1
Vmware Server 1
Vmware Vmware Player 18
Vmware Vmware Workstation 19

- References For CVE-2009-0177

http://milw0rm.com/exploits/7647
MILW0RM 7647
http://seclists.org/fulldisclosure/2009/Apr/0036.html
FULLDISC 20090403 VMSA-2009-0005 VMware Hosted products, VI Client and patches for ESX and ESXi resolve multiple security issues
http://lists.vmware.com/pipermail/security-announce/2009/000054.html
MLIST [security-announce] 20090403 VMSA-2009-0005 VMware Hosted products, VI Client and patches for ESX and ESXi resolve multiple security issues
http://osvdb.org/51180
OSVDB 51180
http://secunia.com/advisories/33372
SECUNIA 33372
http://secunia.com/advisories/34601
SECUNIA 34601
http://www.securityfocus.com/bid/34373
BID 34373 VMware Hosted Products VMSA-2009-0005 Multiple Remote Vulnerabilities Release Date:2012-10-01
http://www.vupen.com/english/advisories/2009/0024
VUPEN ADV-2009-0024
http://www.securitytracker.com/id?1021512
SECTRACK 1021512
http://www.vupen.com/english/advisories/2009/0944
VUPEN ADV-2009-0944
http://www.vmware.com/security/advisories/VMSA-2009-0005.html CONFIRM

- Metasploit Modules Related To CVE-2009-0177

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.