CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2009-0021

NTP 4.2.4 before 4.2.4p5 and 4.2.5 before 4.2.5p150 does not properly check the return value from the OpenSSL EVP_VerifyFinal function, which allows remote attackers to bypass validation of the certificate chain via a malformed SSL/TLS signature for DSA and ECDSA keys, a similar vulnerability to CVE-2008-5077.
Publish Date : 2009-01-07 Last Update Date : 2012-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Bypass a restriction or similar
CWE ID 287

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate
4.3
AV:N/AC:M/Au:N/C:P/I:N/A:N 2008-12-16 2009-01-07
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2009-0021 oval:org.opensuse.security:def:20090021 unix
DSA-1702 ntp -- interpretation conflict oval:org.mitre.oval:def:7079 unix
DSA-1702-1 ntp -- interpretation conflict oval:org.mitre.oval:def:13252 unix
ELSA-2009:0046: ntp security update (Moderate) oval:org.mitre.oval:def:22471 unix
NTP 4.2.4 before 4.2.4p5 and 4.2.5 before 4.2.5p150 does not properly check the return value from the OpenSSL EVP_Verify... oval:org.mitre.oval:def:10035 unix
RHSA-2009:0046 -- ntp security update (Moderate) oval:org.mitre.oval:def:28923 unix
RHSA-2009:0046: ntp security update (Moderate) oval:com.redhat.rhsa:def:20090046 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2009-0021

# Product Type Vendor Product Version Update Edition Language
1 Application NTP NTP 4.2.0 Version Details Vulnerabilities
2 Application NTP NTP 4.2.2 Version Details Vulnerabilities
3 Application NTP NTP 4.2.4p2 Version Details Vulnerabilities
4 Application NTP NTP 4.2.4p3 Version Details Vulnerabilities
5 Application NTP NTP 4.2.4p4 Version Details Vulnerabilities
6 Application NTP NTP 4.2.4p1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
NTP NTP 6

- References For CVE-2009-0021

http://lists.apple.com/archives/security-announce/2009/May/msg00002.html
APPLE APPLE-SA-2009-05-12
http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00000.html
SUSE SUSE-SR:2009:005
https://lists.ntp.org/pipermail/announce/2009-January/000055.html
MLIST [announce] 20090108 NTP 4.2.4p6 Released
http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00003.html
SUSE SUSE-SR:2009:008
http://secunia.com/advisories/33406
SECUNIA 33406
http://www.securityfocus.com/archive/1/archive/1/499827/100/0/threaded
BUGTRAQ 20090107 [oCERT-2008-016] Multiple OpenSSL signature verification API misuses
http://secunia.com/advisories/33558
SECUNIA 33558
http://secunia.com/advisories/33648
SECUNIA 33648
http://secunia.com/advisories/35074
SECUNIA 35074
http://secunia.com/advisories/34642
SECUNIA 34642
http://slackware.com/security/viewer.php?l=slackware-security&y=2009&m=slackware-security.531177
SLACKWARE SSA:2009-014-03
http://support.apple.com/kb/HT3549 CONFIRM
http://www.ocert.org/advisories/ocert-2008-016.html
http://www.redhat.com/support/errata/RHSA-2009-0046.html
REDHAT RHSA-2009:0046
http://www.securitytracker.com/id?1021533
SECTRACK 1021533
http://www.vupen.com/english/advisories/2009/0042
VUPEN ADV-2009-0042
http://www.vupen.com/english/advisories/2009/1297
VUPEN ADV-2009-1297
http://www.us-cert.gov/cas/techalerts/TA09-133A.html
CERT TA09-133A

- Metasploit Modules Related To CVE-2009-0021

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.