CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-4917

Unspecified vulnerability in VMware Workstation 5.5.8 and earlier, and 6.0.5 and earlier 6.x versions; VMware Player 1.0.8 and earlier, and 2.0.5 and earlier 2.x versions; VMware Server 1.0.9 and earlier; VMware ESXi 3.5; and VMware ESX 3.0.2 through 3.5 allows guest OS users to have an unknown impact by sending the virtual hardware a request that triggers an arbitrary physical-memory write operation, leading to memory corruption.
Publish Date : 2008-12-08 Last Update Date : 2013-05-14
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Memory corruption
CWE ID 399

- Related OVAL Definitions

Title Definition Id Class Family
VMware ESX Virtual Hardware Memory Access Bug Lets Local Users Gain Elevated Privileges oval:org.mitre.oval:def:6246 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-4917

# Product Type Vendor Product Version Update Edition Language
1 Application Vmware ESX 3.0.2 Version Details Vulnerabilities
2 Application Vmware ESX 3.0.3 Version Details Vulnerabilities
3 Application Vmware ESX 3.5 Version Details Vulnerabilities
4 Application Vmware Esxi 3.5 Version Details Vulnerabilities
5 Application Vmware Player 1.0 Version Details Vulnerabilities
6 Application Vmware Player 1.0.0 Version Details Vulnerabilities
7 Application Vmware Player 1.0.1 Version Details Vulnerabilities
8 Application Vmware Player 1.0.2 Version Details Vulnerabilities
9 Application Vmware Player 1.0.3 Version Details Vulnerabilities
10 Application Vmware Player 1.0.4 Version Details Vulnerabilities
11 Application Vmware Player 1.0.5 Version Details Vulnerabilities
12 Application Vmware Player 1.0.6 Version Details Vulnerabilities
13 Application Vmware Player 1.0.7 Version Details Vulnerabilities
14 Application Vmware Player 1.0.8 Version Details Vulnerabilities
15 Application Vmware Player 2.0 Version Details Vulnerabilities
16 Application Vmware Player 2.0.1 Version Details Vulnerabilities
17 Application Vmware Player 2.0.2 Version Details Vulnerabilities
18 Application Vmware Player 2.0.3 Version Details Vulnerabilities
19 Application Vmware Player 2.0.4 Version Details Vulnerabilities
20 Application Vmware Player 2.0.5 Version Details Vulnerabilities
21 Application Vmware Server 1.0 Version Details Vulnerabilities
22 Application Vmware Server 1.0.1 Version Details Vulnerabilities
23 Application Vmware Server 1.0.2 Version Details Vulnerabilities
24 Application Vmware Server 1.0.3 Version Details Vulnerabilities
25 Application Vmware Server 1.0.4 Version Details Vulnerabilities
26 Application Vmware Server 1.0.5 Version Details Vulnerabilities
27 Application Vmware Server 1.0.6 Version Details Vulnerabilities
28 Application Vmware Server 1.0.7 Version Details Vulnerabilities
29 Application Vmware Server 1.0.8 Version Details Vulnerabilities
30 Application Vmware Server 1.0.9 Version Details Vulnerabilities
31 Application Vmware Vmware Workstation 5.0 Version Details Vulnerabilities
32 Application Vmware Vmware Workstation 5.5.0 Version Details Vulnerabilities
33 Application Vmware Vmware Workstation 5.5.1 Version Details Vulnerabilities
34 Application Vmware Vmware Workstation 5.5.2 Version Details Vulnerabilities
35 Application Vmware Vmware Workstation 5.5.3 Version Details Vulnerabilities
36 Application Vmware Vmware Workstation 5.5.4 Version Details Vulnerabilities
37 Application Vmware Vmware Workstation 5.5.5 Version Details Vulnerabilities
38 Application Vmware Vmware Workstation 5.5.6 Version Details Vulnerabilities
39 Application Vmware Vmware Workstation 5.5.7 Version Details Vulnerabilities
40 Application Vmware Vmware Workstation 6.0.1 Version Details Vulnerabilities
41 Application Vmware Vmware Workstation 6.0.2 Version Details Vulnerabilities
42 Application Vmware Vmware Workstation 6.0.3 Version Details Vulnerabilities
43 Application Vmware Vmware Workstation 6.0.4 Version Details Vulnerabilities
44 Application Vmware Vmware Workstation 6.0.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Vmware ESX 3
Vmware Esxi 1
Vmware Player 16
Vmware Server 10
Vmware Vmware Workstation 14

- References For CVE-2008-4917

http://kb.vmware.com/kb/1006986 CONFIRM
http://security.gentoo.org/glsa/glsa-201209-25.xml
GENTOO GLSA-201209-25
http://securitytracker.com/id?1021301
SECTRACK 1021301
http://securitytracker.com/id?1021300
SECTRACK 1021300
http://secunia.com/advisories/32965
SECUNIA 32965
http://kb.vmware.com/kb/1006980 CONFIRM
http://www.securityfocus.com/bid/32597
BID 32597 VMware Products Unspecified Host Memory Corruption Vulnerability Release Date:2012-10-01
http://www.securityfocus.com/archive/1/archive/1/498886/100/0/threaded
BUGTRAQ 20081203 Re: VMSA-2008-0019 VMware Hosted products and patches for ESX and ESXi resolve a critical security issue and update bzip2
http://www.securityfocus.com/archive/1/archive/1/498863/100/0/threaded
BUGTRAQ 20081203 VMSA-2008-0019 VMware Hosted products and patches for ESX and ESXi resolve a critical security issue and update bzip2

- Metasploit Modules Related To CVE-2008-4917

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.