CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-4326

The PMA_escapeJsString function in libraries/js_escape.lib.php in phpMyAdmin before 2.11.9.2, when Internet Explorer is used, allows remote attackers to bypass cross-site scripting (XSS) protection mechanisms and conduct XSS attacks via a NUL byte inside a "</script" sequence.
Publish Date : 2008-09-30 Last Update Date : 2009-08-25
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Cross Site ScriptingBypass a restriction or similar
CWE ID 79

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-4326 oval:org.opensuse.security:def:20084326 unix
DSA-1675 phpmyadmin -- insufficient input sanitising oval:org.mitre.oval:def:8223 unix
DSA-1675-1 phpmyadmin - cross site scripting oval:org.mitre.oval:def:19750 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-4326

# Product Type Vendor Product Version Update Edition Language
1 Application Phpmyadmin Phpmyadmin 2.0 Version Details Vulnerabilities
2 Application Phpmyadmin Phpmyadmin 2.0.0 Version Details Vulnerabilities
3 Application Phpmyadmin Phpmyadmin 2.0.1 Version Details Vulnerabilities
4 Application Phpmyadmin Phpmyadmin 2.0.2 Version Details Vulnerabilities
5 Application Phpmyadmin Phpmyadmin 2.0.3 Version Details Vulnerabilities
6 Application Phpmyadmin Phpmyadmin 2.0.4 Version Details Vulnerabilities
7 Application Phpmyadmin Phpmyadmin 2.0.5 Version Details Vulnerabilities
8 Application Phpmyadmin Phpmyadmin 2.1 Version Details Vulnerabilities
9 Application Phpmyadmin Phpmyadmin 2.1.0 Version Details Vulnerabilities
10 Application Phpmyadmin Phpmyadmin 2.1.1 Version Details Vulnerabilities
11 Application Phpmyadmin Phpmyadmin 2.1.2 Version Details Vulnerabilities
12 Application Phpmyadmin Phpmyadmin 2.2 Pre1 Version Details Vulnerabilities
13 Application Phpmyadmin Phpmyadmin 2.2 Rc2 Version Details Vulnerabilities
14 Application Phpmyadmin Phpmyadmin 2.2 Version Details Vulnerabilities
15 Application Phpmyadmin Phpmyadmin 2.2 Rc1 Version Details Vulnerabilities
16 Application Phpmyadmin Phpmyadmin 2.2 Pre2 Version Details Vulnerabilities
17 Application Phpmyadmin Phpmyadmin 2.2 Rc3 Version Details Vulnerabilities
18 Application Phpmyadmin Phpmyadmin 2.2.0 Rc3 Version Details Vulnerabilities
19 Application Phpmyadmin Phpmyadmin 2.2.0 Pre2 Version Details Vulnerabilities
20 Application Phpmyadmin Phpmyadmin 2.2.0 Rc1 Version Details Vulnerabilities
21 Application Phpmyadmin Phpmyadmin 2.2.0 Rc2 Version Details Vulnerabilities
22 Application Phpmyadmin Phpmyadmin 2.2.0 Version Details Vulnerabilities
23 Application Phpmyadmin Phpmyadmin 2.2.0 Pre1 Version Details Vulnerabilities
24 Application Phpmyadmin Phpmyadmin 2.2.2 Version Details Vulnerabilities
25 Application Phpmyadmin Phpmyadmin 2.2.3 Version Details Vulnerabilities
26 Application Phpmyadmin Phpmyadmin 2.2.4 Version Details Vulnerabilities
27 Application Phpmyadmin Phpmyadmin 2.2.5 Version Details Vulnerabilities
28 Application Phpmyadmin Phpmyadmin 2.2.6 Version Details Vulnerabilities
29 Application Phpmyadmin Phpmyadmin 2.2.7 Pl1 Version Details Vulnerabilities
30 Application Phpmyadmin Phpmyadmin 2.3.1 Version Details Vulnerabilities
31 Application Phpmyadmin Phpmyadmin 2.3.2 Version Details Vulnerabilities
32 Application Phpmyadmin Phpmyadmin 2.4.0 Version Details Vulnerabilities
33 Application Phpmyadmin Phpmyadmin 2.5.0 Version Details Vulnerabilities
34 Application Phpmyadmin Phpmyadmin 2.5.1 Version Details Vulnerabilities
35 Application Phpmyadmin Phpmyadmin 2.5.2 Pl1 Version Details Vulnerabilities
36 Application Phpmyadmin Phpmyadmin 2.5.2 Version Details Vulnerabilities
37 Application Phpmyadmin Phpmyadmin 2.5.3 Version Details Vulnerabilities
38 Application Phpmyadmin Phpmyadmin 2.5.4 Version Details Vulnerabilities
39 Application Phpmyadmin Phpmyadmin 2.5.5 Rc2 Version Details Vulnerabilities
40 Application Phpmyadmin Phpmyadmin 2.5.5 Rc1 Version Details Vulnerabilities
41 Application Phpmyadmin Phpmyadmin 2.5.5 Pl1 Version Details Vulnerabilities
42 Application Phpmyadmin Phpmyadmin 2.5.5 Version Details Vulnerabilities
43 Application Phpmyadmin Phpmyadmin 2.5.6 Rc2 Version Details Vulnerabilities
44 Application Phpmyadmin Phpmyadmin 2.5.6 Rc1 Version Details Vulnerabilities
45 Application Phpmyadmin Phpmyadmin 2.5.7 Pl1 Version Details Vulnerabilities
46 Application Phpmyadmin Phpmyadmin 2.5.7 Version Details Vulnerabilities
47 Application Phpmyadmin Phpmyadmin 2.6.0 Pl3 Version Details Vulnerabilities
48 Application Phpmyadmin Phpmyadmin 2.6.0 Pl2 Version Details Vulnerabilities
49 Application Phpmyadmin Phpmyadmin 2.6.0 Pl1 Version Details Vulnerabilities
50 Application Phpmyadmin Phpmyadmin 2.6.1 Rc1 Version Details Vulnerabilities
51 Application Phpmyadmin Phpmyadmin 2.6.1 Pl3 Version Details Vulnerabilities
52 Application Phpmyadmin Phpmyadmin 2.6.1 Pl1 Version Details Vulnerabilities
53 Application Phpmyadmin Phpmyadmin 2.6.1 Version Details Vulnerabilities
54 Application Phpmyadmin Phpmyadmin 2.6.2 Dev Version Details Vulnerabilities
55 Application Phpmyadmin Phpmyadmin 2.6.2 Pl1 Version Details Vulnerabilities
56 Application Phpmyadmin Phpmyadmin 2.6.2 Rc1 Version Details Vulnerabilities
57 Application Phpmyadmin Phpmyadmin 2.6.2 Version Details Vulnerabilities
58 Application Phpmyadmin Phpmyadmin 2.6.3 Version Details Vulnerabilities
59 Application Phpmyadmin Phpmyadmin 2.6.3 Pl1 Version Details Vulnerabilities
60 Application Phpmyadmin Phpmyadmin 2.6.4 Pl3 Version Details Vulnerabilities
61 Application Phpmyadmin Phpmyadmin 2.6.4 Version Details Vulnerabilities
62 Application Phpmyadmin Phpmyadmin 2.6.4 Pl1 Version Details Vulnerabilities
63 Application Phpmyadmin Phpmyadmin 2.6.4 Pl4 Version Details Vulnerabilities
64 Application Phpmyadmin Phpmyadmin 2.6.4 Rc1 Version Details Vulnerabilities
65 Application Phpmyadmin Phpmyadmin 2.6.4 Pl2 Version Details Vulnerabilities
66 Application Phpmyadmin Phpmyadmin 2.7 Pl1 Version Details Vulnerabilities
67 Application Phpmyadmin Phpmyadmin 2.7 Version Details Vulnerabilities
68 Application Phpmyadmin Phpmyadmin 2.7.0 Beta1 Version Details Vulnerabilities
69 Application Phpmyadmin Phpmyadmin 2.7.0 Pl2 Version Details Vulnerabilities
70 Application Phpmyadmin Phpmyadmin 2.7.0 Version Details Vulnerabilities
71 Application Phpmyadmin Phpmyadmin 2.7.0 Pl1 Version Details Vulnerabilities
72 Application Phpmyadmin Phpmyadmin 2.7.0 Rc1 Version Details Vulnerabilities
73 Application Phpmyadmin Phpmyadmin 2.8.0 Version Details Vulnerabilities
74 Application Phpmyadmin Phpmyadmin 2.8.0.1 Version Details Vulnerabilities
75 Application Phpmyadmin Phpmyadmin 2.8.0.2 Version Details Vulnerabilities
76 Application Phpmyadmin Phpmyadmin 2.8.0.3 Version Details Vulnerabilities
77 Application Phpmyadmin Phpmyadmin 2.8.1 Dev Version Details Vulnerabilities
78 Application Phpmyadmin Phpmyadmin 2.8.1 Version Details Vulnerabilities
79 Application Phpmyadmin Phpmyadmin 2.8.2 Version Details Vulnerabilities
80 Application Phpmyadmin Phpmyadmin 2.8.3 Version Details Vulnerabilities
81 Application Phpmyadmin Phpmyadmin 2.8.4 Version Details Vulnerabilities
82 Application Phpmyadmin Phpmyadmin 2.9 Rc1 Version Details Vulnerabilities
83 Application Phpmyadmin Phpmyadmin 2.9 Version Details Vulnerabilities
84 Application Phpmyadmin Phpmyadmin 2.9.0 Rc1 Version Details Vulnerabilities
85 Application Phpmyadmin Phpmyadmin 2.9.0 Beta1 Version Details Vulnerabilities
86 Application Phpmyadmin Phpmyadmin 2.9.0 Version Details Vulnerabilities
87 Application Phpmyadmin Phpmyadmin 2.9.0 Dev Version Details Vulnerabilities
88 Application Phpmyadmin Phpmyadmin 2.9.0.1 Version Details Vulnerabilities
89 Application Phpmyadmin Phpmyadmin 2.9.0.2 Version Details Vulnerabilities
90 Application Phpmyadmin Phpmyadmin 2.9.0.3 Version Details Vulnerabilities
91 Application Phpmyadmin Phpmyadmin 2.9.1 Version Details Vulnerabilities
92 Application Phpmyadmin Phpmyadmin 2.9.1 Rc1 Version Details Vulnerabilities
93 Application Phpmyadmin Phpmyadmin 2.9.1 Rc2 Version Details Vulnerabilities
94 Application Phpmyadmin Phpmyadmin 2.9.1.1 Version Details Vulnerabilities
95 Application Phpmyadmin Phpmyadmin 2.9.2 Version Details Vulnerabilities
96 Application Phpmyadmin Phpmyadmin 2.10.0 Version Details Vulnerabilities
97 Application Phpmyadmin Phpmyadmin 2.10.0.0 Version Details Vulnerabilities
98 Application Phpmyadmin Phpmyadmin 2.10.0.1 Version Details Vulnerabilities
99 Application Phpmyadmin Phpmyadmin 2.10.0.2 Version Details Vulnerabilities
100 Application Phpmyadmin Phpmyadmin 2.10.1 Version Details Vulnerabilities
101 Application Phpmyadmin Phpmyadmin 2.10.01 Version Details Vulnerabilities
102 Application Phpmyadmin Phpmyadmin 2.10.1.0 Version Details Vulnerabilities
103 Application Phpmyadmin Phpmyadmin 2.10.2 Version Details Vulnerabilities
104 Application Phpmyadmin Phpmyadmin 2.10.2.0 Version Details Vulnerabilities
105 Application Phpmyadmin Phpmyadmin 2.10.3 Version Details Vulnerabilities
106 Application Phpmyadmin Phpmyadmin 2.10.3rc1 Version Details Vulnerabilities
107 Application Phpmyadmin Phpmyadmin 2.10.3.0 Version Details Vulnerabilities
108 Application Phpmyadmin Phpmyadmin 2.11.0beta1 Version Details Vulnerabilities
109 Application Phpmyadmin Phpmyadmin 2.11.0 Version Details Vulnerabilities
110 Application Phpmyadmin Phpmyadmin 2.11.0rc1 Version Details Vulnerabilities
111 Application Phpmyadmin Phpmyadmin 2.11.0.0 Version Details Vulnerabilities
112 Application Phpmyadmin Phpmyadmin 2.11.1rc1 Version Details Vulnerabilities
113 Application Phpmyadmin Phpmyadmin 2.11.1 Version Details Vulnerabilities
114 Application Phpmyadmin Phpmyadmin 2.11.1.0 Version Details Vulnerabilities
115 Application Phpmyadmin Phpmyadmin 2.11.1.1 Version Details Vulnerabilities
116 Application Phpmyadmin Phpmyadmin 2.11.1.2 Version Details Vulnerabilities
117 Application Phpmyadmin Phpmyadmin 2.11.2 Version Details Vulnerabilities
118 Application Phpmyadmin Phpmyadmin 2.11.2.0 Version Details Vulnerabilities
119 Application Phpmyadmin Phpmyadmin 2.11.2.1 Version Details Vulnerabilities
120 Application Phpmyadmin Phpmyadmin 2.11.2.2 Version Details Vulnerabilities
121 Application Phpmyadmin Phpmyadmin 2.11.3rc1 Version Details Vulnerabilities
122 Application Phpmyadmin Phpmyadmin 2.11.3 Version Details Vulnerabilities
123 Application Phpmyadmin Phpmyadmin 2.11.3.0 Version Details Vulnerabilities
124 Application Phpmyadmin Phpmyadmin 2.11.4 Version Details Vulnerabilities
125 Application Phpmyadmin Phpmyadmin 2.11.4rc1 Version Details Vulnerabilities
126 Application Phpmyadmin Phpmyadmin 2.11.4.0 Version Details Vulnerabilities
127 Application Phpmyadmin Phpmyadmin 2.11.5 Version Details Vulnerabilities
128 Application Phpmyadmin Phpmyadmin 2.11.5rc1 Version Details Vulnerabilities
129 Application Phpmyadmin Phpmyadmin 2.11.5.0 Version Details Vulnerabilities
130 Application Phpmyadmin Phpmyadmin 2.11.5.1 Version Details Vulnerabilities
131 Application Phpmyadmin Phpmyadmin 2.11.5.2 Version Details Vulnerabilities
132 Application Phpmyadmin Phpmyadmin 2.11.6rc1 Version Details Vulnerabilities
133 Application Phpmyadmin Phpmyadmin 2.11.6 Version Details Vulnerabilities
134 Application Phpmyadmin Phpmyadmin 2.11.7 Version Details Vulnerabilities
135 Application Phpmyadmin Phpmyadmin 2.11.7.0 Version Details Vulnerabilities
136 Application Phpmyadmin Phpmyadmin 2.11.8 Version Details Vulnerabilities
137 Application Phpmyadmin Phpmyadmin 2.11.9 Version Details Vulnerabilities
138 Application Phpmyadmin Phpmyadmin 2.11.9.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Phpmyadmin Phpmyadmin 138

- References For CVE-2008-4326

http://osvdb.org/48511
OSVDB 48511
http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00000.html
SUSE SUSE-SR:2009:003
http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/MAINT_2_11_9/phpMyAdmin/libraries/js_escape.lib.php?r1=11514&r2=11603&pathrev=11603 CONFIRM
http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/QA_2_11/phpMyAdmin/libraries/js_escape.lib.php?view=log&pathrev=11603 CONFIRM
http://secunia.com/advisories/31974
SECUNIA 31974
http://secunia.com/advisories/31992
SECUNIA 31992
http://secunia.com/advisories/32954
SECUNIA 32954
http://typo3.org/teams/security/security-bulletins/typo3-20080924-1/ CONFIRM
http://secunia.com/advisories/33822
SECUNIA 33822
http://www.openwall.com/lists/oss-security/2008/09/22/2
MLIST [oss-security] 20080923 CVE req: phpmyadmin < 2.11.9.2 xss
http://www.frsirt.com/english/advisories/2008/2657
VUPEN ADV-2008-2657
http://www.debian.org/security/2008/dsa-1675
DEBIAN DSA-1675
http://www.phpmyadmin.net/home_page/downloads.php?relnotes=1 CONFIRM
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2008-8 CONFIRM
http://jvndb.jvn.jp/ja/contents/2008/JVNDB-2008-000061.html
JVNDB JVNDB-2008-000061
http://jvn.jp/en/jp/JVN54824688/index.html
JVN JVN#54824688

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2008-4326

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.