CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-3747

The (1) get_edit_post_link and (2) get_edit_comment_link functions in wp-includes/link-template.php in WordPress before 2.6.1 do not force SSL communication in the intended situations, which might allow remote attackers to gain administrative access by sniffing the network for a cookie.
Publish Date : 2008-08-27 Last Update Date : 2009-08-19
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s)
CWE ID 264

- Products Affected By CVE-2008-3747

# Product Type Vendor Product Version Update Edition Language
1 Application Wordpress Wordpress 0.6.2 Version Details Vulnerabilities
2 Application Wordpress Wordpress 0.6.2.1 Version Details Vulnerabilities
3 Application Wordpress Wordpress 0.7 Version Details Vulnerabilities
4 Application Wordpress Wordpress 0.71 Version Details Vulnerabilities
5 Application Wordpress Wordpress 0.72 RC1 Version Details Vulnerabilities
6 Application Wordpress Wordpress 0.72 Version Details Vulnerabilities
7 Application Wordpress Wordpress 0.72 Beta1 Version Details Vulnerabilities
8 Application Wordpress Wordpress 0.72 Beta2 Version Details Vulnerabilities
9 Application Wordpress Wordpress 0.711 Version Details Vulnerabilities
10 Application Wordpress Wordpress 1.0 Version Details Vulnerabilities
11 Application Wordpress Wordpress 1.0.1 Version Details Vulnerabilities
12 Application Wordpress Wordpress 1.2 Beta Version Details Vulnerabilities
13 Application Wordpress Wordpress 1.2 Version Details Vulnerabilities
14 Application Wordpress Wordpress 1.2.1 Version Details Vulnerabilities
15 Application Wordpress Wordpress 1.2.2 Version Details Vulnerabilities
16 Application Wordpress Wordpress 1.5 Version Details Vulnerabilities
17 Application Wordpress Wordpress 1.5.1.3 Version Details Vulnerabilities
18 Application Wordpress Wordpress 1.5.2 Version Details Vulnerabilities
19 Application Wordpress Wordpress 2.0 Version Details Vulnerabilities
20 Application Wordpress Wordpress 2.0.1 Version Details Vulnerabilities
21 Application Wordpress Wordpress 2.0.2 Version Details Vulnerabilities
22 Application Wordpress Wordpress 2.0.4 Version Details Vulnerabilities
23 Application Wordpress Wordpress 2.0.5 Version Details Vulnerabilities
24 Application Wordpress Wordpress 2.0.6 Version Details Vulnerabilities
25 Application Wordpress Wordpress 2.0.7 Version Details Vulnerabilities
26 Application Wordpress Wordpress 2.0.9 Version Details Vulnerabilities
27 Application Wordpress Wordpress 2.0.10 Version Details Vulnerabilities
28 Application Wordpress Wordpress 2.0.11 Version Details Vulnerabilities
29 Application Wordpress Wordpress 2.1 Version Details Vulnerabilities
30 Application Wordpress Wordpress 2.1.1 Version Details Vulnerabilities
31 Application Wordpress Wordpress 2.1.2 Version Details Vulnerabilities
32 Application Wordpress Wordpress 2.1.3 Version Details Vulnerabilities
33 Application Wordpress Wordpress 2.2 Version Details Vulnerabilities
34 Application Wordpress Wordpress 2.2.1 Version Details Vulnerabilities
35 Application Wordpress Wordpress 2.2.2 Version Details Vulnerabilities
36 Application Wordpress Wordpress 2.2.3 Version Details Vulnerabilities
37 Application Wordpress Wordpress 2.3 Beta3 Version Details Vulnerabilities
38 Application Wordpress Wordpress 2.3 RC1 Version Details Vulnerabilities
39 Application Wordpress Wordpress 2.3 Version Details Vulnerabilities
40 Application Wordpress Wordpress 2.3.1 Version Details Vulnerabilities
41 Application Wordpress Wordpress 2.3.1 RC1 Version Details Vulnerabilities
42 Application Wordpress Wordpress 2.3.2 Version Details Vulnerabilities
43 Application Wordpress Wordpress 2.5 Version Details Vulnerabilities
44 Application Wordpress Wordpress 2.5.1 Version Details Vulnerabilities
45 Application Wordpress Wordpress 2.6 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Wordpress Wordpress 45

- References For CVE-2008-3747

http://www.openwall.com/lists/oss-security/2008/08/19/1
MLIST [oss-security] 20080819 wordpress 2.6.1
http://www.openwall.com/lists/oss-security/2008/08/20/3
MLIST [oss-security] 20080820 Re: wordpress 2.6.1
http://www.securityfocus.com/bid/30750
BID 30750 WordPress 'get_edit_post_link()' & 'get_edit_comment_link()' Multiple Eavesdropping Vulnerabilities Release Date:2008-08-28
http://xforce.iss.net/xforce/xfdb/44569
XF wordpress-geteditpostlink-info-disclosure(44569)
http://trac.wordpress.org/ticket/7359 CONFIRM

- Metasploit Modules Related To CVE-2008-3747

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.