CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-3641

The Hewlett-Packard Graphics Language (HPGL) filter in CUPS before 1.3.9 allows remote attackers to execute arbitrary code via crafted pen width and pen color opcodes that overwrite arbitrary memory.
Publish Date : 2008-10-10 Last Update Date : 2012-10-29
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 399

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important
5.8
AV:A/AC:L/Au:N/C:P/I:P/A:P 2008-09-26 2008-10-09
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-3641 oval:org.opensuse.security:def:20083641 unix
DSA-1656 cupsys -- several vulnerabilities oval:org.mitre.oval:def:8170 unix
DSA-1656-1 cupsys - several vulnerabilities oval:org.mitre.oval:def:18746 unix
ELSA-2008:0937: cups security update (Important) oval:org.mitre.oval:def:22723 unix
RHSA-2008:0937: cups security update (Important) oval:com.redhat.rhsa:def:20080937 unix
The Hewlett-Packard Graphics Language (HPGL) filter in CUPS before 1.3.9 allows remote attackers to execute arbitrary co... oval:org.mitre.oval:def:9666 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-3641

# Product Type Vendor Product Version Update Edition Language
1 Application Apple Cups 1.1 Version Details Vulnerabilities
2 Application Apple Cups 1.1.1 Version Details Vulnerabilities
3 Application Apple Cups 1.1.2 Version Details Vulnerabilities
4 Application Apple Cups 1.1.3 Version Details Vulnerabilities
5 Application Apple Cups 1.1.4 Version Details Vulnerabilities
6 Application Apple Cups 1.1.5 Version Details Vulnerabilities
7 Application Apple Cups 1.1.5-2 Version Details Vulnerabilities
8 Application Apple Cups 1.1.5-1 Version Details Vulnerabilities
9 Application Apple Cups 1.1.6-2 Version Details Vulnerabilities
10 Application Apple Cups 1.1.6-1 Version Details Vulnerabilities
11 Application Apple Cups 1.1.6 Version Details Vulnerabilities
12 Application Apple Cups 1.1.6-3 Version Details Vulnerabilities
13 Application Apple Cups 1.1.7 Version Details Vulnerabilities
14 Application Apple Cups 1.1.8 Version Details Vulnerabilities
15 Application Apple Cups 1.1.9 Version Details Vulnerabilities
16 Application Apple Cups 1.1.9-1 Version Details Vulnerabilities
17 Application Apple Cups 1.1.10-1 Version Details Vulnerabilities
18 Application Apple Cups 1.1.10 Version Details Vulnerabilities
19 Application Apple Cups 1.1.11 Version Details Vulnerabilities
20 Application Apple Cups 1.1.12 Version Details Vulnerabilities
21 Application Apple Cups 1.1.13 Version Details Vulnerabilities
22 Application Apple Cups 1.1.14 Version Details Vulnerabilities
23 Application Apple Cups 1.1.15 Version Details Vulnerabilities
24 Application Apple Cups 1.1.16 Version Details Vulnerabilities
25 Application Apple Cups 1.1.17 Version Details Vulnerabilities
26 Application Apple Cups 1.1.18 Version Details Vulnerabilities
27 Application Apple Cups 1.1.19 Version Details Vulnerabilities
28 Application Apple Cups 1.1.19 RC5 Version Details Vulnerabilities
29 Application Apple Cups 1.1.19 RC4 Version Details Vulnerabilities
30 Application Apple Cups 1.1.19 RC3 Version Details Vulnerabilities
31 Application Apple Cups 1.1.19 RC2 Version Details Vulnerabilities
32 Application Apple Cups 1.1.19 RC1 Version Details Vulnerabilities
33 Application Apple Cups 1.1.20 RC5 Version Details Vulnerabilities
34 Application Apple Cups 1.1.20 RC4 Version Details Vulnerabilities
35 Application Apple Cups 1.1.20 RC3 Version Details Vulnerabilities
36 Application Apple Cups 1.1.20 RC2 Version Details Vulnerabilities
37 Application Apple Cups 1.1.20 RC1 Version Details Vulnerabilities
38 Application Apple Cups 1.1.20 RC6 Version Details Vulnerabilities
39 Application Apple Cups 1.1.20 Version Details Vulnerabilities
40 Application Apple Cups 1.1.21 Version Details Vulnerabilities
41 Application Apple Cups 1.1.21 RC1 Version Details Vulnerabilities
42 Application Apple Cups 1.1.21 RC2 Version Details Vulnerabilities
43 Application Apple Cups 1.1.22 RC1 Version Details Vulnerabilities
44 Application Apple Cups 1.1.22 Version Details Vulnerabilities
45 Application Apple Cups 1.1.22 RC2 Version Details Vulnerabilities
46 Application Apple Cups 1.1.23 Version Details Vulnerabilities
47 Application Apple Cups 1.1.23 RC1 Version Details Vulnerabilities
48 Application Apple Cups 1.2 B1 Version Details Vulnerabilities
49 Application Apple Cups 1.2 RC3 Version Details Vulnerabilities
50 Application Apple Cups 1.2 RC2 Version Details Vulnerabilities
51 Application Apple Cups 1.2 RC1 Version Details Vulnerabilities
52 Application Apple Cups 1.2 B2 Version Details Vulnerabilities
53 Application Apple Cups 1.2.0 Version Details Vulnerabilities
54 Application Apple Cups 1.2.1 Version Details Vulnerabilities
55 Application Apple Cups 1.2.2 Version Details Vulnerabilities
56 Application Apple Cups 1.2.3 Version Details Vulnerabilities
57 Application Apple Cups 1.2.4 Version Details Vulnerabilities
58 Application Apple Cups 1.2.5 Version Details Vulnerabilities
59 Application Apple Cups 1.2.6 Version Details Vulnerabilities
60 Application Apple Cups 1.2.7 Version Details Vulnerabilities
61 Application Apple Cups 1.2.8 Version Details Vulnerabilities
62 Application Apple Cups 1.2.9 Version Details Vulnerabilities
63 Application Apple Cups 1.2.10 Version Details Vulnerabilities
64 Application Apple Cups 1.2.11 Version Details Vulnerabilities
65 Application Apple Cups 1.2.12 Version Details Vulnerabilities
66 Application Apple Cups 1.3 RC2 Version Details Vulnerabilities
67 Application Apple Cups 1.3 RC1 Version Details Vulnerabilities
68 Application Apple Cups 1.3 B1 Version Details Vulnerabilities
69 Application Apple Cups 1.3.0 Version Details Vulnerabilities
70 Application Apple Cups 1.3.1 Version Details Vulnerabilities
71 Application Apple Cups 1.3.2 Version Details Vulnerabilities
72 Application Apple Cups 1.3.3 Version Details Vulnerabilities
73 Application Apple Cups 1.3.4 Version Details Vulnerabilities
74 Application Apple Cups 1.3.5 Version Details Vulnerabilities
75 Application Apple Cups 1.3.6 Version Details Vulnerabilities
76 Application Apple Cups 1.3.7 Version Details Vulnerabilities
77 Application Apple Cups 1.3.8 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apple Cups 77

- References For CVE-2008-3641

http://www.vupen.com/english/advisories/2008/2782
VUPEN ADV-2008-2782
http://www.vupen.com/english/advisories/2008/2780
VUPEN ADV-2008-2780
http://www.ubuntulinux.org/support/documentation/usn/usn-656-1
UBUNTU USN-656-1
http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00006.html
SUSE SUSE-SR:2008:021
http://lists.apple.com/archives/security-announce/2008/Oct/msg00001.html
APPLE APPLE-SA-2008-10-09
http://secunia.com/advisories/32222
SECUNIA 32222
http://lists.opensuse.org/opensuse-security-announce/2009-01/msg00004.html
SUSE SUSE-SR:2009:002
http://secunia.com/advisories/32084
SECUNIA 32084
http://secunia.com/advisories/32284
SECUNIA 32284
http://secunia.com/advisories/32226
SECUNIA 32226
http://secunia.com/advisories/32292
SECUNIA 32292
http://secunia.com/advisories/33111
SECUNIA 33111
http://secunia.com/advisories/33085
SECUNIA 33085
http://secunia.com/advisories/32331
SECUNIA 32331
http://secunia.com/advisories/32316
SECUNIA 32316
http://secunia.com/advisories/33568
SECUNIA 33568
http://www.cups.org/articles.php?L575 CONFIRM
http://support.avaya.com/elmodocs2/security/ASA-2008-470.htm CONFIRM
http://support.apple.com/kb/HT3216 CONFIRM
http://www.securityfocus.com/archive/1/archive/1/497221/100/0/threaded
BUGTRAQ 20081010 ZDI-08-067: Apple CUPS 1.3.7 (HP-GL/2 filter) Remote Code Execution Vulnerability
http://sunsolve.sun.com/search/document.do?assetkey=1-26-261088-1
SUNALERT 261088
http://www.debian.org/security/2008/dsa-1656
DEBIAN DSA-1656
http://www.cups.org/str.php?L2911 CONFIRM
http://www.gentoo.org/security/en/glsa/glsa-200812-11.xml
GENTOO GLSA-200812-11
http://www.mandriva.com/security/advisories?name=MDVSA-2008:211
MANDRIVA MDVSA-2008:211
http://www.redhat.com/support/errata/RHSA-2008-0937.html
REDHAT RHSA-2008:0937
https://www.redhat.com/archives/fedora-package-announce/2008-October/msg00331.html
FEDORA FEDORA-2008-8801
http://www.securitytracker.com/id?1021031
SECTRACK 1021031
http://www.vupen.com/english/advisories/2008/3401
VUPEN ADV-2008-3401
http://www.vupen.com/english/advisories/2009/1568
VUPEN ADV-2009-1568
http://www.zerodayinitiative.com/advisories/ZDI-08-067
http://www.securityfocus.com/bid/31681
BID 31681 RETIRED: Apple Mac OS X 2008-007 Multiple Security Vulnerabilities Release Date:2009-03-24
https://www.redhat.com/archives/fedora-package-announce/2008-October/msg00380.html
FEDORA FEDORA-2008-8844
http://xforce.iss.net/xforce/xfdb/45779
XF cups-hpgl-code-execution(45779)
http://www.securityfocus.com/bid/31688
BID 31688 CUPS 'HP-GL/2' Filter Remote Code Execution Vulnerability Release Date:2009-06-12

- Metasploit Modules Related To CVE-2008-3641

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.