CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-3105

Unspecified vulnerability in the JAX-WS client and service in Sun Java Runtime Environment (JRE) in JDK and JRE 6 Update 6 and earlier allows remote attackers to access URLs or cause a denial of service via unknown vectors involving "processing of XML data" by a trusted application.
Publish Date : 2008-07-09 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
8.3
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 264

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2008-06-23 2008-07-08
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-3105 oval:org.opensuse.security:def:20083105 unix
ELSA-2008:0594: java-1.6.0-sun security update (Critical) oval:org.mitre.oval:def:22389 unix
ELSA-2008:0906: java-1.6.0-ibm security update (Critical) oval:org.mitre.oval:def:22274 unix
RHSA-2008:0594: java-1.6.0-sun security update (Critical) oval:com.redhat.rhsa:def:20080594 unix
RHSA-2008:0906: java-1.6.0-ibm security update (Critical) oval:com.redhat.rhsa:def:20080906 unix
Unspecified vulnerability in the JAX-WS client and service in Sun Java Runtime Environment (JRE) in JDK and JRE 6 Update... oval:org.mitre.oval:def:11274 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-3105

# Product Type Vendor Product Version Update Edition Language
1 Application SUN JDK 6 Update 4 Version Details Vulnerabilities
2 Application SUN JDK 6 Update 5 Version Details Vulnerabilities
3 Application SUN JDK 6 Update 6 Version Details Vulnerabilities
4 Application SUN JDK 6 Update 1 Version Details Vulnerabilities
5 Application SUN JDK 6 Update 2 Version Details Vulnerabilities
6 Application SUN JDK 6 Update 3 Version Details Vulnerabilities
7 Application SUN JRE 6 Update 5 Version Details Vulnerabilities
8 Application SUN JRE 6 Update 1 Version Details Vulnerabilities
9 Application SUN JRE 6 Update 6 Version Details Vulnerabilities
10 Application SUN JRE 6 Update 2 Version Details Vulnerabilities
11 Application SUN JRE 6 Update 3 Version Details Vulnerabilities
12 Application SUN JRE 6 Update 4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
SUN JDK 6
SUN JRE 6

- References For CVE-2008-3105

http://marc.info/?l=bugtraq&m=122331139823057&w=2
BUGTRAQ 20081004 VMSA-2008-0016 VMware Hosted products, VirtualCenter Update 3 and
http://secunia.com/advisories/31600
SECUNIA 31600
http://secunia.com/advisories/31010
SECUNIA 31010
http://secunia.com/advisories/32018
SECUNIA 32018
http://secunia.com/advisories/32179
SECUNIA 32179
http://secunia.com/advisories/32180
SECUNIA 32180
http://secunia.com/advisories/32436
SECUNIA 32436
http://secunia.com/advisories/33237
SECUNIA 33237
http://secunia.com/advisories/33238
SECUNIA 33238
http://security.gentoo.org/glsa/glsa-200911-02.xml
GENTOO GLSA-200911-02
http://secunia.com/advisories/37386
SECUNIA 37386
http://support.apple.com/kb/HT3179 CONFIRM
http://support.avaya.com/elmodocs2/security/ASA-2008-299.htm CONFIRM
http://www.redhat.com/support/errata/RHSA-2008-0594.html
REDHAT RHSA-2008:0594
http://www.frsirt.com/english/advisories/2008/2740
VUPEN ADV-2008-2740
http://www.frsirt.com/english/advisories/2008/2056/references
VUPEN ADV-2008-2056
http://support.nortel.com/go/main.jsp?cscat=BLTNDETAIL&id=756717 CONFIRM
http://support.nortel.com/go/main.jsp?cscat=BLTNDETAIL&id=751014 CONFIRM
http://support.avaya.com/elmodocs2/security/ASA-2008-509.htm CONFIRM
http://support.avaya.com/elmodocs2/security/ASA-2008-507.htm CONFIRM
http://support.avaya.com/elmodocs2/security/ASA-2008-428.htm CONFIRM
http://www.securitytracker.com/id?1020457
SECTRACK 1020457
http://www.securityfocus.com/bid/30143
BID 30143 Sun Java Runtime Environment XML Data Processing Multiple Vulnerabilities Release Date:2009-11-18
http://www.securityfocus.com/archive/1/archive/1/497041/100/0/threaded
BUGTRAQ 20081004 VMSA-2008-0016 VMware Hosted products, VirtualCenter Update 3 and patches for ESX and ESXi resolve multiple security issues
http://www.redhat.com/support/errata/RHSA-2008-1045.html
REDHAT RHSA-2008:1045
http://www.vmware.com/security/advisories/VMSA-2008-0016.html CONFIRM
http://www.redhat.com/support/errata/RHSA-2008-0906.html
REDHAT RHSA-2008:0906
http://www.redhat.com/support/errata/RHSA-2008-1044.html
REDHAT RHSA-2008:1044
http://xforce.iss.net/xforce/xfdb/43657
XF sun-jre-xml-dos(43657)
http://xforce.iss.net/xforce/xfdb/43654
XF sun-jre-jaxws-unauth-access(43654)
http://www.us-cert.gov/cas/techalerts/TA08-193A.html
CERT TA08-193A
http://lists.apple.com/archives/security-announce//2008/Sep/msg00007.html
APPLE APPLE-SA-2008-09-24
http://lists.opensuse.org/opensuse-security-announce/2008-08/msg00005.html
SUSE SUSE-SA:2008:042
http://sunsolve.sun.com/search/document.do?assetkey=1-66-238628-1
SUNALERT 238628

- Metasploit Modules Related To CVE-2008-3105

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.