CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-2809

Mozilla 1.9 M8 and earlier, Mozilla Firefox 2 before 2.0.0.15, SeaMonkey 1.1.5 and other versions before 1.1.10, Netscape 9.0, and other Mozilla-based web browsers, when a user accepts an SSL server certificate on the basis of the CN domain name in the DN field, regard the certificate as also accepted for all domain names in subjectAltName:dNSName fields, which makes it easier for remote attackers to trick a user into accepting an invalid certificate for a spoofed web site.
Publish Date : 2008-07-08 Last Update Date : 2012-11-26
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 20

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2008-06-12 2008-07-02
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-2809 oval:org.opensuse.security:def:20082809 unix
ELSA-2008:0569: firefox security update (Critical) oval:org.mitre.oval:def:22654 unix
ELSA-2008:0616: thunderbird security update (Moderate) oval:org.mitre.oval:def:22266 unix
Mozilla 1.9 M8 and earlier, Mozilla Firefox 2 before 2.0.0.15, SeaMonkey 1.1.5 and other versions before 1.1.10, Netscap... oval:org.mitre.oval:def:10205 unix
RHSA-2008:0547: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20080547 unix
RHSA-2008:0549: firefox security update (Critical) oval:com.redhat.rhsa:def:20080549 unix
RHSA-2008:0569: firefox security update (Critical) oval:com.redhat.rhsa:def:20080569 unix
RHSA-2008:0616: thunderbird security update (Moderate) oval:com.redhat.rhsa:def:20080616 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-2809

# Product Type Vendor Product Version Update Edition Language
1 Application Mozilla Firefox 2.0.0.1 Version Details Vulnerabilities
2 Application Mozilla Firefox 2.0.0.2 Version Details Vulnerabilities
3 Application Mozilla Firefox 2.0.0.3 Version Details Vulnerabilities
4 Application Mozilla Firefox 2.0.0.4 Version Details Vulnerabilities
5 Application Mozilla Firefox 2.0.0.5 Version Details Vulnerabilities
6 Application Mozilla Firefox 2.0.0.6 Version Details Vulnerabilities
7 Application Mozilla Firefox 2.0.0.7 Version Details Vulnerabilities
8 Application Mozilla Firefox 2.0.0.8 Version Details Vulnerabilities
9 Application Mozilla Firefox 2.0.0.9 Version Details Vulnerabilities
10 Application Mozilla Firefox 2.0.0.10 Version Details Vulnerabilities
11 Application Mozilla Firefox 2.0.0.11 Version Details Vulnerabilities
12 Application Mozilla Firefox 2.0.0.12 Version Details Vulnerabilities
13 Application Mozilla Firefox 2.0.0.13 Version Details Vulnerabilities
14 Application Mozilla Firefox 2.0.0.14 Version Details Vulnerabilities
15 Application Mozilla Geckb 1.9 M8 Version Details Vulnerabilities
16 Application Mozilla Seamonkey 1.0.9 Version Details Vulnerabilities
17 Application Mozilla Seamonkey 1.1.5 Version Details Vulnerabilities
18 Application Netscape Navigator 9.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mozilla Firefox 14
Mozilla Geckb 1
Mozilla Seamonkey 2
Netscape Navigator 1

- References For CVE-2008-2809

http://nils.toedtmann.net/pub/subjectAltName.txt
http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00004.html
SUSE SUSE-SA:2008:034
http://rhn.redhat.com/errata/RHSA-2008-0616.html
REDHAT RHSA-2008:0616
http://secunia.com/advisories/31005
SECUNIA 31005
http://secunia.com/advisories/30949
SECUNIA 30949
http://secunia.com/advisories/30911
SECUNIA 30911
http://secunia.com/advisories/30903
SECUNIA 30903
http://secunia.com/advisories/30898
SECUNIA 30898
http://secunia.com/advisories/30878
SECUNIA 30878
http://secunia.com/advisories/31008
SECUNIA 31008
http://secunia.com/advisories/31021
SECUNIA 31021
http://secunia.com/advisories/31023
SECUNIA 31023
http://secunia.com/advisories/31069
SECUNIA 31069
http://secunia.com/advisories/31076
SECUNIA 31076
http://secunia.com/advisories/31183
SECUNIA 31183
http://secunia.com/advisories/31195
SECUNIA 31195
http://secunia.com/advisories/31220
SECUNIA 31220
http://secunia.com/advisories/31253
SECUNIA 31253
http://secunia.com/advisories/31286
SECUNIA 31286
http://secunia.com/advisories/31377
SECUNIA 31377
http://secunia.com/advisories/31403
SECUNIA 31403
http://secunia.com/advisories/33433
SECUNIA 33433
http://secunia.com/advisories/34501
SECUNIA 34501
http://security.gentoo.org/glsa/glsa-200808-03.xml
GENTOO GLSA-200808-03
http://securityreason.com/securityalert/3498
SREASON 3498
http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.410484
SLACKWARE SSA:2008-210-05
http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.384911
SLACKWARE SSA:2008-191
http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.383152
SLACKWARE SSA:2008-191-03
http://securitytracker.com/id?1018979
SECTRACK 1018979
http://sunsolve.sun.com/search/document.do?assetkey=1-26-256408-1
SUNALERT 256408
http://wiki.rpath.com/Advisories:rPSA-2008-0216 CONFIRM
http://www.debian.org/security/2008/dsa-1607
DEBIAN DSA-1607
http://www.debian.org/security/2008/dsa-1615
DEBIAN DSA-1615
http://www.debian.org/security/2008/dsa-1621
DEBIAN DSA-1621
http://www.mozilla.org/security/announce/2008/mfsa2008-31.html CONFIRM
http://www.mozilla.org/projects/security/known-vulnerabilities.html#firefox2.0.0.15 CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2008:155
MANDRIVA MDVSA-2008:155
http://www.mandriva.com/security/advisories?name=MDVSA-2008:136
MANDRIVA MDVSA-2008:136
http://www.debian.org/security/2009/dsa-1697
DEBIAN DSA-1697
http://www.redhat.com/support/errata/RHSA-2008-0547.html
REDHAT RHSA-2008:0547
http://www.redhat.com/support/errata/RHSA-2008-0549.html
REDHAT RHSA-2008:0549
http://www.redhat.com/support/errata/RHSA-2008-0569.html
REDHAT RHSA-2008:0569
http://www.securityfocus.com/archive/1/archive/1/483937/100/100/threaded
BUGTRAQ 20071118 Re: Certificate spoofing issue with Mozilla, Konqueror, Safari 2
http://www.securityfocus.com/archive/1/archive/1/483929/100/100/threaded
BUGTRAQ 20071118 Certificate spoofing issue with Mozilla, Konqueror, Safari 2
http://www.securityfocus.com/bid/30038
BID 30038 Mozilla Firefox 2.0.0.14 Multiple Remote Vulnerabilities Release Date:2009-05-15
http://www.securityfocus.com/archive/1/archive/1/494080/100/0/threaded
BUGTRAQ 20080708 rPSA-2008-0216-1 firefox
http://www.securityfocus.com/archive/1/archive/1/483960/100/100/threaded
BUGTRAQ 20071118 RE: Certificate spoofing issue with Mozilla, Konqueror, Safari 2
https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00295.html
FEDORA FEDORA-2008-6196
http://www.ubuntu.com/usn/usn-619-1
UBUNTU USN-619-1
http://www.securitytracker.com/id?1020419
SECTRACK 1020419
http://www.ubuntu.com/usn/usn-629-1
UBUNTU USN-629-1
http://www.vupen.com/english/advisories/2008/1993/references
VUPEN ADV-2008-1993
http://www.vupen.com/english/advisories/2009/0977
VUPEN ADV-2009-0977
http://xforce.iss.net/xforce/xfdb/43524
XF mozilla-altnames-spoofing(43524)
https://bugzilla.mozilla.org/show_bug.cgi?id=240261 CONFIRM
https://bugzilla.mozilla.org/show_bug.cgi?id=327181 CONFIRM
https://bugzilla.mozilla.org/show_bug.cgi?id=402347 CONFIRM
https://issues.rpath.com/browse/RPL-2646 CONFIRM
https://www.redhat.com/archives/fedora-package-announce/2008-August/msg00125.html
FEDORA FEDORA-2008-6737
https://www.redhat.com/archives/fedora-package-announce/2008-August/msg00144.html
FEDORA FEDORA-2008-6706
https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00207.html
FEDORA FEDORA-2008-6127
https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00288.html
FEDORA FEDORA-2008-6193

- Metasploit Modules Related To CVE-2008-2809

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.