CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-1149

phpMyAdmin before 2.11.5 accesses $_REQUEST to obtain some parameters instead of $_GET and $_POST, which allows attackers in the same domain to override certain variables and conduct SQL injection and Cross-Site Request Forgery (CSRF) attacks by using crafted cookies.
Publish Date : 2008-03-04 Last Update Date : 2011-08-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Sql InjectionCSRF
CWE ID 352

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-1149 oval:org.opensuse.security:def:20081149 unix
DSA-1557 phpmyadmin -- insufficient input sanitising oval:org.mitre.oval:def:8041 unix
DSA-1557-1 phpmyadmin - several vulnerabilities oval:org.mitre.oval:def:18667 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-1149

# Product Type Vendor Product Version Update Edition Language
1 Application Phpmyadmin Phpmyadmin 2.11.0 Version Details Vulnerabilities
2 Application Phpmyadmin Phpmyadmin 2.11.0 RC1 Version Details Vulnerabilities
3 Application Phpmyadmin Phpmyadmin 2.11.0 Beta1 Version Details Vulnerabilities
4 Application Phpmyadmin Phpmyadmin 2.11.0.0 Version Details Vulnerabilities
5 Application Phpmyadmin Phpmyadmin 2.11.1 Version Details Vulnerabilities
6 Application Phpmyadmin Phpmyadmin 2.11.1 RC1 Version Details Vulnerabilities
7 Application Phpmyadmin Phpmyadmin 2.11.1.0 Version Details Vulnerabilities
8 Application Phpmyadmin Phpmyadmin 2.11.1.1 Version Details Vulnerabilities
9 Application Phpmyadmin Phpmyadmin 2.11.1.2 Version Details Vulnerabilities
10 Application Phpmyadmin Phpmyadmin 2.11.2 Version Details Vulnerabilities
11 Application Phpmyadmin Phpmyadmin 2.11.2.0 Version Details Vulnerabilities
12 Application Phpmyadmin Phpmyadmin 2.11.2.1 Version Details Vulnerabilities
13 Application Phpmyadmin Phpmyadmin 2.11.2.2 Version Details Vulnerabilities
14 Application Phpmyadmin Phpmyadmin 2.11.3 RC1 Version Details Vulnerabilities
15 Application Phpmyadmin Phpmyadmin 2.11.3 Version Details Vulnerabilities
16 Application Phpmyadmin Phpmyadmin 2.11.3.0 Version Details Vulnerabilities
17 Application Phpmyadmin Phpmyadmin 2.11.4 Version Details Vulnerabilities
18 Application Phpmyadmin Phpmyadmin 2.11.4 RC1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Phpmyadmin Phpmyadmin 18

- References For CVE-2008-1149

http://www.securityfocus.com/bid/28068
BID 28068 phpMyAdmin '$_REQUEST' SQL Injection Vulnerability Release Date:2009-02-02
http://secunia.com/advisories/29143
SECUNIA 29143
http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00000.html
SUSE SUSE-SR:2009:003
http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00002.html
SUSE SUSE-SR:2008:026
http://www.mandriva.com/security/advisories?name=MDVSA-2008:131
MANDRIVA MDVSA-2008:131
http://www.gentoo.org/security/en/glsa/glsa-200803-15.xml
GENTOO GLSA-200803-15
http://secunia.com/advisories/33822
SECUNIA 33822
http://secunia.com/advisories/32834
SECUNIA 32834
http://secunia.com/advisories/30816
SECUNIA 30816
http://secunia.com/advisories/29964
SECUNIA 29964
http://secunia.com/advisories/29287
SECUNIA 29287
http://secunia.com/advisories/29200
SECUNIA 29200
http://www.vupen.com/english/advisories/2008/0731
VUPEN ADV-2008-0731
http://www.vupen.com/english/advisories/2008/0758
VUPEN ADV-2008-0758
https://www.redhat.com/archives/fedora-package-announce/2008-March/msg00069.html
FEDORA FEDORA-2008-2189
http://xforce.iss.net/xforce/xfdb/40968
XF phpmyadmin-request-sql-injection(40968)
https://www.redhat.com/archives/fedora-package-announce/2008-March/msg00100.html
FEDORA FEDORA-2008-2229
http://www.debian.org/security/2008/dsa-1557
DEBIAN DSA-1557
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2008-1 CONFIRM

- Metasploit Modules Related To CVE-2008-1149

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.