CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-0785

Multiple SQL injection vulnerabilities in Cacti 0.8.7 before 0.8.7b and 0.8.6 before 0.8.6k allow remote authenticated users to execute arbitrary SQL commands via the (1) graph_list parameter to graph_view.php, (2) leaf_id and id parameters to tree.php, (3) local_graph_id parameter to graph_xport.php, and (4) login_username parameter to index.php/login.
Publish Date : 2008-02-14 Last Update Date : 2008-09-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Execute CodeSql Injection
CWE ID 89

- Products Affected By CVE-2008-0785

# Product Type Vendor Product Version Update Edition Language
1 Application Cacti Cacti 0.6.7 Version Details Vulnerabilities
2 Application Cacti Cacti 0.8 Version Details Vulnerabilities
3 Application Cacti Cacti 0.8.1 Version Details Vulnerabilities
4 Application Cacti Cacti 0.8.2 Version Details Vulnerabilities
5 Application Cacti Cacti 0.8.2a Version Details Vulnerabilities
6 Application Cacti Cacti 0.8.3 Version Details Vulnerabilities
7 Application Cacti Cacti 0.8.3a Version Details Vulnerabilities
8 Application Cacti Cacti 0.8.4 Version Details Vulnerabilities
9 Application Cacti Cacti 0.8.5 Version Details Vulnerabilities
10 Application Cacti Cacti 0.8.5a Version Details Vulnerabilities
11 Application Cacti Cacti 0.8.6c Version Details Vulnerabilities
12 Application Cacti Cacti 0.8.6f Version Details Vulnerabilities
13 Application Cacti Cacti 0.8.6i Version Details Vulnerabilities
14 Application Cacti Cacti 0.8.6j Version Details Vulnerabilities
15 Application Cacti Cacti 0.8.7a Version Details Vulnerabilities
16 Application Cacti Cacti 0.8.7 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Cacti Cacti 16

- References For CVE-2008-0785

http://secunia.com/advisories/30045
SECUNIA 30045
http://security.gentoo.org/glsa/glsa-200803-18.xml
GENTOO GLSA-200803-18
http://securityreason.com/securityalert/3657
SREASON 3657
http://www.mandriva.com/security/advisories?name=MDVSA-2008:052
MANDRIVA MDVSA-2008:052
http://www.debian.org/security/2008/dsa-1569
DEBIAN DSA-1569
https://bugzilla.redhat.com/show_bug.cgi?id=432758 CONFIRM
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00570.html
FEDORA FEDORA-2008-1699
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00593.html
FEDORA FEDORA-2008-1737
http://secunia.com/advisories/28872
SECUNIA 28872
http://www.frsirt.com/english/advisories/2008/0540
VUPEN ADV-2008-0540
http://www.securityfocus.com/archive/1/archive/1/488013/100/0/threaded
BUGTRAQ 20080212 cacti -- Multiple security vulnerabilities have been discovered
http://www.securityfocus.com/archive/1/archive/1/488018/100/0/threaded
BUGTRAQ 20080212 Cacti 0.8.7a Multiple Vulnerabilities
http://www.securitytracker.com/id?1019414
SECTRACK 1019414
http://www.securityfocus.com/bid/27749
BID 27749 Cacti Multiple Input Validation Vulnerabilities Release Date:2009-05-21
http://www.cacti.net/release_notes_0_8_7b.php CONFIRM
http://secunia.com/advisories/29274
SECUNIA 29274
http://secunia.com/advisories/29242
SECUNIA 29242
http://secunia.com/advisories/28976
SECUNIA 28976
http://lists.opensuse.org/opensuse-security-announce/2008-03/msg00001.html
SUSE SUSE-SR:2008:005

- Metasploit Modules Related To CVE-2008-0785

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.