CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-0525

PatchLink Update client for Unix, as used by Novell ZENworks Patch Management Update Agent for Linux/Unix/Mac (LUM) 6.2094 through 6.4102 and other products, allows local users to (1) truncate arbitrary files via a symlink attack on the /tmp/patchlink.tmp file used by the logtrimmer script, and (2) execute arbitrary code via a symlink attack on the /tmp/plshutdown file used by the rebootTask script.
Publish Date : 2008-01-31 Last Update Date : 2011-08-23
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.6
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Execute Code
CWE ID 59

- Products Affected By CVE-2008-0525

# Product Type Vendor Product Version Update Edition Language
1 Application Lumension Security Patchlink Update 6.2 Unix Version Details Vulnerabilities
2 Application Lumension Security Patchlink Update 6.2 MAC Version Details Vulnerabilities
3 Application Lumension Security Patchlink Update 6.2 Linux Version Details Vulnerabilities
4 Application Lumension Security Patchlink Update 6.3 Unix Version Details Vulnerabilities
5 Application Lumension Security Patchlink Update 6.3 MAC Version Details Vulnerabilities
6 Application Lumension Security Patchlink Update 6.3 Linux Version Details Vulnerabilities
7 Application Lumension Security Patchlink Update 6.4 Unix Version Details Vulnerabilities
8 Application Lumension Security Patchlink Update 6.4 MAC Version Details Vulnerabilities
9 Application Lumension Security Patchlink Update 6.4 Linux Version Details Vulnerabilities
10 Application Novell Zenworks Patch Management Update Agent 6.2 MAC Version Details Vulnerabilities
11 Application Novell Zenworks Patch Management Update Agent 6.2 Linux Version Details Vulnerabilities
12 Application Novell Zenworks Patch Management Update Agent 6.2 Unix Version Details Vulnerabilities
13 Application Novell Zenworks Patch Management Update Agent 6.3 Unix Version Details Vulnerabilities
14 Application Novell Zenworks Patch Management Update Agent 6.3 MAC Version Details Vulnerabilities
15 Application Novell Zenworks Patch Management Update Agent 6.3 Linux Version Details Vulnerabilities
16 Application Novell Zenworks Patch Management Update Agent 6.4 Linux Version Details Vulnerabilities
17 Application Novell Zenworks Patch Management Update Agent 6.4 Unix Version Details Vulnerabilities
18 Application Novell Zenworks Patch Management Update Agent 6.4 MAC Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Lumension Security Patchlink Update 9
Novell Zenworks Patch Management Update Agent 9

- References For CVE-2008-0525

http://secunia.com/advisories/28657
SECUNIA 28657
http://secunia.com/advisories/28665
SECUNIA 28665
http://securityreason.com/securityalert/3599
SREASON 3599
http://support.lumension.com/scripts/rightnow.cfg/php.exe/enduser/std_adp.php?p_faqid=527 CONFIRM
http://support.lumension.com/scripts/rightnow.cfg/php.exe/enduser/std_adp.php?p_faqid=528 CONFIRM
http://www.securitytracker.com/id?1019272
SECTRACK 1019272
http://www.securityfocus.com/bid/27458
BID 27458 PatchLink Update Multiple Insecure Temporary File Creation Vulnerabilities Release Date:2008-02-07
http://www.securityfocus.com/archive/1/archive/1/487103/100/0/threaded
BUGTRAQ 20080125 Two vulnerabilities for PatchLink Update Client for Unix.
http://support.lumension.com/scripts/rightnow.cfg/php.exe/enduser/std_adp.php?p_faqid=530 CONFIRM
http://www.vupen.com/english/advisories/2008/0426
VUPEN ADV-2008-0426
http://xforce.iss.net/xforce/xfdb/39956
XF patchlinkupdate-logtrimmer-symlink(39956)
http://xforce.iss.net/xforce/xfdb/39958
XF patchlinkupdate-reboottask-symlink(39958)
https://secure-support.novell.com/KanisaPlatform/Publishing/18/3908994_f.SAL_Public.html CONFIRM

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2008-0525

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.