CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-0417

CRLF injection vulnerability in Mozilla Firefox before 2.0.0.12 allows remote user-assisted web sites to corrupt the user's password store via newlines that are not properly handled when the user saves a password.
Publish Date : 2008-02-08 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 94

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2008-01-28 2008-02-07
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CRLF injection vulnerability in Mozilla Firefox before 2.0.0.12 allows remote user-assisted web sites to corrupt the use... oval:org.mitre.oval:def:11154 unix
CVE-2008-0417 oval:org.opensuse.security:def:20080417 unix
DSA-1484 xulrunner -- several vulnerabilities oval:org.mitre.oval:def:8000 unix
DSA-1484-1 xulrunner - several vulnerabilities oval:org.mitre.oval:def:20267 unix
DSA-1485 icedove -- several vulnerabilities oval:org.mitre.oval:def:7914 unix
DSA-1485-2 icedove - several vulnerabilities oval:org.mitre.oval:def:18417 unix
DSA-1489 iceweasel -- several vulnerabilities oval:org.mitre.oval:def:7909 unix
DSA-1489-1 iceweasel - several vulnerabilities oval:org.mitre.oval:def:18434 unix
DSA-1506 iceape -- several vulnerabilities oval:org.mitre.oval:def:8162 unix
DSA-1506-1 iceape - several vulnerabilities oval:org.mitre.oval:def:20074 unix
ELSA-2008:0103: firefox security update (Critical) oval:org.mitre.oval:def:22437 unix
RHSA-2008:0103: firefox security update (Critical) oval:com.redhat.rhsa:def:20080103 unix
RHSA-2008:0104: seamonkey security update (Critical) oval:com.redhat.rhsa:def:20080104 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-0417

# Product Type Vendor Product Version Update Edition Language
1 Application Mozilla Firefox 2.0.0.11 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Mozilla Firefox 1

- References For CVE-2008-0417

http://lists.opensuse.org/opensuse-security-announce/2008-02/msg00006.html
SUSE SUSE-SA:2008:008
http://browser.netscape.com/releasenotes/ CONFIRM
http://secunia.com/advisories/28818
SECUNIA 28818
http://secunia.com/advisories/28839
SECUNIA 28839
http://secunia.com/advisories/28864
SECUNIA 28864
http://secunia.com/advisories/28924
SECUNIA 28924
http://secunia.com/advisories/28879
SECUNIA 28879
http://secunia.com/advisories/28877
SECUNIA 28877
http://secunia.com/advisories/28865
SECUNIA 28865
http://secunia.com/advisories/30327
SECUNIA 30327
http://secunia.com/advisories/28939
SECUNIA 28939
http://secunia.com/advisories/28958
SECUNIA 28958
http://secunia.com/advisories/29086
SECUNIA 29086
http://secunia.com/advisories/29567
SECUNIA 29567
http://support.novell.com/techcenter/psdb/6251b18e050302ebe7fe74294b55c818.html CONFIRM
http://www.debian.org/security/2008/dsa-1489
DEBIAN DSA-1489
http://www.debian.org/security/2008/dsa-1485
DEBIAN DSA-1485
http://www.debian.org/security/2008/dsa-1484
DEBIAN DSA-1484
http://wiki.rpath.com/Advisories:rPSA-2008-0051 CONFIRM
http://www.debian.org/security/2008/dsa-1506
DEBIAN DSA-1506
http://www.frsirt.com/english/advisories/2008/0453/references
VUPEN ADV-2008-0453
http://www.redhat.com/support/errata/RHSA-2008-0103.html
REDHAT RHSA-2008:0103
http://www.mandriva.com/security/advisories?name=MDVSA-2008:048
MANDRIVA MDVSA-2008:048
http://www.frsirt.com/english/advisories/2008/0627/references
VUPEN ADV-2008-0627
http://www.redhat.com/support/errata/RHSA-2008-0104.html
REDHAT RHSA-2008:0104
http://www.securityfocus.com/bid/27683
BID 27683 Mozilla Thunderbird/Seamonkey/Firefox 2.0.0.11 Multiple Remote Vulnerabilities Release Date:2008-08-01
http://www.securityfocus.com/archive/1/archive/1/487826/100/0/threaded
BUGTRAQ 20080209 rPSA-2008-0051-1 firefox
http://www.securityfocus.com/archive/1/archive/1/488002/100/0/threaded
BUGTRAQ 20080212 FLEA-2008-0001-1 firefox
http://www.ubuntu.com/usn/usn-576-1
UBUNTU USN-576-1
http://www.securitytracker.com/id?1019334
SECTRACK 1019334
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00274.html
FEDORA FEDORA-2008-1435
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00309.html
FEDORA FEDORA-2008-1459
http://sunsolve.sun.com/search/document.do?assetkey=1-26-238492-1
SUNALERT 238492
http://secunia.com/advisories/30620
SECUNIA 30620
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00381.html
FEDORA FEDORA-2008-1535
http://www.frsirt.com/english/advisories/2008/1793/references
VUPEN ADV-2008-1793
http://www.gentoo.org/security/en/glsa/glsa-200805-18.xml
GENTOO GLSA-200805-18
http://www.mozilla.org/security/announce/2008/mfsa2008-04.html CONFIRM
https://bugzilla.mozilla.org/show_bug.cgi?id=394610 CONFIRM
http://secunia.com/advisories/28766
SECUNIA 28766

- Metasploit Modules Related To CVE-2008-0417

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.