CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-0411

Stack-based buffer overflow in the zseticcspace function in zicc.c in Ghostscript 8.61 and earlier allows remote attackers to execute arbitrary code via a postscript (.ps) file containing a long Range array in a .seticcspace operator.
Publish Date : 2008-02-28 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.8
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Execute CodeOverflow
CWE ID 119

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2008-02-05 2008-02-27
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2008-0411 oval:org.opensuse.security:def:20080411 unix
DSA-1510 gs-esp gs-gpl -- buffer overflow oval:org.mitre.oval:def:7775 unix
DSA-1510-1 gs-esp gs-gpl - arbitrary code execution oval:org.mitre.oval:def:20095 unix
ELSA-2008:0155: ghostscript security update (Important) oval:org.mitre.oval:def:22430 unix
RHSA-2008:0155: ghostscript security update (Important) oval:com.redhat.rhsa:def:20080155 unix
Stack-based buffer overflow in the zseticcspace function in zicc.c in Ghostscript 8.61 and earlier allows remote attacke... oval:org.mitre.oval:def:9557 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2008-0411

# Product Type Vendor Product Version Update Edition Language
1 Application Ghostscript Ghostscript 0 Version Details Vulnerabilities
2 Application Ghostscript Ghostscript 8.0.1 Version Details Vulnerabilities
3 Application Ghostscript Ghostscript 8.15 Version Details Vulnerabilities
4 Application Ghostscript Ghostscript 8.61 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Ghostscript Ghostscript 4

- References For CVE-2008-0411

http://lists.opensuse.org/opensuse-security-announce/2008-02/msg00009.html
SUSE SUSE-SA:2008:010
http://secunia.com/advisories/29101
SECUNIA 29101
http://scary.beasts.org/security/CESA-2008-001.html
http://secunia.com/advisories/29103
SECUNIA 29103
http://secunia.com/advisories/29112
SECUNIA 29112
http://secunia.com/advisories/29135
SECUNIA 29135
http://secunia.com/advisories/29147
SECUNIA 29147
http://secunia.com/advisories/29154
SECUNIA 29154
http://secunia.com/advisories/29169
SECUNIA 29169
http://www.securityfocus.com/archive/1/archive/1/488946/100/0/threaded
BUGTRAQ 20080228 Ghostscript buffer overflow
http://www.securityfocus.com/archive/1/archive/1/488932/100/0/threaded
BUGTRAQ 20080228 rPSA-2008-0082-1 espgs
http://www.redhat.com/support/errata/RHSA-2008-0155.html
REDHAT RHSA-2008:0155
http://www.mandriva.com/security/advisories?name=MDVSA-2008:055
MANDRIVA MDVSA-2008:055
http://www.gentoo.org/security/en/glsa/glsa-200803-14.xml
GENTOO GLSA-200803-14
http://www.frsirt.com/english/advisories/2008/0693/references
VUPEN ADV-2008-0693
http://wiki.rpath.com/Advisories:rPSA-2008-0082 CONFIRM
http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.370633
SLACKWARE SSA:2008-062-01
http://secunia.com/advisories/29768
SECUNIA 29768
http://secunia.com/advisories/29314
SECUNIA 29314
http://secunia.com/advisories/29196
SECUNIA 29196
http://www.securityfocus.com/bid/28017
BID 28017 Ghostscript zseticcspace() Function Buffer Overflow Vulnerability Release Date:2008-04-16
http://www.ubuntu.com/usn/usn-599-1
UBUNTU USN-599-1
http://www.securitytracker.com/id?1019511
SECTRACK 1019511
http://www.debian.org/security/2008/dsa-1510
DEBIAN DSA-1510
https://www.redhat.com/archives/fedora-package-announce/2008-March/msg00085.html
FEDORA FEDORA-2008-1998
https://issues.rpath.com/browse/RPL-2217 CONFIRM

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)
Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2008-0411

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.