CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2008-0009

The vmsplice_to_user function in fs/splice.c in the Linux kernel 2.6.22 through 2.6.24 does not validate a certain userspace pointer before dereference, which might allow local users to access arbitrary kernel memory locations.
Publish Date : 2008-02-12 Last Update Date : 2008-09-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 20

- Vendor Statements

Not vulnerable. This issue did not affect the versions of the Linux kernel as shipped with Red Hat Enterprise Linux 2.1, 3, 4, or 5.
Source: Redhat

- Products Affected By CVE-2008-0009

# Product Type Vendor Product Version Update Edition Language
1 OS Linux Linux Kernel 2.6.22 Version Details Vulnerabilities
2 OS Linux Linux Kernel 2.6.22 RC6 Version Details Vulnerabilities
3 OS Linux Linux Kernel 2.6.22.1 Version Details Vulnerabilities
4 OS Linux Linux Kernel 2.6.22.3 Version Details Vulnerabilities
5 OS Linux Linux Kernel 2.6.22.4 Version Details Vulnerabilities
6 OS Linux Linux Kernel 2.6.22.5 Version Details Vulnerabilities
7 OS Linux Linux Kernel 2.6.22.6 Version Details Vulnerabilities
8 OS Linux Linux Kernel 2.6.22.7 Version Details Vulnerabilities
9 OS Linux Linux Kernel 2.6.22.16 Version Details Vulnerabilities
10 OS Linux Linux Kernel 2.6.23 RC2 Version Details Vulnerabilities
11 OS Linux Linux Kernel 2.6.23 Version Details Vulnerabilities
12 OS Linux Linux Kernel 2.6.23 RC1 Version Details Vulnerabilities
13 OS Linux Linux Kernel 2.6.23.1 Version Details Vulnerabilities
14 OS Linux Linux Kernel 2.6.23.2 Version Details Vulnerabilities
15 OS Linux Linux Kernel 2.6.23.3 Version Details Vulnerabilities
16 OS Linux Linux Kernel 2.6.23.4 Version Details Vulnerabilities
17 OS Linux Linux Kernel 2.6.23.5 Version Details Vulnerabilities
18 OS Linux Linux Kernel 2.6.23.6 Version Details Vulnerabilities
19 OS Linux Linux Kernel 2.6.23.7 Version Details Vulnerabilities
20 OS Linux Linux Kernel 2.6.23.9 Version Details Vulnerabilities
21 OS Linux Linux Kernel 2.6.23.14 Version Details Vulnerabilities
22 OS Linux Linux Kernel 2.6.24 RC3 Version Details Vulnerabilities
23 OS Linux Linux Kernel 2.6.24 RC2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Linux Linux Kernel 23

- References For CVE-2008-0009

http://www.frsirt.com/english/advisories/2008/0487/references
VUPEN ADV-2008-0487
http://secunia.com/advisories/28896
SECUNIA 28896
http://www.securityfocus.com/archive/1/archive/1/487982/100/0/threaded
BUGTRAQ 20080212 CSA-L03: Linux kernel vmsplice unchecked user-pointer dereference
http://www.securityfocus.com/bid/27799
BID 27799 Linux Kernel Prior to 2.6.24.1 'vmsplice_to_user()' Local Privilege Escalation Vulnerability Release Date:2008-02-20
http://www.securityfocus.com/bid/27704
BID 27704 RETIRED: Linux Kernel Multiple Prior to 2.6.24.1 Multiple Memory Access Vulnerabilities Release Date:2008-02-14
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00254.html
FEDORA FEDORA-2008-1422
https://www.redhat.com/archives/fedora-package-announce/2008-February/msg00255.html
FEDORA FEDORA-2008-1423
http://isec.pl/vulnerabilities/isec-0026-vmsplice_to_kernel.txt
http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.24.1 CONFIRM
https://bugzilla.redhat.com/show_bug.cgi?id=431206 CONFIRM
http://secunia.com/advisories/28835
SECUNIA 28835

- Metasploit Modules Related To CVE-2008-0009

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.