CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-6600

PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, 7.4 before 7.4.19, and 7.3 before 7.3.21 uses superuser privileges instead of table owner privileges for (1) VACUUM and (2) ANALYZE operations within index functions, and supports (3) SET ROLE and (4) SET SESSION AUTHORIZATION within index functions, which allows remote authenticated users to gain privileges.
Publish Date : 2008-01-09 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Gain privileges
CWE ID 264

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2007-12-31 2008-01-07
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2007-6600 oval:org.opensuse.security:def:20076600 unix
DSA-1460 postgresql-8.1 -- several vulnerabilities oval:org.mitre.oval:def:7844 unix
DSA-1460-1 postgresql-8.1 - several oval:org.mitre.oval:def:20164 unix
DSA-1463 postgresql-7.4 -- several vulnerabilities oval:org.mitre.oval:def:8199 unix
DSA-1463-1 postgresql-7.4 - several oval:org.mitre.oval:def:18105 unix
ELSA-2008:0038: postgresql security update (Moderate) oval:org.mitre.oval:def:21738 unix
PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, 7.4 before 7.4.19, and 7.3 before 7.3.21 uses superus... oval:org.mitre.oval:def:10493 unix
RHSA-2008:0038: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20080038 unix
RHSA-2008:0039: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20080039 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2007-6600

# Product Type Vendor Product Version Update Edition Language
1 Application Postgresql Postgresql 7.3 Version Details Vulnerabilities
2 Application Postgresql Postgresql 7.3.1 Version Details Vulnerabilities
3 Application Postgresql Postgresql 7.3.2 Version Details Vulnerabilities
4 Application Postgresql Postgresql 7.3.3 Version Details Vulnerabilities
5 Application Postgresql Postgresql 7.3.4 Version Details Vulnerabilities
6 Application Postgresql Postgresql 7.3.5 Version Details Vulnerabilities
7 Application Postgresql Postgresql 7.3.6 Version Details Vulnerabilities
8 Application Postgresql Postgresql 7.3.7 Version Details Vulnerabilities
9 Application Postgresql Postgresql 7.3.8 Version Details Vulnerabilities
10 Application Postgresql Postgresql 7.3.9 Version Details Vulnerabilities
11 Application Postgresql Postgresql 7.3.10 Version Details Vulnerabilities
12 Application Postgresql Postgresql 7.3.11 Version Details Vulnerabilities
13 Application Postgresql Postgresql 7.3.12 Version Details Vulnerabilities
14 Application Postgresql Postgresql 7.3.13 Version Details Vulnerabilities
15 Application Postgresql Postgresql 7.3.14 Version Details Vulnerabilities
16 Application Postgresql Postgresql 7.3.15 Version Details Vulnerabilities
17 Application Postgresql Postgresql 7.3.16 Version Details Vulnerabilities
18 Application Postgresql Postgresql 7.3.17 Version Details Vulnerabilities
19 Application Postgresql Postgresql 7.3.18 Version Details Vulnerabilities
20 Application Postgresql Postgresql 7.3.19 Version Details Vulnerabilities
21 Application Postgresql Postgresql 7.4 Version Details Vulnerabilities
22 Application Postgresql Postgresql 7.4.1 Version Details Vulnerabilities
23 Application Postgresql Postgresql 7.4.2 Version Details Vulnerabilities
24 Application Postgresql Postgresql 7.4.3 Version Details Vulnerabilities
25 Application Postgresql Postgresql 7.4.4 Version Details Vulnerabilities
26 Application Postgresql Postgresql 7.4.5 Version Details Vulnerabilities
27 Application Postgresql Postgresql 7.4.6 Version Details Vulnerabilities
28 Application Postgresql Postgresql 7.4.7 Version Details Vulnerabilities
29 Application Postgresql Postgresql 7.4.8 Version Details Vulnerabilities
30 Application Postgresql Postgresql 7.4.9 Version Details Vulnerabilities
31 Application Postgresql Postgresql 7.4.10 Version Details Vulnerabilities
32 Application Postgresql Postgresql 7.4.11 Version Details Vulnerabilities
33 Application Postgresql Postgresql 7.4.12 Version Details Vulnerabilities
34 Application Postgresql Postgresql 7.4.13 Version Details Vulnerabilities
35 Application Postgresql Postgresql 7.4.14 Version Details Vulnerabilities
36 Application Postgresql Postgresql 7.4.16 Version Details Vulnerabilities
37 Application Postgresql Postgresql 7.4.17 Version Details Vulnerabilities
38 Application Postgresql Postgresql 7.4.18 Version Details Vulnerabilities
39 Application Postgresql Postgresql 8.0 Version Details Vulnerabilities
40 Application Postgresql Postgresql 8.0.0 Version Details Vulnerabilities
41 Application Postgresql Postgresql 8.0.1 Version Details Vulnerabilities
42 Application Postgresql Postgresql 8.0.2 Version Details Vulnerabilities
43 Application Postgresql Postgresql 8.0.3 Version Details Vulnerabilities
44 Application Postgresql Postgresql 8.0.4 Version Details Vulnerabilities
45 Application Postgresql Postgresql 8.0.5 Version Details Vulnerabilities
46 Application Postgresql Postgresql 8.0.6 Version Details Vulnerabilities
47 Application Postgresql Postgresql 8.0.7 Version Details Vulnerabilities
48 Application Postgresql Postgresql 8.0.8 Version Details Vulnerabilities
49 Application Postgresql Postgresql 8.0.9 Version Details Vulnerabilities
50 Application Postgresql Postgresql 8.0.10 Version Details Vulnerabilities
51 Application Postgresql Postgresql 8.0.11 Version Details Vulnerabilities
52 Application Postgresql Postgresql 8.0.12 Version Details Vulnerabilities
53 Application Postgresql Postgresql 8.0.13 Version Details Vulnerabilities
54 Application Postgresql Postgresql 8.0.14 Version Details Vulnerabilities
55 Application Postgresql Postgresql 8.1.1 Version Details Vulnerabilities
56 Application Postgresql Postgresql 8.1.2 Version Details Vulnerabilities
57 Application Postgresql Postgresql 8.1.3 Version Details Vulnerabilities
58 Application Postgresql Postgresql 8.1.4 Version Details Vulnerabilities
59 Application Postgresql Postgresql 8.1.5 Version Details Vulnerabilities
60 Application Postgresql Postgresql 8.1.6 Version Details Vulnerabilities
61 Application Postgresql Postgresql 8.1.7 Version Details Vulnerabilities
62 Application Postgresql Postgresql 8.1.8 Version Details Vulnerabilities
63 Application Postgresql Postgresql 8.1.9 Version Details Vulnerabilities
64 Application Postgresql Postgresql 8.1.10 Version Details Vulnerabilities
65 Application Postgresql Postgresql 8.2 Version Details Vulnerabilities
66 Application Postgresql Postgresql 8.2.1 Version Details Vulnerabilities
67 Application Postgresql Postgresql 8.2.2 Version Details Vulnerabilities
68 Application Postgresql Postgresql 8.2.3 Version Details Vulnerabilities
69 Application Postgresql Postgresql 8.2.4 Version Details Vulnerabilities
70 Application Postgresql Postgresql 8.2.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Postgresql Postgresql 70

- References For CVE-2007-6600

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01420154
HP SSRT080006
http://xforce.iss.net/xforce/xfdb/39496
XF postgresql-indexfunctions-priv-escalation(39496)
http://lists.opensuse.org/opensuse-security-announce/2008-02/msg00000.html
SUSE SUSE-SA:2008:005
http://secunia.com/advisories/28359
SECUNIA 28359
http://secunia.com/advisories/28376
SECUNIA 28376
http://secunia.com/advisories/28445
SECUNIA 28445
http://secunia.com/advisories/28438
SECUNIA 28438
http://secunia.com/advisories/28437
SECUNIA 28437
http://secunia.com/advisories/28454
SECUNIA 28454
http://secunia.com/advisories/28455
SECUNIA 28455
http://secunia.com/advisories/28464
SECUNIA 28464
http://secunia.com/advisories/28477
SECUNIA 28477
http://secunia.com/advisories/28479
SECUNIA 28479
http://secunia.com/advisories/28679
SECUNIA 28679
http://secunia.com/advisories/29638
SECUNIA 29638
http://secunia.com/advisories/28698
SECUNIA 28698
http://security.gentoo.org/glsa/glsa-200801-15.xml
GENTOO GLSA-200801-15
http://securitytracker.com/id?1019157
SECTRACK 1019157
http://sunsolve.sun.com/search/document.do?assetkey=1-26-103197-1
SUNALERT 103197
http://sunsolve.sun.com/search/document.do?assetkey=1-66-200559-1
SUNALERT 200559
http://www.debian.org/security/2008/dsa-1460
DEBIAN DSA-1460
http://www.debian.org/security/2008/dsa-1463
DEBIAN DSA-1463
http://www.frsirt.com/english/advisories/2008/0109
VUPEN ADV-2008-0109
http://www.mandriva.com/security/advisories?name=MDVSA-2008:004
MANDRIVA MDVSA-2008:004
http://www.redhat.com/support/errata/RHSA-2008-0039.html
REDHAT RHSA-2008:0039
http://www.redhat.com/support/errata/RHSA-2008-0038.html
REDHAT RHSA-2008:0038
http://www.redhat.com/support/errata/RHSA-2008-0040.html
REDHAT RHSA-2008:0040
http://www.securityfocus.com/archive/1/archive/1/485864/100/0/threaded
BUGTRAQ 20080107 PostgreSQL 2007-01-07 Cumulative Security Release
http://www.securityfocus.com/archive/1/archive/1/486407/100/0/threaded
BUGTRAQ 20080115 rPSA-2008-0016-1 postgresql postgresql-server
https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00397.html
FEDORA FEDORA-2008-0478
http://www.ubuntulinux.org/support/documentation/usn/usn-568-1
UBUNTU USN-568-1
https://issues.rpath.com/browse/RPL-1768 CONFIRM
https://www.redhat.com/archives/fedora-package-announce/2008-January/msg00469.html
FEDORA FEDORA-2008-0552
http://www.frsirt.com/english/advisories/2008/0061
VUPEN ADV-2008-0061
http://www.frsirt.com/english/advisories/2008/1071/references
VUPEN ADV-2008-1071
http://www.securityfocus.com/bid/27163
BID 27163 PostgreSQL Multiple Privilege Escalation and Denial of Service Vulnerabilities Release Date:2013-02-11
http://www.postgresql.org/about/news.905 CONFIRM

- Metasploit Modules Related To CVE-2007-6600

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.