CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-6282

The IPsec implementation in Linux kernel before 2.6.25 allows remote routers to cause a denial of service (crash) via a fragmented ESP packet in which the first fragment does not contain the entire ESP header and IV.
Publish Date : 2008-05-07 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.1
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID 16

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2007-11-29 2008-02-22
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2007-6282 oval:org.opensuse.security:def:20076282 unix
DSA-1630 linux-2.6 -- denial of service/information leak oval:org.mitre.oval:def:8183 unix
DSA-1630-1 fai-kernels linux-2.6 user-mode-linux - several vulnerabilities oval:org.mitre.oval:def:18465 unix
ELSA-2008:0275: kernel security and bug fix update (Important) oval:org.mitre.oval:def:22087 unix
RHSA-2008:0237: kernel security and bug fix update (Important) oval:com.redhat.rhsa:def:20080237 unix
RHSA-2008:0275: kernel security and bug fix update (Important) oval:com.redhat.rhsa:def:20080275 unix
The IPsec implementation in Linux kernel before 2.6.25 allows remote routers to cause a denial of service (crash) via a ... oval:org.mitre.oval:def:10549 unix
USN-625-1 -- linux, linux-source-2.6.15/20/22 vulnerabilities oval:org.mitre.oval:def:17496 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2007-6282

# Product Type Vendor Product Version Update Edition Language
1 OS Redhat Enterprise Linux As 4 Version Details Vulnerabilities
2 OS Redhat Enterprise Linux Es 4 Version Details Vulnerabilities
3 OS Redhat Enterprise Linux Ws 4 Version Details Vulnerabilities
4 OS Redhat Enterprise Linux Desktop 4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Redhat Enterprise Linux 3
Redhat Enterprise Linux Desktop 1

- References For CVE-2007-6282

http://www.redhat.com/support/errata/RHSA-2008-0275.html
REDHAT RHSA-2008:0275
http://lists.opensuse.org/opensuse-security-announce/2008-06/msg00006.html
SUSE SUSE-SA:2008:030
http://xforce.iss.net/xforce/xfdb/42276
XF linux-kernel-esp-dos(42276)
http://www.securityfocus.com/bid/29081
BID 29081 Linux Kernel IPSec Fragmented ESP Packet Remote Denial of Service Vulnerability Release Date:2008-08-27
http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00000.html
SUSE SUSE-SA:2008:031
http://marc.info/?l=linux-netdev&m=120372380411259&w=2
MLIST [linux-netdev] 20080222 [Patch] Crash (BUG()) when handling fragmented ESP packets
http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00002.html
SUSE SUSE-SA:2008:032
https://bugzilla.redhat.com/show_bug.cgi?id=404291
http://www.redhat.com/support/errata/RHSA-2008-0585.html
REDHAT RHSA-2008:0585
http://www.redhat.com/support/errata/RHSA-2008-0237.html
REDHAT RHSA-2008:0237
http://www.debian.org/security/2008/dsa-1630
DEBIAN DSA-1630
http://secunia.com/advisories/31628
SECUNIA 31628
http://secunia.com/advisories/31551
SECUNIA 31551
http://secunia.com/advisories/30294
SECUNIA 30294
http://secunia.com/advisories/30112
SECUNIA 30112
http://secunia.com/advisories/30818
SECUNIA 30818
http://secunia.com/advisories/30962
SECUNIA 30962
http://secunia.com/advisories/30890
SECUNIA 30890
http://secunia.com/advisories/31107
SECUNIA 31107
http://www.ubuntu.com/usn/usn-625-1
UBUNTU USN-625-1

- Metasploit Modules Related To CVE-2007-6282

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.