CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-3474

Multiple unspecified vulnerabilities in the GIF reader in the GD Graphics Library (libgd) before 2.0.35 have unspecified impact and user-assisted remote attack vectors.
Publish Date : 2007-06-28 Last Update Date : 2012-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.6
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID CWE id is not defined for this vulnerability

- Vendor Statements

This issue did not affect the versions of gd as shipped with Red Hat Enterprise Linux 2.1 or 3 as they did not offer GIF image support. We do not plan to backport a fix for this issue to the gd packages as shipped in Red Hat Enterprise Linux 4 and 5 due to the low likelihood of an application affected by this problem being exposed in a way that would allow a trust boundary to be crossed.
Source: Redhat

- Products Affected By CVE-2007-3474

# Product Type Vendor Product Version Update Edition Language
1 Application Libgd Gd Graphics Library 2.0.33 Version Details Vulnerabilities
2 Application Libgd Gd Graphics Library 2.0.34 RC2 Version Details Vulnerabilities
3 Application Libgd Gd Graphics Library 2.0.34 RC1 Version Details Vulnerabilities
4 Application Libgd Gd Graphics Library 2.0.34 Version Details Vulnerabilities
5 Application Libgd Gd Graphics Library 2.0.35 RC2 Version Details Vulnerabilities
6 Application Libgd Gd Graphics Library 2.0.35 RC1 Version Details Vulnerabilities
7 Application Libgd Gd Graphics Library 2.0.35 RC5 Version Details Vulnerabilities
8 Application Libgd Gd Graphics Library 2.0.35 RC4 Version Details Vulnerabilities
9 Application Libgd Gd Graphics Library 2.0.35 RC3 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Libgd Gd Graphics Library 9

- References For CVE-2007-3474

http://fedoranews.org/updates/FEDORA-2007-205.shtml
FEDORA FEDORA-2007-2055
ftp://ftp.slackware.com/pub/slackware/slackware-11.0/patches/packages/gd-2.0.35-i486-1_slack11.0.tgz CONFIRM
http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052848.html
FEDORA FEDORA-2010-19033
http://lists.fedoraproject.org/pipermail/package-announce/2011-January/052854.html
FEDORA FEDORA-2010-19022
http://osvdb.org/37743
OSVDB 37743
http://secunia.com/advisories/25855
SECUNIA 25855
http://secunia.com/advisories/25860
SECUNIA 25860
http://secunia.com/advisories/26272
SECUNIA 26272
http://secunia.com/advisories/26390
SECUNIA 26390
http://secunia.com/advisories/26415
SECUNIA 26415
http://secunia.com/advisories/26467
SECUNIA 26467
http://secunia.com/advisories/26663
SECUNIA 26663
http://secunia.com/advisories/26766
SECUNIA 26766
http://secunia.com/advisories/26856
SECUNIA 26856
http://secunia.com/advisories/30168
SECUNIA 30168
http://secunia.com/advisories/42813
SECUNIA 42813
http://security.gentoo.org/glsa/glsa-200708-05.xml
GENTOO GLSA-200708-05
http://security.gentoo.org/glsa/glsa-200711-34.xml
GENTOO GLSA-200711-34
http://security.gentoo.org/glsa/glsa-200805-13.xml
GENTOO GLSA-200805-13
http://www.mandriva.com/security/advisories?name=MDKSA-2007:153
MANDRIVA MDKSA-2007:153
http://www.mandriva.com/security/advisories?name=MDKSA-2007:164
MANDRIVA MDKSA-2007:164
http://www.redhat.com/archives/fedora-package-announce/2007-September/msg00311.html
FEDORA FEDORA-2007-692
http://www.securityfocus.com/bid/24651
BID 24651 GD Graphics Library Multiple Vulnerabilities Release Date:2009-11-05
http://www.securityfocus.com/archive/1/archive/1/478796/100/0/threaded
BUGTRAQ 20070907 FLEA-2007-0052-1 gd
http://www.vupen.com/english/advisories/2011/0022
VUPEN ADV-2011-0022
http://www.vupen.com/english/advisories/2007/2336
VUPEN ADV-2007-2336
http://www.trustix.org/errata/2007/0024/
TRUSTIX 2007-0024
http://www.libgd.org/ReleaseNote020035 CONFIRM
http://xforce.iss.net/xforce/xfdb/35110
XF gd-gifreader-unspecified(35110)
https://issues.rpath.com/browse/RPL-1643 CONFIRM
https://bugzilla.redhat.com/show_bug.cgi?id=277421 CONFIRM

- Metasploit Modules Related To CVE-2007-3474

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.