CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-3106

lib/info.c in libvorbis 1.1.2, and possibly other versions before 1.2.0, allows context-dependent attackers to cause a denial of service and possibly execute arbitrary code via invalid (1) blocksize_0 and (2) blocksize_1 values, which trigger a "heap overwrite" in the _01inverse function in res0.c. NOTE: this issue has been RECAST so that CVE-2007-4029 handles additional vectors.
Publish Date : 2007-07-26 Last Update Date : 2011-10-11
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.8
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Denial Of ServiceExecute Code
CWE ID 399

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2007-06-21 2007-07-26
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2007-3106 oval:org.opensuse.security:def:20073106 unix
DSA-1471 libvorbis -- several vulnerabilities oval:org.mitre.oval:def:8019 unix
DSA-1471-1 libvorbis - several vulnerabilities oval:org.mitre.oval:def:18690 unix
ELSA-2007:0845: libvorbis security update (Important) oval:org.mitre.oval:def:22328 unix
lib/info.c in libvorbis 1.1.2, and possibly other versions before 1.2.0, allows context-dependent attackers to cause a d... oval:org.mitre.oval:def:11449 unix
RHSA-2007:0845: libvorbis security update (Important) oval:com.redhat.rhsa:def:20070845 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2007-3106

# Product Type Vendor Product Version Update Edition Language
1 Application Libvorbis Libvorbis 1.1.2 Version Details Vulnerabilities
2 Application Libvorbis Libvorbis 1.2.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Libvorbis Libvorbis 2

- References For CVE-2007-3106

http://www.vupen.com/english/advisories/2007/2760
VUPEN ADV-2007-2760
http://secunia.com/advisories/24923
SECUNIA 24923
http://secunia.com/advisories/26087
SECUNIA 26087
http://secunia.com/advisories/26232
SECUNIA 26232
http://secunia.com/advisories/26299
SECUNIA 26299
http://secunia.com/advisories/26429
SECUNIA 26429
http://secunia.com/advisories/26535
SECUNIA 26535
http://secunia.com/advisories/26865
SECUNIA 26865
http://secunia.com/advisories/27099
SECUNIA 27099
http://secunia.com/advisories/28614
SECUNIA 28614
http://www.debian.org/security/2008/dsa-1471
DEBIAN DSA-1471
http://security.gentoo.org/glsa/glsa-200710-03.xml
GENTOO GLSA-200710-03
http://www.isecpartners.com/advisories/2007-003-libvorbis.txt
http://www.redhat.com/support/errata/RHSA-2007-0912.html
REDHAT RHSA-2007:0912
http://www.redhat.com/support/errata/RHSA-2007-0845.html
REDHAT RHSA-2007:0845
http://www.mandriva.com/security/advisories?name=MDKSA-2007:167-1
MANDRIVA MDKSA-2007:167-1
http://www.securityfocus.com/archive/1/archive/1/474729/100/0/threaded
BUGTRAQ 20070726 libvorbis 1.1.2 - Multiple memory corruption flaws
http://www.securityfocus.com/bid/25082
BID 25082 Libvorbis Denial Of Service And Memory Corruption Vulnerabilities Release Date:2008-01-22
http://www.vupen.com/english/advisories/2007/2698
VUPEN ADV-2007-2698
http://www.ubuntu.com/usn/usn-498-1
UBUNTU USN-498-1
https://bugzilla.redhat.com/show_bug.cgi?id=249780 CONFIRM
https://bugzilla.redhat.com/show_bug.cgi?id=245991 CONFIRM
http://www.tellini.org/blog/archives/32-Music-Box-1.6.html CONFIRM
http://xforce.iss.net/xforce/xfdb/35622
XF libvorbis-inverse-code-execution(35622)
https://issues.rpath.com/browse/RPL-1590 CONFIRM
https://trac.xiph.org/changeset/13160 CONFIRM

- Vulnerability Conditions

Vulnerability is valid if product versions listed below are used TOGETHER WITH(AND)

- Metasploit Modules Related To CVE-2007-3106

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.