CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-2844

PHP 4.x and 5.x before 5.2.1, when running on multi-threaded systems, does not ensure thread safety for libc crypt function calls using protection schemes such as a mutex, which creates race conditions that allow remote attackers to overwrite internal program memory and gain system access.
Publish Date : 2007-05-24 Last Update Date : 2012-11-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s)
CWE ID CWE id is not defined for this vulnerability

- Vendor Statements

Not vulnerable. PHP is not built or supported in a multi-threaded environment in the packages distributed in Red Hat Enterprise Linux or Application Stack.
Source: Redhat

- Products Affected By CVE-2007-2844

# Product Type Vendor Product Version Update Edition Language
1 Application PHP PHP 4.0 RC2 Version Details Vulnerabilities
2 Application PHP PHP 4.0 Beta1 Version Details Vulnerabilities
3 Application PHP PHP 4.0 Beta2 Version Details Vulnerabilities
4 Application PHP PHP 4.0 Beta3 Version Details Vulnerabilities
5 Application PHP PHP 4.0 Beta4 Version Details Vulnerabilities
6 Application PHP PHP 4.0 RC1 Version Details Vulnerabilities
7 Application PHP PHP 4.0 Beta 4 Patch1 Version Details Vulnerabilities
8 Application PHP PHP 4.0 Version Details Vulnerabilities
9 Application PHP PHP 4.0.0 Version Details Vulnerabilities
10 Application PHP PHP 4.0.1 Version Details Vulnerabilities
11 Application PHP PHP 4.0.1 Patch1 Version Details Vulnerabilities
12 Application PHP PHP 4.0.1 Patch2 Version Details Vulnerabilities
13 Application PHP PHP 4.0.2 Version Details Vulnerabilities
14 Application PHP PHP 4.0.3 Version Details Vulnerabilities
15 Application PHP PHP 4.0.3 Patch1 Version Details Vulnerabilities
16 Application PHP PHP 4.0.4 Version Details Vulnerabilities
17 Application PHP PHP 4.0.4 Patch1 Version Details Vulnerabilities
18 Application PHP PHP 4.0.5 Version Details Vulnerabilities
19 Application PHP PHP 4.0.6 Version Details Vulnerabilities
20 Application PHP PHP 4.0.7 Version Details Vulnerabilities
21 Application PHP PHP 4.0.7 RC1 Version Details Vulnerabilities
22 Application PHP PHP 4.0.7 RC2 Version Details Vulnerabilities
23 Application PHP PHP 4.0.7 RC3 Version Details Vulnerabilities
24 Application PHP PHP 4.1.0 Version Details Vulnerabilities
25 Application PHP PHP 4.1.1 Version Details Vulnerabilities
26 Application PHP PHP 4.1.2 Version Details Vulnerabilities
27 Application PHP PHP 4.2.0 Version Details Vulnerabilities
28 Application PHP PHP 4.2.1 Version Details Vulnerabilities
29 Application PHP PHP 4.2.2 Version Details Vulnerabilities
30 Application PHP PHP 4.2.3 Version Details Vulnerabilities
31 Application PHP PHP 4.3 Version Details Vulnerabilities
32 Application PHP PHP 4.3.1 Version Details Vulnerabilities
33 Application PHP PHP 4.3.2 Version Details Vulnerabilities
34 Application PHP PHP 4.3.3 Version Details Vulnerabilities
35 Application PHP PHP 4.3.4 Version Details Vulnerabilities
36 Application PHP PHP 4.3.5 Version Details Vulnerabilities
37 Application PHP PHP 4.3.6 Version Details Vulnerabilities
38 Application PHP PHP 4.3.7 Version Details Vulnerabilities
39 Application PHP PHP 4.3.8 Version Details Vulnerabilities
40 Application PHP PHP 4.3.9 Version Details Vulnerabilities
41 Application PHP PHP 4.3.10 Version Details Vulnerabilities
42 Application PHP PHP 4.3.11 Version Details Vulnerabilities
43 Application PHP PHP 4.4.0 Version Details Vulnerabilities
44 Application PHP PHP 4.4.1 Version Details Vulnerabilities
45 Application PHP PHP 4.4.2 Version Details Vulnerabilities
46 Application PHP PHP 4.4.3 Version Details Vulnerabilities
47 Application PHP PHP 4.4.4 Version Details Vulnerabilities
48 Application PHP PHP 4.4.5 Version Details Vulnerabilities
49 Application PHP PHP 4.4.6 Version Details Vulnerabilities
50 Application PHP PHP 5.0 RC1 Version Details Vulnerabilities
51 Application PHP PHP 5.0 RC2 Version Details Vulnerabilities
52 Application PHP PHP 5.0 RC3 Version Details Vulnerabilities
53 Application PHP PHP 5.0.0 RC1 Version Details Vulnerabilities
54 Application PHP PHP 5.0.0 Version Details Vulnerabilities
55 Application PHP PHP 5.0.0 RC2 Version Details Vulnerabilities
56 Application PHP PHP 5.0.0 Beta1 Version Details Vulnerabilities
57 Application PHP PHP 5.0.0 RC3 Version Details Vulnerabilities
58 Application PHP PHP 5.0.0 Beta2 Version Details Vulnerabilities
59 Application PHP PHP 5.0.0 Beta3 Version Details Vulnerabilities
60 Application PHP PHP 5.0.0 Beta4 Version Details Vulnerabilities
61 Application PHP PHP 5.0.1 Version Details Vulnerabilities
62 Application PHP PHP 5.0.2 Version Details Vulnerabilities
63 Application PHP PHP 5.0.3 Version Details Vulnerabilities
64 Application PHP PHP 5.0.4 Version Details Vulnerabilities
65 Application PHP PHP 5.0.5 Version Details Vulnerabilities
66 Application PHP PHP 5.1 Version Details Vulnerabilities
67 Application PHP PHP 5.1.0 Version Details Vulnerabilities
68 Application PHP PHP 5.1.1 Version Details Vulnerabilities
69 Application PHP PHP 5.1.2 Version Details Vulnerabilities
70 Application PHP PHP 5.1.3 Version Details Vulnerabilities
71 Application PHP PHP 5.1.4 Version Details Vulnerabilities
72 Application PHP PHP 5.1.5 Version Details Vulnerabilities
73 Application PHP PHP 5.1.6 Version Details Vulnerabilities
74 Application PHP PHP 5.2.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
PHP PHP 74

- References For CVE-2007-2844

http://www.securityfocus.com/bid/24109
BID 24109 PHP Crypt Function Authentication Bypass Vulnerability Release Date:2007-05-23
http://secunia.com/advisories/25434
SECUNIA 25434
http://xforce.iss.net/xforce/xfdb/34601
XF php-crypt-authentication-bypass(34601)
http://osvdb.org/36088
OSVDB 36088
http://blog.php-security.org/archives/82-Suhosin-0.9.20-and-crypt-Thread-Safety-Vulnerability.html

- Metasploit Modules Related To CVE-2007-2844

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.