CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2007-0906

Multiple buffer overflows in PHP before 5.2.1 allow attackers to cause a denial of service and possibly execute arbitrary code via unspecified vectors in the (1) session, (2) zip, (3) imap, and (4) sqlite extensions; (5) stream filters; and the (6) str_replace, (7) mail, (8) ibase_delete_user, (9) ibase_add_user, and (10) ibase_modify_user functions. NOTE: vector 6 might actually be an integer overflow (CVE-2007-1885). NOTE: as of 20070411, vector (3) might involve the imap_mail_compose function (CVE-2007-1825).
Publish Date : 2007-02-13 Last Update Date : 2011-09-20
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Denial Of ServiceExecute CodeOverflow
CWE ID 119

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2007-02-14 2007-02-14
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2007-0906 oval:org.opensuse.security:def:20070906 unix
ELSA-2007:0082: php security update (Important) oval:org.mitre.oval:def:22487 unix
Multiple buffer overflows in PHP before 5.2.1 allow attackers to cause a denial of service and possibly execute arbitrar... oval:org.mitre.oval:def:8992 unix
RHSA-2007:0076: php security update (Important) oval:com.redhat.rhsa:def:20070076 unix
RHSA-2007:0082: php security update (Important) oval:com.redhat.rhsa:def:20070082 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2007-0906

# Product Type Vendor Product Version Update Edition Language
1 Application PHP PHP 3.0 Version Details Vulnerabilities
2 Application PHP PHP 3.0.1 Version Details Vulnerabilities
3 Application PHP PHP 3.0.2 Version Details Vulnerabilities
4 Application PHP PHP 3.0.3 Version Details Vulnerabilities
5 Application PHP PHP 3.0.4 Version Details Vulnerabilities
6 Application PHP PHP 3.0.5 Version Details Vulnerabilities
7 Application PHP PHP 3.0.6 Version Details Vulnerabilities
8 Application PHP PHP 3.0.7 Version Details Vulnerabilities
9 Application PHP PHP 3.0.8 Version Details Vulnerabilities
10 Application PHP PHP 3.0.9 Version Details Vulnerabilities
11 Application PHP PHP 3.0.10 Version Details Vulnerabilities
12 Application PHP PHP 3.0.11 Version Details Vulnerabilities
13 Application PHP PHP 3.0.12 Version Details Vulnerabilities
14 Application PHP PHP 3.0.13 Version Details Vulnerabilities
15 Application PHP PHP 3.0.14 Version Details Vulnerabilities
16 Application PHP PHP 3.0.15 Version Details Vulnerabilities
17 Application PHP PHP 3.0.16 Version Details Vulnerabilities
18 Application PHP PHP 3.0.17 Version Details Vulnerabilities
19 Application PHP PHP 3.0.18 Version Details Vulnerabilities
20 Application PHP PHP 4.0 Version Details Vulnerabilities
21 Application PHP PHP 4.0.1 Version Details Vulnerabilities
22 Application PHP PHP 4.0.1 Patch2 Version Details Vulnerabilities
23 Application PHP PHP 4.0.1 Patch1 Version Details Vulnerabilities
24 Application PHP PHP 4.0.2 Version Details Vulnerabilities
25 Application PHP PHP 4.0.3 Patch1 Version Details Vulnerabilities
26 Application PHP PHP 4.0.3 Version Details Vulnerabilities
27 Application PHP PHP 4.0.4 Version Details Vulnerabilities
28 Application PHP PHP 4.0.5 Version Details Vulnerabilities
29 Application PHP PHP 4.0.6 Version Details Vulnerabilities
30 Application PHP PHP 4.0.7 RC3 Version Details Vulnerabilities
31 Application PHP PHP 4.0.7 RC2 Version Details Vulnerabilities
32 Application PHP PHP 4.0.7 RC1 Version Details Vulnerabilities
33 Application PHP PHP 4.0.7 Version Details Vulnerabilities
34 Application PHP PHP 4.1.0 Version Details Vulnerabilities
35 Application PHP PHP 4.1.1 Version Details Vulnerabilities
36 Application PHP PHP 4.1.2 Version Details Vulnerabilities
37 Application PHP PHP 4.2 DEV Version Details Vulnerabilities
38 Application PHP PHP 4.2.0 Version Details Vulnerabilities
39 Application PHP PHP 4.2.1 Version Details Vulnerabilities
40 Application PHP PHP 4.2.2 Version Details Vulnerabilities
41 Application PHP PHP 4.2.3 Version Details Vulnerabilities
42 Application PHP PHP 4.3 Version Details Vulnerabilities
43 Application PHP PHP 4.3.1 Version Details Vulnerabilities
44 Application PHP PHP 4.3.2 Version Details Vulnerabilities
45 Application PHP PHP 4.3.3 Version Details Vulnerabilities
46 Application PHP PHP 4.3.4 Version Details Vulnerabilities
47 Application PHP PHP 4.3.5 Version Details Vulnerabilities
48 Application PHP PHP 4.3.6 Version Details Vulnerabilities
49 Application PHP PHP 4.3.7 Version Details Vulnerabilities
50 Application PHP PHP 4.3.8 Version Details Vulnerabilities
51 Application PHP PHP 4.3.9 Version Details Vulnerabilities
52 Application PHP PHP 4.3.10 Version Details Vulnerabilities
53 Application PHP PHP 4.3.11 Version Details Vulnerabilities
54 Application PHP PHP 4.4.0 Version Details Vulnerabilities
55 Application PHP PHP 4.4.1 Version Details Vulnerabilities
56 Application PHP PHP 4.4.2 Version Details Vulnerabilities
57 Application PHP PHP 4.4.3 Version Details Vulnerabilities
58 Application PHP PHP 4.4.4 Version Details Vulnerabilities
59 Application PHP PHP 5.0 RC2 Version Details Vulnerabilities
60 Application PHP PHP 5.0 RC1 Version Details Vulnerabilities
61 Application PHP PHP 5.0 RC3 Version Details Vulnerabilities
62 Application PHP PHP 5.0.0 Version Details Vulnerabilities
63 Application PHP PHP 5.0.1 Version Details Vulnerabilities
64 Application PHP PHP 5.0.2 Version Details Vulnerabilities
65 Application PHP PHP 5.0.3 Version Details Vulnerabilities
66 Application PHP PHP 5.0.4 Version Details Vulnerabilities
67 Application PHP PHP 5.0.5 Version Details Vulnerabilities
68 Application PHP PHP 5.1 Version Details Vulnerabilities
69 Application PHP PHP 5.1.1 Version Details Vulnerabilities
70 Application PHP PHP 5.1.2 Version Details Vulnerabilities
71 Application PHP PHP 5.1.3 Version Details Vulnerabilities
72 Application PHP PHP 5.1.4 Version Details Vulnerabilities
73 Application PHP PHP 5.1.5 Version Details Vulnerabilities
74 Application PHP PHP 5.1.6 Version Details Vulnerabilities
75 Application PHP PHP 5.2.0 Version Details Vulnerabilities
76 OS Trustix Secure Linux 2.2 Version Details Vulnerabilities
77 OS Trustix Secure Linux 3.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
PHP PHP 75
Trustix Secure Linux 2

- References For CVE-2007-0906

ftp://patches.sgi.com/support/free/security/advisories/20070201-01-P.asc
SGI 20070201-01-P
http://osvdb.org/34706
OSVDB 34706
http://lists.suse.com/archive/suse-security-announce/2007-Mar/0003.html
SUSE SUSE-SA:2007:020
http://lists.opensuse.org/opensuse-security-announce/2007-07/msg00006.html
SUSE SUSE-SA:2007:044
http://osvdb.org/34707
OSVDB 34707
http://osvdb.org/34712
OSVDB 34712
http://osvdb.org/34711
OSVDB 34711
http://osvdb.org/34710
OSVDB 34710
http://osvdb.org/34709
OSVDB 34709
http://osvdb.org/34708
OSVDB 34708
http://osvdb.org/34714
OSVDB 34714
http://osvdb.org/34713
OSVDB 34713
http://rhn.redhat.com/errata/RHSA-2007-0089.html
REDHAT RHSA-2007:0089
http://osvdb.org/34715
OSVDB 34715
http://secunia.com/advisories/24089
SECUNIA 24089
http://secunia.com/advisories/24195
SECUNIA 24195
http://secunia.com/advisories/24217
SECUNIA 24217
http://secunia.com/advisories/24236
SECUNIA 24236
http://secunia.com/advisories/24248
SECUNIA 24248
http://secunia.com/advisories/24284
SECUNIA 24284
http://secunia.com/advisories/24295
SECUNIA 24295
http://secunia.com/advisories/24322
SECUNIA 24322
http://secunia.com/advisories/24419
SECUNIA 24419
http://secunia.com/advisories/24421
SECUNIA 24421
http://secunia.com/advisories/24432
SECUNIA 24432
http://secunia.com/advisories/24514
SECUNIA 24514
http://secunia.com/advisories/24606
SECUNIA 24606
http://secunia.com/advisories/24642
SECUNIA 24642
http://security.gentoo.org/glsa/glsa-200703-21.xml
GENTOO GLSA-200703-21
http://secunia.com/advisories/26048
SECUNIA 26048
http://secunia.com/advisories/24945
SECUNIA 24945
http://support.avaya.com/elmodocs2/security/ASA-2007-101.htm CONFIRM
http://support.avaya.com/elmodocs2/security/ASA-2007-136.htm CONFIRM
http://www.mandriva.com/security/advisories?name=MDKSA-2007:048
MANDRIVA MDKSA-2007:048
http://www.osvdb.org/32776
OSVDB 32776
http://www.openpkg.com/security/advisories/OpenPKG-SA-2007.010.html
OPENPKG OpenPKG-SA-2007.010
http://www.php.net/ChangeLog-5.php#5.2.1 CONFIRM
http://www.php.net/releases/5_2_1.php CONFIRM
http://www.redhat.com/support/errata/RHSA-2007-0076.html
REDHAT RHSA-2007:0076
http://www.redhat.com/support/errata/RHSA-2007-0082.html
REDHAT RHSA-2007:0082
http://www.vupen.com/english/advisories/2007/0546
VUPEN ADV-2007-0546
http://www.us.debian.org/security/2007/dsa-1264
DEBIAN DSA-1264
http://www.ubuntu.com/usn/usn-424-2
UBUNTU USN-424-2
http://www.ubuntu.com/usn/usn-424-1
UBUNTU USN-424-1
http://www.redhat.com/support/errata/RHSA-2007-0081.html
REDHAT RHSA-2007:0081
http://www.redhat.com/support/errata/RHSA-2007-0088.html
REDHAT RHSA-2007:0088
http://www.securityfocus.com/archive/1/archive/1/461462/100/0/threaded
BUGTRAQ 20070227 rPSA-2007-0043-1 php php-mysql php-pgsql
http://www.securityfocus.com/archive/1/archive/1/466166/100/0/threaded
BUGTRAQ 20070418 rPSA-2007-0073-1 php php-mysql php-pgsql
http://www.securitytracker.com/id?1017671
SECTRACK 1017671
http://www.trustix.org/errata/2007/0009/
TRUSTIX 2007-0009
https://issues.rpath.com/browse/RPL-1088 CONFIRM
https://issues.rpath.com/browse/RPL-1268 CONFIRM
http://www.securityfocus.com/bid/22496
BID 22496 PHP 5.2.0 and Prior Versions Multiple Vulnerabilities Release Date:2007-07-12

- Metasploit Modules Related To CVE-2007-0906

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.