CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-7166

IBM WebSphere Application Server (WAS) 5.1.1.9 and earlier allows remote attackers to obtain JSP source code and other sensitive information via "a specific JSP URL."
Publish Date : 2007-03-20 Last Update Date : 2008-09-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID CWE id is not defined for this vulnerability

- Products Affected By CVE-2006-7166

# Product Type Vendor Product Version Update Edition Language
1 Application IBM Websphere Application Server 5.0 Version Details Vulnerabilities
2 Application IBM Websphere Application Server 5.0.1 Version Details Vulnerabilities
3 Application IBM Websphere Application Server 5.0.2 Version Details Vulnerabilities
4 Application IBM Websphere Application Server 5.0.2.1 Version Details Vulnerabilities
5 Application IBM Websphere Application Server 5.0.2.2 Version Details Vulnerabilities
6 Application IBM Websphere Application Server 5.0.2.3 Version Details Vulnerabilities
7 Application IBM Websphere Application Server 5.0.2.4 Version Details Vulnerabilities
8 Application IBM Websphere Application Server 5.0.2.5 Version Details Vulnerabilities
9 Application IBM Websphere Application Server 5.0.2.6 Version Details Vulnerabilities
10 Application IBM Websphere Application Server 5.0.2.7 Version Details Vulnerabilities
11 Application IBM Websphere Application Server 5.0.2.8 Version Details Vulnerabilities
12 Application IBM Websphere Application Server 5.0.2.9 Version Details Vulnerabilities
13 Application IBM Websphere Application Server 5.0.2.10 Version Details Vulnerabilities
14 Application IBM Websphere Application Server 5.0.2.11 Version Details Vulnerabilities
15 Application IBM Websphere Application Server 5.0.2.12 Version Details Vulnerabilities
16 Application IBM Websphere Application Server 5.0.2.13 Version Details Vulnerabilities
17 Application IBM Websphere Application Server 5.0.2.14 Version Details Vulnerabilities
18 Application IBM Websphere Application Server 5.0.2.15 Version Details Vulnerabilities
19 Application IBM Websphere Application Server 5.0.2.16 Version Details Vulnerabilities
20 Application IBM Websphere Application Server 5.1.0 Version Details Vulnerabilities
21 Application IBM Websphere Application Server 5.1.0.2 Version Details Vulnerabilities
22 Application IBM Websphere Application Server 5.1.0.3 Version Details Vulnerabilities
23 Application IBM Websphere Application Server 5.1.0.4 Version Details Vulnerabilities
24 Application IBM Websphere Application Server 5.1.0.5 Version Details Vulnerabilities
25 Application IBM Websphere Application Server 5.1.1 Version Details Vulnerabilities
26 Application IBM Websphere Application Server 5.1.1.1 Version Details Vulnerabilities
27 Application IBM Websphere Application Server 5.1.1.2 Version Details Vulnerabilities
28 Application IBM Websphere Application Server 5.1.1.3 Version Details Vulnerabilities
29 Application IBM Websphere Application Server 5.1.1.4 Version Details Vulnerabilities
30 Application IBM Websphere Application Server 5.1.1.5 Version Details Vulnerabilities
31 Application IBM Websphere Application Server 5.1.1.6 Version Details Vulnerabilities
32 Application IBM Websphere Application Server 5.1.1.7 Version Details Vulnerabilities
33 Application IBM Websphere Application Server 5.1.1.8 Version Details Vulnerabilities
34 Application IBM Websphere Application Server 5.1.1.9 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
IBM Websphere Application Server 34

- References For CVE-2006-7166

http://www.securityfocus.com/bid/22991
BID 22991 IBM WebSphere Application Server Source Code Disclosure Vulnerability Release Date:2007-03-16
http://secunia.com/advisories/24478
SECUNIA 24478
http://www-1.ibm.com/support/docview.wss?uid=swg21243541 CONFIRM
http://www.frsirt.com/english/advisories/2007/0970
VUPEN ADV-2007-0970
http://www-1.ibm.com/support/docview.wss?uid=swg24011720
AIXAPAR PK20181

- Metasploit Modules Related To CVE-2006-7166

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.