CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-6745

Multiple unspecified vulnerabilities in Sun Java Development Kit (JDK) and Java Runtime Environment (JRE) 5.0 Update 7 and earlier, and Java System Development Kit (SDK) and JRE 1.4.2_12 and earlier 1.4.x versions, allow attackers to develop Java applets or applications that are able to gain privileges, related to serialization in JRE.
Publish Date : 2006-12-26 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.3
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Gain privileges
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat critical 2007-01-04 2007-01-04
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2006-6745 oval:org.opensuse.security:def:20066745 unix
Multiple unspecified vulnerabilities in Sun Java Development Kit (JDK) and Java Runtime Environment (JRE) 5.0 Update 7 a... oval:org.mitre.oval:def:9621 unix
RHSA-2007:0062: java-1.4.2-ibm security update (Critical) oval:com.redhat.rhsa:def:20070062 unix
RHSA-2007:0073: java-1.5.0-ibm security update (Critical) oval:com.redhat.rhsa:def:20070073 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-6745

# Product Type Vendor Product Version Update Edition Language
1 Application SUN J2se 1.4 SDK Version Details Vulnerabilities
2 Application SUN J2se 1.4.1 SDK Version Details Vulnerabilities
3 Application SUN J2se 1.4.2 01 SDK Version Details Vulnerabilities
4 Application SUN J2se 1.4.2 12 Version Details Vulnerabilities
5 Application SUN J2se 1.4.2 07 SDK Version Details Vulnerabilities
6 Application SUN J2se 1.4.2 02 SDK Version Details Vulnerabilities
7 Application SUN J2se 1.4.2 08 Version Details Vulnerabilities
8 Application SUN J2se 1.4.2 03 SDK Version Details Vulnerabilities
9 Application SUN J2se 1.4.2 09 Version Details Vulnerabilities
10 Application SUN J2se 1.4.2 04 SDK Version Details Vulnerabilities
11 Application SUN J2se 1.4.2 10 Version Details Vulnerabilities
12 Application SUN J2se 1.4.2 05 SDK Version Details Vulnerabilities
13 Application SUN J2se 1.4.2 SDK Version Details Vulnerabilities
14 Application SUN J2se 1.4.2 11 Version Details Vulnerabilities
15 Application SUN J2se 1.4.2 06 SDK Version Details Vulnerabilities
16 Application SUN J2se 5.0 Update3 Version Details Vulnerabilities
17 Application SUN J2se 5.0 Update4 Version Details Vulnerabilities
18 Application SUN J2se 5.0 Update5 Version Details Vulnerabilities
19 Application SUN J2se 5.0 SDK Version Details Vulnerabilities
20 Application SUN J2se 5.0 Update6 Version Details Vulnerabilities
21 Application SUN J2se 5.0 Update1 SDK Version Details Vulnerabilities
22 Application SUN J2se 5.0 Update7 Version Details Vulnerabilities
23 Application SUN J2se 5.0 Update2 SDK Version Details Vulnerabilities
24 Application SUN JRE 1.4.1 Version Details Vulnerabilities
25 Application SUN JRE 1.4.2 Update6 Version Details Vulnerabilities
26 Application SUN JRE 1.4.2 Update13 Version Details Vulnerabilities
27 Application SUN JRE 1.4.2 Version Details Vulnerabilities
28 Application SUN JRE 1.4.2 Update7 Version Details Vulnerabilities
29 Application SUN JRE 1.4.2 Update2 Version Details Vulnerabilities
30 Application SUN JRE 1.4.2 Update1 Version Details Vulnerabilities
31 Application SUN JRE 1.4.2 Update8 Version Details Vulnerabilities
32 Application SUN JRE 1.4.2 Update3 Version Details Vulnerabilities
33 Application SUN JRE 1.4.2 Update10 Version Details Vulnerabilities
34 Application SUN JRE 1.4.2 Update9 Version Details Vulnerabilities
35 Application SUN JRE 1.4.2 Update4 Version Details Vulnerabilities
36 Application SUN JRE 1.4.2 Update11 Version Details Vulnerabilities
37 Application SUN JRE 1.4.2 Update5 Version Details Vulnerabilities
38 Application SUN JRE 1.4.2 Update12 Version Details Vulnerabilities
39 Application SUN JRE 1.5.0 Update7 Version Details Vulnerabilities
40 Application SUN JRE 1.5.0 Update2 Version Details Vulnerabilities
41 Application SUN JRE 1.5.0 Update3 Version Details Vulnerabilities
42 Application SUN JRE 1.5.0 Update4 Version Details Vulnerabilities
43 Application SUN JRE 1.5.0 Update5 Version Details Vulnerabilities
44 Application SUN JRE 1.5.0 Version Details Vulnerabilities
45 Application SUN JRE 1.5.0 Update6 Version Details Vulnerabilities
46 Application SUN JRE 1.5.0 Update1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
SUN J2se 23
SUN JRE 23

- References For CVE-2006-6745

http://docs.info.apple.com/article.html?artnum=307177
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c00876579
HP HPSBUX02196
http://lists.apple.com/archives/Security-announce/2007/Dec/msg00001.html
APPLE APPLE-SA-2007-12-14
http://secunia.com/advisories/23445
SECUNIA 23445
http://lists.suse.com/archive/suse-security-announce/2007-Jan/0003.html
SUSE SUSE-SA:2007:003
http://secunia.com/advisories/23650
SECUNIA 23650
http://secunia.com/advisories/23835
SECUNIA 23835
http://secunia.com/advisories/24099
SECUNIA 24099
http://secunia.com/advisories/24189
SECUNIA 24189
http://secunia.com/advisories/24468
SECUNIA 24468
http://secunia.com/advisories/25283
SECUNIA 25283
http://secunia.com/advisories/25404
SECUNIA 25404
http://secunia.com/advisories/26049
SECUNIA 26049
http://secunia.com/advisories/26119
SECUNIA 26119
http://secunia.com/advisories/28115
SECUNIA 28115
http://security.gentoo.org/glsa/glsa-200701-15.xml
GENTOO GLSA-200701-15
http://security.gentoo.org/glsa/glsa-200702-08.xml
GENTOO GLSA-200702-08
http://support.novell.com/techcenter/psdb/4f850d1e2b871db609de64ec70f0089c.html CONFIRM
http://support.novell.com/techcenter/psdb/d2f549cc040cd81ae4a268bb5edfe918.html CONFIRM
http://www.frsirt.com/english/advisories/2007/0936
VUPEN ADV-2007-0936
http://www.frsirt.com/english/advisories/2007/1814
VUPEN ADV-2007-1814
http://www.redhat.com/support/errata/RHSA-2007-0062.html
REDHAT RHSA-2007:0062
http://www.novell.com/linux/security/advisories/2007_45_java.html
SUSE SUSE-SA:2007:045
http://www.novell.com/linux/security/advisories/2007_10_ibmjava.html
SUSE SUSE-SA:2007:010
http://www.gentoo.org/security/en/glsa/glsa-200705-20.xml
GENTOO GLSA-200705-20
http://www.frsirt.com/english/advisories/2007/4224
VUPEN ADV-2007-4224
http://www.redhat.com/support/errata/RHSA-2007-0073.html
REDHAT RHSA-2007:0073
http://www.securityfocus.com/bid/21673
BID 21673 Sun Java Runtime Environment Multiple Remote Privilege Escalation Vulnerabilities Release Date:2007-12-18
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102731-1
SUNALERT 102731
http://securitytracker.com/id?1017426
SECTRACK 1017426
http://www.frsirt.com/english/advisories/2006/5074
VUPEN ADV-2006-5074
http://www.kb.cert.org/vuls/id/102289
CERT-VN VU#102289
http://www.us-cert.gov/cas/techalerts/TA07-022A.html
CERT TA07-022A
http://dev2dev.bea.com/pub/advisory/240
BEA BEA07-171.00

- Metasploit Modules Related To CVE-2006-6745

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.