CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-6101

Integer overflow in the ProcRenderAddGlyphs function in the Render extension for X.Org 6.8.2, 6.9.0, 7.0, and 7.1, and XFree86 X server, allows local users to execute arbitrary code via a crafted X protocol request that triggers memory corruption during processing of glyph management data structures.
Publish Date : 2006-12-31 Last Update Date : 2010-09-15
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.6
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access Admin
Vulnerability Type(s) Execute CodeOverflowMemory corruption
CWE ID CWE id is not defined for this vulnerability

- Vendor Statements

Red Hat Enterprise Linux 5 is not vulnerable to this issue as it contains a backported patch.
Source: Redhat

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2006-12-07 2006-01-09
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2006-6101 oval:org.opensuse.security:def:20066101 unix
Integer overflow in the ProcRenderAddGlyphs function in the Render extension for X.Org 6.8.2, 6.9.0, 7.0, and 7.1, and X... oval:org.mitre.oval:def:10490 unix
RHSA-2007:0002: XFree86 security update (Important) oval:com.redhat.rhsa:def:20070002 unix
RHSA-2007:0003: xorg-x11 security update (Important) oval:com.redhat.rhsa:def:20070003 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-6101

# Product Type Vendor Product Version Update Edition Language
1 Application X.org X.org 6.8.2 Version Details Vulnerabilities
2 Application X.org X.org 6.9.0 Version Details Vulnerabilities
3 Application X.org X.org 7.0 Version Details Vulnerabilities
4 Application X.org X.org 7.1 Version Details Vulnerabilities
5 Application Xfree86 Project Xfree86 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
X.org X.org 4
Xfree86 Project Xfree86 1

- References For CVE-2006-6101

http://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2007-002.txt.asc
NETBSD NetBSD-SA2007-002
http://lists.debian.org/debian-security-announce/debian-security-announce-2007/msg00004.html
DEBIAN DSA-1249
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01075678
HP SSRT071295
http://secunia.com/advisories/23633
SECUNIA 23633
http://secunia.com/advisories/23670
SECUNIA 23670
http://secunia.com/advisories/23684
SECUNIA 23684
http://secunia.com/advisories/23689
SECUNIA 23689
http://secunia.com/advisories/23698
SECUNIA 23698
http://secunia.com/advisories/23705
SECUNIA 23705
http://secunia.com/advisories/23758
SECUNIA 23758
http://secunia.com/advisories/23789
SECUNIA 23789
http://security.gentoo.org/glsa/glsa-200701-25.xml
GENTOO GLSA-200701-25
http://secunia.com/advisories/25802
SECUNIA 25802
http://secunia.com/advisories/24401
SECUNIA 24401
http://secunia.com/advisories/24247
SECUNIA 24247
http://secunia.com/advisories/24210
SECUNIA 24210
http://secunia.com/advisories/23966
SECUNIA 23966
http://secunia.com/advisories/24168
SECUNIA 24168
http://securitytracker.com/id?1017495
SECTRACK 1017495
http://support.avaya.com/elmodocs2/security/ASA-2007-066.htm CONFIRM
http://sunsolve.sun.com/search/document.do?assetkey=1-26-102803-1
SUNALERT 102803
http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.393555
SLACKWARE SSA:2007-066-02
http://www.frsirt.com/english/advisories/2007/0108
VUPEN ADV-2007-0108
http://support.avaya.com/elmodocs2/security/ASA-2007-074.htm CONFIRM
http://www.frsirt.com/english/advisories/2007/0109
VUPEN ADV-2007-0109
http://www.frsirt.com/english/advisories/2007/0669
VUPEN ADV-2007-0669
http://www.frsirt.com/english/advisories/2007/0589
VUPEN ADV-2007-0589
http://www.frsirt.com/english/advisories/2007/2233
VUPEN ADV-2007-2233
http://www.mandriva.com/security/advisories?name=MDKSA-2007:005
MANDRIVA MDKSA-2007:005
http://www.novell.com/linux/security/advisories/2007_08_x.html
SUSE SUSE-SA:2007:008
http://www.redhat.com/support/errata/RHSA-2007-0003.html
REDHAT RHSA-2007:0003
http://www.securityfocus.com/bid/21968
BID 21968 X.Org DBE And Render Extensions Multiple Local Integer Overflow Vulnerabilities Release Date:2007-11-15
http://www.ubuntu.com/usn/usn-403-1
UBUNTU USN-403-1
http://xforce.iss.net/xforce/xfdb/31337
XF xorg-xserver-render-overflow(31337)
http://osvdb.org/32084
OSVDB 32084
https://issues.rpath.com/browse/RPL-920 CONFIRM
http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=463
IDEFENSE 20070109 Multiple Vendor X Server Render Extension ProcRenderAddGlyphs Memory Corruption Vulnerability
http://lists.freedesktop.org/archives/xorg-announce/2007-January/000235.html
MLIST [x-org announce] 20070109 X.Org Security Advisory: multiple integer overflows in dbe and render extensions
http://www.redhat.com/support/errata/RHSA-2007-0002.html
REDHAT RHSA-2007:0002

- Metasploit Modules Related To CVE-2006-6101

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.