CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-5540

backend/parser/analyze.c in PostgreSQL 8.1.x before 8.1.5 allows remote authenticated users to cause a denial of service (daemon crash) via certain aggregate functions in an UPDATE statement, which are not properly handled during a "MIN/MAX index optimization."
Publish Date : 2006-10-26 Last Update Date : 2010-09-15
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low 2006-10-25 2006-10-16
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
backend/parser/analyze.c in PostgreSQL 8.1.x before 8.1.5 allows remote authenticated users to cause a denial of service... oval:org.mitre.oval:def:11425 unix
CVE-2006-5540 oval:org.opensuse.security:def:20065540 unix
ELSA-2007:0068: postgresql security update (Moderate) oval:org.mitre.oval:def:22160 unix
RHSA-2007:0064: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20070064 unix
RHSA-2007:0068: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20070068 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-5540

# Product Type Vendor Product Version Update Edition Language
1 Application Postgresql Postgresql 6.3.2 Version Details Vulnerabilities
2 Application Postgresql Postgresql 6.5.3 Version Details Vulnerabilities
3 Application Postgresql Postgresql 7.0.2 Version Details Vulnerabilities
4 Application Postgresql Postgresql 7.0.3 Version Details Vulnerabilities
5 Application Postgresql Postgresql 7.1 Version Details Vulnerabilities
6 Application Postgresql Postgresql 7.1.1 Version Details Vulnerabilities
7 Application Postgresql Postgresql 7.1.2 Version Details Vulnerabilities
8 Application Postgresql Postgresql 7.1.3 Version Details Vulnerabilities
9 Application Postgresql Postgresql 7.2 Version Details Vulnerabilities
10 Application Postgresql Postgresql 7.2.1 Version Details Vulnerabilities
11 Application Postgresql Postgresql 7.2.2 Version Details Vulnerabilities
12 Application Postgresql Postgresql 7.2.3 Version Details Vulnerabilities
13 Application Postgresql Postgresql 7.2.4 Version Details Vulnerabilities
14 Application Postgresql Postgresql 7.2.7 Version Details Vulnerabilities
15 Application Postgresql Postgresql 7.3 Version Details Vulnerabilities
16 Application Postgresql Postgresql 7.3.1 Version Details Vulnerabilities
17 Application Postgresql Postgresql 7.3.2 Version Details Vulnerabilities
18 Application Postgresql Postgresql 7.3.3 Version Details Vulnerabilities
19 Application Postgresql Postgresql 7.3.4 Version Details Vulnerabilities
20 Application Postgresql Postgresql 7.3.6 Version Details Vulnerabilities
21 Application Postgresql Postgresql 7.3.8 Version Details Vulnerabilities
22 Application Postgresql Postgresql 7.3.9 Version Details Vulnerabilities
23 Application Postgresql Postgresql 7.3.10 Version Details Vulnerabilities
24 Application Postgresql Postgresql 7.3.11 Version Details Vulnerabilities
25 Application Postgresql Postgresql 7.3.12 Version Details Vulnerabilities
26 Application Postgresql Postgresql 7.3.13 Version Details Vulnerabilities
27 Application Postgresql Postgresql 7.3.14 Version Details Vulnerabilities
28 Application Postgresql Postgresql 7.3.15 Version Details Vulnerabilities
29 Application Postgresql Postgresql 7.4 Version Details Vulnerabilities
30 Application Postgresql Postgresql 7.4.1 Version Details Vulnerabilities
31 Application Postgresql Postgresql 7.4.2 Version Details Vulnerabilities
32 Application Postgresql Postgresql 7.4.3 Version Details Vulnerabilities
33 Application Postgresql Postgresql 7.4.4 Version Details Vulnerabilities
34 Application Postgresql Postgresql 7.4.5 Version Details Vulnerabilities
35 Application Postgresql Postgresql 7.4.6 Version Details Vulnerabilities
36 Application Postgresql Postgresql 7.4.7 Version Details Vulnerabilities
37 Application Postgresql Postgresql 7.4.8 Version Details Vulnerabilities
38 Application Postgresql Postgresql 7.4.9 Version Details Vulnerabilities
39 Application Postgresql Postgresql 7.4.10 Version Details Vulnerabilities
40 Application Postgresql Postgresql 7.4.11 Version Details Vulnerabilities
41 Application Postgresql Postgresql 7.4.12 Version Details Vulnerabilities
42 Application Postgresql Postgresql 7.4.13 Version Details Vulnerabilities
43 Application Postgresql Postgresql 8.0 Version Details Vulnerabilities
44 Application Postgresql Postgresql 8.0.1 Version Details Vulnerabilities
45 Application Postgresql Postgresql 8.0.2 Version Details Vulnerabilities
46 Application Postgresql Postgresql 8.0.3 Version Details Vulnerabilities
47 Application Postgresql Postgresql 8.0.4 Version Details Vulnerabilities
48 Application Postgresql Postgresql 8.0.5 Version Details Vulnerabilities
49 Application Postgresql Postgresql 8.0.6 Version Details Vulnerabilities
50 Application Postgresql Postgresql 8.0.7 Version Details Vulnerabilities
51 Application Postgresql Postgresql 8.0.8 Version Details Vulnerabilities
52 Application Postgresql Postgresql 8.1 Version Details Vulnerabilities
53 Application Postgresql Postgresql 8.1.1 Version Details Vulnerabilities
54 Application Postgresql Postgresql 8.1.2 Version Details Vulnerabilities
55 Application Postgresql Postgresql 8.1.3 Version Details Vulnerabilities
56 Application Postgresql Postgresql 8.1.4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Postgresql Postgresql 56

- References For CVE-2006-5540

http://secunia.com/advisories/22562
SECUNIA 22562
ftp://patches.sgi.com/support/free/security/advisories/20070201-01-P.asc
SGI 20070201-01-P
http://secunia.com/advisories/22606
SECUNIA 22606
http://secunia.com/advisories/22636
SECUNIA 22636
http://secunia.com/advisories/23048
SECUNIA 23048
http://secunia.com/advisories/23132
SECUNIA 23132
http://www.redhat.com/support/errata/RHSA-2007-0064.html
REDHAT RHSA-2007:0064
http://www.novell.com/linux/security/advisories/2006_27_sr.html
SUSE SUSE-SR:2006:027
http://support.avaya.com/elmodocs2/security/ASA-2007-117.htm CONFIRM
http://securitytracker.com/id?1017115
SECTRACK 1017115
http://secunia.com/advisories/24577
SECUNIA 24577
http://support.novell.com/techcenter/psdb/59650c03a8bc5ae310cd7898bd106ad2.html CONFIRM
http://secunia.com/advisories/24284
SECUNIA 24284
http://secunia.com/advisories/24094
SECUNIA 24094
http://www.frsirt.com/english/advisories/2006/4182
VUPEN ADV-2006-4182
http://www.mandriva.com/security/advisories?name=MDKSA-2006:194
MANDRIVA MDKSA-2006:194
http://projects.commandprompt.com/public/pgsql/changeset/25504 CONFIRM
http://www.ubuntu.com/usn/usn-369-2
UBUNTU USN-369-2
http://www.redhat.com/support/errata/RHSA-2007-0067.html
REDHAT RHSA-2007:0067
http://www.trustix.org/errata/2006/0059/
TRUSTIX 2006-0059
http://www.redhat.com/support/errata/RHSA-2007-0068.html
REDHAT RHSA-2007:0068
http://www.postgresql.org/about/news.664 CONFIRM
http://www.securityfocus.com/bid/20717
BID 20717 PostgreSQL Multiple Local Denial of Service Vulnerabilities Release Date:2007-11-15
http://secunia.com/advisories/22584
SECUNIA 22584
http://www.ubuntu.com/usn/usn-369-1
UBUNTU USN-369-1

- Metasploit Modules Related To CVE-2006-5540

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.