CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-5456

Multiple buffer overflows in GraphicsMagick before 1.1.7 and ImageMagick 6.0.7 allow user-assisted attackers to cause a denial of service and possibly execute arbitrary code via (1) a DCM image that is not properly handled by the ReadDCMImage function in coders/dcm.c, or (2) a PALM image that is not properly handled by the ReadPALMImage function in coders/palm.c.
Publish Date : 2006-10-23 Last Update Date : 2011-09-20
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Denial Of ServiceExecute CodeOverflow
CWE ID 119

- Vendor Statements

Red Hat Enterprise Linux 5 is not vulnerable to this issue as it contains a backported patch.
Source: Redhat

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2006-10-16 2006-09-29
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2006-5456 oval:org.opensuse.security:def:20065456 unix
Multiple buffer overflows in GraphicsMagick before 1.1.7 and ImageMagick 6.0.7 allow user-assisted attackers to cause a ... oval:org.mitre.oval:def:9765 unix
RHSA-2007:0015: ImageMagick security update (Moderate) oval:com.redhat.rhsa:def:20070015 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-5456

# Product Type Vendor Product Version Update Edition Language
1 Application Graphicsmagick Graphicsmagick 1.0 Version Details Vulnerabilities
2 Application Graphicsmagick Graphicsmagick 1.0.6 Version Details Vulnerabilities
3 Application Graphicsmagick Graphicsmagick 1.1 Version Details Vulnerabilities
4 Application Graphicsmagick Graphicsmagick 1.1.3 Version Details Vulnerabilities
5 Application Graphicsmagick Graphicsmagick 1.1.4 Version Details Vulnerabilities
6 Application Graphicsmagick Graphicsmagick 1.1.5 Version Details Vulnerabilities
7 Application Graphicsmagick Graphicsmagick 1.1.6 Version Details Vulnerabilities
8 Application Imagemagick Imagemagick 6.0.7 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Graphicsmagick Graphicsmagick 7
Imagemagick Imagemagick 1

- References For CVE-2006-5456

http://secunia.com/advisories/22604
SECUNIA 22604
http://secunia.com/advisories/22819
SECUNIA 22819
ftp://patches.sgi.com/support/free/security/advisories/20070201-01-P.asc
SGI 20070201-01-P
http://packages.debian.org/changelogs/pool/main/g/graphicsmagick/graphicsmagick_1.1.7-9/changelog#versionversion1.1.7-9 CONFIRM
http://secunia.com/advisories/22569
SECUNIA 22569
http://secunia.com/advisories/22601
SECUNIA 22601
http://secunia.com/advisories/22572
SECUNIA 22572
http://secunia.com/advisories/22834
SECUNIA 22834
http://secunia.com/advisories/22998
SECUNIA 22998
http://secunia.com/advisories/23090
SECUNIA 23090
http://secunia.com/advisories/23121
SECUNIA 23121
http://secunia.com/advisories/24186
SECUNIA 24186
http://secunia.com/advisories/24196
SECUNIA 24196
http://secunia.com/advisories/24284
SECUNIA 24284
http://security.gentoo.org/glsa/glsa-200611-19.xml
GENTOO GLSA-200611-19
http://secunia.com/advisories/24458
SECUNIA 24458
http://security.gentoo.org/glsa/glsa-200611-07.xml
GENTOO GLSA-200611-07
http://www.osvdb.org/29990
OSVDB 29990
http://www.novell.com/linux/security/advisories/2007_3_sr.html
SUSE SUSE-SR:2007:003
http://www.novell.com/linux/security/advisories/2006_66_imagemagick.html
SUSE SUSE-SA:2006:066
http://www.mandriva.com/security/advisories?name=MDKSA-2007:041
MANDRIVA MDKSA-2007:041
http://www.mandriva.com/security/advisories?name=MDKSA-2006:193
MANDRIVA MDKSA-2006:193
http://www.debian.org/security/2006/dsa-1213
DEBIAN DSA-1213
http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.352092
SLACKWARE SSA:2007-066-06
http://www.redhat.com/support/errata/RHSA-2007-0015.html
REDHAT RHSA-2007:0015
http://www.ubuntu.com/usn/usn-372-1
UBUNTU USN-372-1
http://www.securityfocus.com/bid/20707
BID 20707 GraphicsMagick PALM DCM Buffer Overflow Vulnerabilities Release Date:2007-03-08
http://www.securityfocus.com/archive/1/archive/1/459507/100/0/threaded
BUGTRAQ 20070208 rPSA-2007-0029-1 ImageMagick
http://www.securityfocus.com/archive/1/archive/1/452718/100/100/threaded
BUGTRAQ 20061127 rPSA-2006-0218-1 ImageMagick
http://www.vupen.com/english/advisories/2006/4170
VUPEN ADV-2006-4170
http://www.ubuntu.com/usn/usn-422-1
UBUNTU USN-422-1
http://www.vupen.com/english/advisories/2006/4171
VUPEN ADV-2006-4171
http://xforce.iss.net/xforce/xfdb/29816
XF imagemagick-graphicsmagick-palm-bo(29816)
https://issues.rpath.com/browse/RPL-1034 CONFIRM
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=210921 CONFIRM
https://issues.rpath.com/browse/RPL-811 CONFIRM

- Metasploit Modules Related To CVE-2006-5456

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.