CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-4980

Buffer overflow in the repr function in Python 2.3 through 2.6 before 20060822 allows context-dependent attackers to cause a denial of service and possibly execute arbitrary code via crafted wide character UTF-32/UCS-4 strings to certain scripts.
Publish Date : 2006-10-10 Last Update Date : 2010-09-15
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Denial Of ServiceExecute CodeOverflow
CWE ID CWE id is not defined for this vulnerability

- Vendor Statements

Red Hat Enterprise Linux 5 is not vulnerable to this issue as it contains a backported patch.
Source: Redhat

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2006-09-25 2006-08-16
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Buffer overflow in the repr function in Python 2.3 through 2.6 before 20060822 allows context-dependent attackers to cau... oval:org.mitre.oval:def:10789 unix
CVE-2006-4980 oval:org.opensuse.security:def:20064980 unix
RHSA-2006:0713: python security update (Important) oval:com.redhat.rhsa:def:20060713 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-4980

# Product Type Vendor Product Version Update Edition Language
1 Application Python Software Foundation Python 2.3 Version Details Vulnerabilities
2 Application Python Software Foundation Python 2.3.1 Version Details Vulnerabilities
3 Application Python Software Foundation Python 2.3.2 Version Details Vulnerabilities
4 Application Python Software Foundation Python 2.3.3 Version Details Vulnerabilities
5 Application Python Software Foundation Python 2.3.4 Version Details Vulnerabilities
6 Application Python Software Foundation Python 2.3.5 Version Details Vulnerabilities
7 Application Python Software Foundation Python 2.4 Version Details Vulnerabilities
8 Application Python Software Foundation Python 2.4.2 Version Details Vulnerabilities
9 Application Python Software Foundation Python 2.4.3 Version Details Vulnerabilities
10 Application Python Software Foundation Python 2.5 Beta 1 Version Details Vulnerabilities
11 Application Python Software Foundation Python 2.5 Release Candidate 2 Version Details Vulnerabilities
12 Application Python Software Foundation Python 2.5 Alpha 2 Version Details Vulnerabilities
13 Application Python Software Foundation Python 2.5 Release Candidate 1 Version Details Vulnerabilities
14 Application Python Software Foundation Python 2.5 Alpha 1 Version Details Vulnerabilities
15 Application Python Software Foundation Python 2.5 Final Version Details Vulnerabilities
16 Application Python Software Foundation Python 2.5 Beta 3 Version Details Vulnerabilities
17 Application Python Software Foundation Python 2.5 Beta 2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Python Software Foundation Python 17

- References For CVE-2006-4980

ftp://patches.sgi.com/support/free/security/advisories/20061001-01-P.asc
SGI 20061001-01-P
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=391589 CONFIRM
http://secunia.com/advisories/22357
SECUNIA 22357
http://secunia.com/advisories/22297
SECUNIA 22297
http://kb.vmware.com/KanisaPlatform/Publishing/882/5120103_f.SAL_Public.html CONFIRM
http://secunia.com/advisories/22358
SECUNIA 22358
http://secunia.com/advisories/22379
SECUNIA 22379
http://secunia.com/advisories/22448
SECUNIA 22448
http://secunia.com/advisories/22487
SECUNIA 22487
http://secunia.com/advisories/22512
SECUNIA 22512
http://secunia.com/advisories/22531
SECUNIA 22531
http://secunia.com/advisories/22639
SECUNIA 22639
http://secunia.com/advisories/23680
SECUNIA 23680
http://securitytracker.com/id?1017019
SECTRACK 1017019
http://security.gentoo.org/glsa/glsa-200610-07.xml
GENTOO GLSA-200610-07
http://www.debian.org/security/2006/dsa-1197
DEBIAN DSA-1197
http://support.avaya.com/elmodocs2/security/ASA-2006-229.htm CONFIRM
http://www.debian.org/security/2006/dsa-1198
DEBIAN DSA-1198
http://www.frsirt.com/english/advisories/2006/3940
VUPEN ADV-2006-3940
http://www.frsirt.com/english/advisories/2006/5131
VUPEN ADV-2006-5131
http://www.mandriva.com/security/advisories?name=MDKSA-2006:181
MANDRIVA MDKSA-2006:181
http://www.novell.com/linux/security/advisories/2006_25_sr.html
SUSE SUSE-SR:2006:025
http://www.redhat.com/support/errata/RHSA-2006-0713.html
REDHAT RHSA-2006:0713
https://issues.rpath.com/browse/RPL-702 CONFIRM
http://xforce.iss.net/xforce/xfdb/29408
XF python-repr-bo(29408)
http://www.vmware.com/support/vi3/doc/esx-9986131-patch.html CONFIRM
http://www.vmware.com/support/vi3/doc/esx-3069097-patch.html CONFIRM
http://www.securityfocus.com/archive/1/archive/1/456546/100/200/threaded
BUGTRAQ 20070110 VMware ESX server security updates
http://www.securityfocus.com/archive/1/archive/1/448244/100/100/threaded
BUGTRAQ 20061011 rPSA-2006-0187-1 idle python
http://secunia.com/advisories/31492
SECUNIA 31492
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=208162 CONFIRM
http://www.redhat.com/support/errata/RHSA-2008-0629.html
REDHAT RHSA-2008:0629
http://sourceforge.net/tracker/index.php?func=detail&aid=1541585&group_id=5470&atid=305470 CONFIRM
http://www.securityfocus.com/bid/20376
BID 20376 Python Repr() Function Remote Code Execution Vulnerability Release Date:2008-08-13
http://www.ubuntu.com/usn/usn-359-1
UBUNTU USN-359-1
http://zoehep.xent.com/~bsittler/python2.4-2.4.3_unicodeobject.c.diff CONFIRM
http://secunia.com/advisories/22276
SECUNIA 22276
https://launchpad.net/distros/ubuntu/+source/python2.4/+bug/56633 CONFIRM
http://secunia.com/advisories/22303
SECUNIA 22303

- Metasploit Modules Related To CVE-2006-4980

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.