CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-3745

Unspecified vulnerability in the sctp_make_abort_user function in the SCTP implementation in Linux 2.6.x before 2.6.17.10 and 2.4.23 up to 2.4.33 allows local users to cause a denial of service (panic) and possibly gain root privileges via unknown attack vectors.
Publish Date : 2006-08-23 Last Update Date : 2012-03-19
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Denial Of ServiceGain privileges
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2006-08-10 2006-08-22
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2006-3745 oval:org.opensuse.security:def:20063745 unix
RHSA-2006:0617: kernel security update (Important) oval:com.redhat.rhsa:def:20060617 unix
Unspecified vulnerability in the sctp_make_abort_user function in the SCTP implementation in Linux 2.6.x before 2.6.17.1... oval:org.mitre.oval:def:10706 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-3745

# Product Type Vendor Product Version Update Edition Language
1 OS Linux Linux Kernel 2.4.23 Version Details Vulnerabilities
2 OS Linux Linux Kernel 2.4.24 Version Details Vulnerabilities
3 OS Linux Linux Kernel 2.4.25 Version Details Vulnerabilities
4 OS Linux Linux Kernel 2.4.26 Version Details Vulnerabilities
5 OS Linux Linux Kernel 2.4.27 Version Details Vulnerabilities
6 OS Linux Linux Kernel 2.4.28 Version Details Vulnerabilities
7 OS Linux Linux Kernel 2.4.29 Version Details Vulnerabilities
8 OS Linux Linux Kernel 2.4.30 Version Details Vulnerabilities
9 OS Linux Linux Kernel 2.4.31 Version Details Vulnerabilities
10 OS Linux Linux Kernel 2.4.32 Version Details Vulnerabilities
11 OS Linux Linux Kernel 2.4.33 Version Details Vulnerabilities
12 OS Linux Linux Kernel 2.6.0 Version Details Vulnerabilities
13 OS Linux Linux Kernel 2.6.1 Version Details Vulnerabilities
14 OS Linux Linux Kernel 2.6.10 Version Details Vulnerabilities
15 OS Linux Linux Kernel 2.6.11 Version Details Vulnerabilities
16 OS Linux Linux Kernel 2.6.11.1 Version Details Vulnerabilities
17 OS Linux Linux Kernel 2.6.11.2 Version Details Vulnerabilities
18 OS Linux Linux Kernel 2.6.11.3 Version Details Vulnerabilities
19 OS Linux Linux Kernel 2.6.11.4 Version Details Vulnerabilities
20 OS Linux Linux Kernel 2.6.11.5 Version Details Vulnerabilities
21 OS Linux Linux Kernel 2.6.11.6 Version Details Vulnerabilities
22 OS Linux Linux Kernel 2.6.11.7 Version Details Vulnerabilities
23 OS Linux Linux Kernel 2.6.11.8 Version Details Vulnerabilities
24 OS Linux Linux Kernel 2.6.11.9 Version Details Vulnerabilities
25 OS Linux Linux Kernel 2.6.11.10 Version Details Vulnerabilities
26 OS Linux Linux Kernel 2.6.11.11 Version Details Vulnerabilities
27 OS Linux Linux Kernel 2.6.11.12 Version Details Vulnerabilities
28 OS Linux Linux Kernel 2.6.12 Version Details Vulnerabilities
29 OS Linux Linux Kernel 2.6.12.1 Version Details Vulnerabilities
30 OS Linux Linux Kernel 2.6.12.2 Version Details Vulnerabilities
31 OS Linux Linux Kernel 2.6.12.3 Version Details Vulnerabilities
32 OS Linux Linux Kernel 2.6.12.4 Version Details Vulnerabilities
33 OS Linux Linux Kernel 2.6.12.5 Version Details Vulnerabilities
34 OS Linux Linux Kernel 2.6.12.6 Version Details Vulnerabilities
35 OS Linux Linux Kernel 2.6.13 Version Details Vulnerabilities
36 OS Linux Linux Kernel 2.6.13.1 Version Details Vulnerabilities
37 OS Linux Linux Kernel 2.6.13.2 Version Details Vulnerabilities
38 OS Linux Linux Kernel 2.6.13.3 Version Details Vulnerabilities
39 OS Linux Linux Kernel 2.6.13.4 Version Details Vulnerabilities
40 OS Linux Linux Kernel 2.6.13.5 Version Details Vulnerabilities
41 OS Linux Linux Kernel 2.6.14 Version Details Vulnerabilities
42 OS Linux Linux Kernel 2.6.14.1 Version Details Vulnerabilities
43 OS Linux Linux Kernel 2.6.14.2 Version Details Vulnerabilities
44 OS Linux Linux Kernel 2.6.14.3 Version Details Vulnerabilities
45 OS Linux Linux Kernel 2.6.14.4 Version Details Vulnerabilities
46 OS Linux Linux Kernel 2.6.14.5 Version Details Vulnerabilities
47 OS Linux Linux Kernel 2.6.14.6 Version Details Vulnerabilities
48 OS Linux Linux Kernel 2.6.14.7 Version Details Vulnerabilities
49 OS Linux Linux Kernel 2.6.15 Version Details Vulnerabilities
50 OS Linux Linux Kernel 2.6.15.1 Version Details Vulnerabilities
51 OS Linux Linux Kernel 2.6.15.2 Version Details Vulnerabilities
52 OS Linux Linux Kernel 2.6.15.3 Version Details Vulnerabilities
53 OS Linux Linux Kernel 2.6.15.4 Version Details Vulnerabilities
54 OS Linux Linux Kernel 2.6.15.5 Version Details Vulnerabilities
55 OS Linux Linux Kernel 2.6.15.6 Version Details Vulnerabilities
56 OS Linux Linux Kernel 2.6.15.7 Version Details Vulnerabilities
57 OS Linux Linux Kernel 2.6.16 Version Details Vulnerabilities
58 OS Linux Linux Kernel 2.6.16.1 Version Details Vulnerabilities
59 OS Linux Linux Kernel 2.6.16.2 Version Details Vulnerabilities
60 OS Linux Linux Kernel 2.6.16.3 Version Details Vulnerabilities
61 OS Linux Linux Kernel 2.6.16.4 Version Details Vulnerabilities
62 OS Linux Linux Kernel 2.6.16.5 Version Details Vulnerabilities
63 OS Linux Linux Kernel 2.6.16.6 Version Details Vulnerabilities
64 OS Linux Linux Kernel 2.6.16.7 Version Details Vulnerabilities
65 OS Linux Linux Kernel 2.6.16.8 Version Details Vulnerabilities
66 OS Linux Linux Kernel 2.6.16.9 Version Details Vulnerabilities
67 OS Linux Linux Kernel 2.6.16.10 Version Details Vulnerabilities
68 OS Linux Linux Kernel 2.6.16.11 Version Details Vulnerabilities
69 OS Linux Linux Kernel 2.6.16.12 Version Details Vulnerabilities
70 OS Linux Linux Kernel 2.6.16.13 Version Details Vulnerabilities
71 OS Linux Linux Kernel 2.6.16.14 Version Details Vulnerabilities
72 OS Linux Linux Kernel 2.6.16.15 Version Details Vulnerabilities
73 OS Linux Linux Kernel 2.6.16.16 Version Details Vulnerabilities
74 OS Linux Linux Kernel 2.6.16.17 Version Details Vulnerabilities
75 OS Linux Linux Kernel 2.6.16.18 Version Details Vulnerabilities
76 OS Linux Linux Kernel 2.6.16.19 Version Details Vulnerabilities
77 OS Linux Linux Kernel 2.6.16.20 Version Details Vulnerabilities
78 OS Linux Linux Kernel 2.6.16.21 Version Details Vulnerabilities
79 OS Linux Linux Kernel 2.6.16.22 Version Details Vulnerabilities
80 OS Linux Linux Kernel 2.6.16.23 Version Details Vulnerabilities
81 OS Linux Linux Kernel 2.6.16.24 Version Details Vulnerabilities
82 OS Linux Linux Kernel 2.6.16.25 Version Details Vulnerabilities
83 OS Linux Linux Kernel 2.6.16.26 Version Details Vulnerabilities
84 OS Linux Linux Kernel 2.6.16.27 Version Details Vulnerabilities
85 OS Linux Linux Kernel 2.6.16.28 Version Details Vulnerabilities
86 OS Linux Linux Kernel 2.6.16.29 Version Details Vulnerabilities
87 OS Linux Linux Kernel 2.6.16.30 Version Details Vulnerabilities
88 OS Linux Linux Kernel 2.6.16.31 Version Details Vulnerabilities
89 OS Linux Linux Kernel 2.6.17 Version Details Vulnerabilities
90 OS Linux Linux Kernel 2.6.17.1 Version Details Vulnerabilities
91 OS Linux Linux Kernel 2.6.17.2 Version Details Vulnerabilities
92 OS Linux Linux Kernel 2.6.17.3 Version Details Vulnerabilities
93 OS Linux Linux Kernel 2.6.17.4 Version Details Vulnerabilities
94 OS Linux Linux Kernel 2.6.17.5 Version Details Vulnerabilities
95 OS Linux Linux Kernel 2.6.17.6 Version Details Vulnerabilities
96 OS Linux Linux Kernel 2.6.17.7 Version Details Vulnerabilities
97 OS Linux Linux Kernel 2.6.17.8 Version Details Vulnerabilities
98 OS Linux Linux Kernel 2.6.17.9 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Linux Linux Kernel 98

- References For CVE-2006-3745

http://archives.neohapsis.com/archives/fulldisclosure/2006-08/0600.html
FULLDISC 20060822 Linux Kernel SCTP Privilege Elevation Vulnerability
http://secunia.com/advisories/21576
SECUNIA 21576
http://kernel.org/pub/linux/kernel/v2.4/ChangeLog-2.4.33.2 CONFIRM
http://secunia.com/advisories/21614
SECUNIA 21614
http://secunia.com/advisories/21695
SECUNIA 21695
http://secunia.com/advisories/21847
SECUNIA 21847
http://secunia.com/advisories/21934
SECUNIA 21934
http://secunia.com/advisories/22082
SECUNIA 22082
http://www.debian.org/security/2006/dsa-1184
DEBIAN DSA-1184
http://secunia.com/advisories/22093
SECUNIA 22093
http://secunia.com/advisories/22148
SECUNIA 22148
http://secunia.com/advisories/22174
SECUNIA 22174
http://support.avaya.com/elmodocs2/security/ASA-2006-203.htm CONFIRM
http://www.debian.org/security/2006/dsa-1183
DEBIAN DSA-1183
http://www.mandriva.com/security/advisories?name=MDKSA-2006:150
MANDRIVA MDKSA-2006:150
http://www.mandriva.com/security/advisories?name=MDKSA-2007:025
MANDRIVA MDKSA-2007:025
http://www.mandriva.com/security/advisories?name=MDKSA-2006:151
MANDRIVA MDKSA-2006:151
http://www.securityfocus.com/archive/1/archive/1/444887/100/0/threaded
BUGTRAQ 20060831 rPSA-2006-0162-1 kernel
http://www.securityfocus.com/archive/1/archive/1/444066/100/0/threaded
BUGTRAQ 20060822 Linux Kernel SCTP Privilege Elevation Vulnerability
http://www.novell.com/linux/security/advisories/2006_57_kernel.html
SUSE SUSE-SA:2006:057
http://www.novell.com/linux/security/advisories/2006_22_sr.html
SUSE SUSE-SR:2006:022
http://www.novell.com/linux/security/advisories/2006_21_sr.html
SUSE SUSE-SR:2006:021
http://www.ubuntu.com/usn/usn-346-1
UBUNTU USN-346-1
http://www.securityfocus.com/bid/19666
BID 19666 Linux Kernel SCTP_Make_Abort_User Function Buffer Overflow Vulnerability Release Date:2006-12-19
http://secunia.com/advisories/21605
SECUNIA 21605
https://issues.rpath.com/browse/RPL-611 CONFIRM
http://www.vupen.com/english/advisories/2006/3358
VUPEN ADV-2006-3358
http://xforce.iss.net/xforce/xfdb/28530
XF kernel-sctp-privilege-escalation(28530)
http://www.redhat.com/support/errata/RHSA-2006-0617.html
REDHAT RHSA-2006:0617

- Metasploit Modules Related To CVE-2006-3745

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.