CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-2685

PHP remote file inclusion vulnerability in Basic Analysis and Security Engine (BASE) 1.2.4 and earlier, with register_globals enabled, allows remote attackers to execute arbitrary PHP code via a URL in the BASE_path parameter to (1) base_qry_common.php, (2) base_stat_common.php, and (3) includes/base_include.inc.php.
Publish Date : 2006-05-31 Last Update Date : 2011-08-23
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeFile Inclusion
CWE ID 94

- Products Affected By CVE-2006-2685

# Product Type Vendor Product Version Update Edition Language
1 Application Kevin Johnson Basic Analysis And Security Engine 1.2.0 Version Details Vulnerabilities
2 Application Kevin Johnson Basic Analysis And Security Engine 1.2.1 Version Details Vulnerabilities
3 Application Kevin Johnson Basic Analysis And Security Engine 1.2.2 Version Details Vulnerabilities
4 Application Kevin Johnson Basic Analysis And Security Engine 1.2.4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Kevin Johnson Basic Analysis And Security Engine 4

- References For CVE-2006-2685

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=370576 CONFIRM
http://www.osvdb.org/25770
OSVDB 25770
http://sourceforge.net/forum/forum.php?forum_id=577228 CONFIRM
http://secunia.com/advisories/20300
SECUNIA 20300
http://milw0rm.com/exploits/1823
MILW0RM 1823
http://www.securityfocus.com/bid/18298
BID 18298 Basic Analysis and Security Engine Multiple Remote File Include Vulnerabilities Release Date:2006-06-06
http://www.vupen.com/english/advisories/2006/1996
VUPEN ADV-2006-1996
http://xforce.iss.net/xforce/xfdb/26652
XF base-path-file-include(26652)

- Metasploit Modules Related To CVE-2006-2685

BASE base_qry_common Remote File Include
This module exploits a remote file inclusion vulnerability in the base_qry_common.php file in BASE 1.2.4 and earlier.
Module type : exploit Rank : excellent Platforms : PHP


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.