CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-2447

SpamAssassin before 3.1.3, when running with vpopmail and the paranoid (-P) switch, allows remote attackers to execute arbitrary commands via a crafted message that is not properly handled when invoking spamd with the virtual pop username.
Publish Date : 2006-06-06 Last Update Date : 2011-04-07
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.1
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Execute Code
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2006-06-01 2006-06-06
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2006-2447 oval:org.opensuse.security:def:20062447 unix
RHSA-2006:0543: spamassassin security update (Moderate) oval:com.redhat.rhsa:def:20060543 unix
SpamAssassin before 3.1.3, when running with vpopmail and the paranoid (-P) switch, allows remote attackers to execute a... oval:org.mitre.oval:def:9184 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-2447

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Spamassassin 3.1.0 Version Details Vulnerabilities
2 Application Apache Spamassassin 3.1.1 Version Details Vulnerabilities
3 Application Apache Spamassassin 3.1.2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Spamassassin 3

- References For CVE-2006-2447

http://www.securityfocus.com/bid/18290
BID 18290 SpamAssassin Vpopmail and Paranoid Switches Remote Command Execution Vulnerability Release Date:2006-11-23
http://www.redhat.com/support/errata/RHSA-2006-0543.html
REDHAT RHSA-2006:0543
http://secunia.com/advisories/20482
SECUNIA 20482
http://secunia.com/advisories/20692
SECUNIA 20692
http://secunia.com/advisories/20566
SECUNIA 20566
http://secunia.com/advisories/20531
SECUNIA 20531
http://securitytracker.com/id?1016235
SECTRACK 1016235
http://securitytracker.com/id?1016230
SECTRACK 1016230
http://www.vupen.com/english/advisories/2006/2148
VUPEN ADV-2006-2148
http://www.trustix.org/errata/2006/0034/
TRUSTIX 2006-0034
http://www.securityfocus.com/archive/1/archive/1/436288/100/0/threaded
BUGTRAQ 20060607 rPSA-2006-0096-1 spamassassin
http://www.mandriva.com/security/advisories?name=MDKSA-2006:103
MANDRIVA MDKSA-2006:103
http://www.gentoo.org/security/en/glsa/glsa-200606-09.xml
GENTOO GLSA-200606-09
http://secunia.com/advisories/20430
SECUNIA 20430
http://xforce.iss.net/xforce/xfdb/27008
XF spamassassin-spamd-command-execution(27008)
http://www.debian.org/security/2006/dsa-1090
DEBIAN DSA-1090
http://secunia.com/advisories/20443
SECUNIA 20443
http://www.nabble.com/ANNOUNCE%3A-Apache-SpamAssassin-3.1.3-available%21-t1736096.html CONFIRM

- Metasploit Modules Related To CVE-2006-2447

SpamAssassin spamd Remote Command Execution
This module exploits a flaw in the SpamAssassin spamd service by specifying a malicious vpopmail User header, when running with vpopmail and paranoid modes enabled (non-default). Versions prior to v3.1.3 are vulnerable
Module type : exploit Rank : excellent Platforms : Unix


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.