CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-0705

Format string vulnerability in a logging function as used by various SFTP servers, including (1) AttachmateWRQ Reflection for Secure IT UNIX Server before 6.0.0.9, (2) Reflection for Secure IT Windows Server before 6.0 build 38, (3) F-Secure SSH Server for Windows before 5.3 build 35, (4) F-Secure SSH Server for UNIX 3.0 through 5.0.8, (5) SSH Tectia Server 4.3.6 and earlier and 4.4.0, and (6) SSH Shell Server 3.2.9 and earlier, allows remote authenticated users to execute arbitrary commands via unspecified vectors, involving crafted filenames and the stat command.
Publish Date : 2006-02-15 Last Update Date : 2008-09-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID CWE id is not defined for this vulnerability

- Products Affected By CVE-2006-0705

# Product Type Vendor Product Version Update Edition Language
1 Application Attachmatewrq Reflection For Secure It Server 6.0 WIN Version Details Vulnerabilities
2 Application Attachmatewrq Reflection For Secure It Server 6.0 Unix Version Details Vulnerabilities
3 Application F-secure F-secure Ssh Server 3.0.0 Version Details Vulnerabilities
4 Application F-secure F-secure Ssh Server 3.0.1 Unix Version Details Vulnerabilities
5 Application F-secure F-secure Ssh Server 3.0.1 Version Details Vulnerabilities
6 Application F-secure F-secure Ssh Server 3.0.2 Version Details Vulnerabilities
7 Application F-secure F-secure Ssh Server 3.0.3 Version Details Vulnerabilities
8 Application F-secure F-secure Ssh Server 3.0.4 Version Details Vulnerabilities
9 Application F-secure F-secure Ssh Server 3.0.5 Version Details Vulnerabilities
10 Application F-secure F-secure Ssh Server 3.0.6 Version Details Vulnerabilities
11 Application F-secure F-secure Ssh Server 3.0.7 Version Details Vulnerabilities
12 Application F-secure F-secure Ssh Server 3.0.8 Version Details Vulnerabilities
13 Application F-secure F-secure Ssh Server 3.0.9 Version Details Vulnerabilities
14 Application F-secure F-secure Ssh Server 3.1.0 Build9 Version Details Vulnerabilities
15 Application F-secure F-secure Ssh Server 3.1.0 Unix Version Details Vulnerabilities
16 Application F-secure F-secure Ssh Server 3.1.0 Version Details Vulnerabilities
17 Application F-secure F-secure Ssh Server 3.2.0 Unix Version Details Vulnerabilities
18 Application F-secure F-secure Ssh Server 3.2.3 Unix Version Details Vulnerabilities
19 Application F-secure F-secure Ssh Server 5.0 Version Details Vulnerabilities
20 Application F-secure F-secure Ssh Server 5.1 WIN Version Details Vulnerabilities
21 Application F-secure F-secure Ssh Server 5.2 WIN Version Details Vulnerabilities
22 Application F-secure F-secure Ssh Server 5.3 WIN Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Attachmatewrq Reflection For Secure It Server 2
F-secure F-secure Ssh Server 20

- References For CVE-2006-0705

http://security.gentoo.org/glsa/glsa-200703-13.xml
GENTOO GLSA-200703-13
http://www.frsirt.com/english/advisories/2008/1008/references
VUPEN ADV-2008-1008
http://www.frsirt.com/english/advisories/2006/0554
VUPEN ADV-2006-0554
http://www.securityfocus.com/bid/16640
BID 16640 SSH Tectia Server Remote Format String Vulnerability Release Date:2008-12-01
http://xforce.iss.net/xforce/xfdb/24651
XF sftp-logging-format-string(24651)
http://secunia.com/advisories/18828
SECUNIA 18828
http://secunia.com/advisories/18843
SECUNIA 18843
http://securitytracker.com/id?1015619
SECTRACK 1015619
http://support.wrq.com/techdocs/1882.html CONFIRM
http://www.frsirt.com/english/advisories/2006/0555
VUPEN ADV-2006-0555
http://www.securityfocus.com/bid/16625
BID 16625 AttachmateWRQ Reflection for Secure IT Remote Format String Vulnerability Release Date:2006-02-14
http://www.kb.cert.org/vuls/id/419241
CERT-VN VU#419241
http://secunia.com/advisories/29552
SECUNIA 29552
http://secunia.com/advisories/24516
SECUNIA 24516
http://marc.info/?l=bugtraq&m=120654385125315&w=2
HP SSRT080011

- Metasploit Modules Related To CVE-2006-0705

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.