CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-0645

Tiny ASN.1 Library (libtasn1) before 0.2.18, as used by (1) GnuTLS 1.2.x before 1.2.10 and 1.3.x before 1.3.4, and (2) GNU Shishi, allows attackers to crash the DER decoder and possibly execute arbitrary code via "out-of-bounds access" caused by invalid input, as demonstrated by the ProtoVer SSL test suite.
Publish Date : 2006-02-10 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Execute Code
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2006-02-09 2006-02-09
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2006-0645 oval:org.opensuse.security:def:20060645 unix
RHSA-2006:0207: gnutls security update (Important) oval:com.redhat.rhsa:def:20060207 unix
Tiny ASN.1 Library (libtasn1) before 0.2.18, as used by (1) GnuTLS 1.2.x before 1.2.10 and 1.3.x before 1.3.4, and (2) G... oval:org.mitre.oval:def:10540 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2006-0645

# Product Type Vendor Product Version Update Edition Language
1 Application Free Software Foundation Inc. Libtasn1 0.1.0 Version Details Vulnerabilities
2 Application Free Software Foundation Inc. Libtasn1 0.1.1 Version Details Vulnerabilities
3 Application Free Software Foundation Inc. Libtasn1 0.1.2 Version Details Vulnerabilities
4 Application Free Software Foundation Inc. Libtasn1 0.2.0 Version Details Vulnerabilities
5 Application Free Software Foundation Inc. Libtasn1 0.2.1 Version Details Vulnerabilities
6 Application Free Software Foundation Inc. Libtasn1 0.2.2 Version Details Vulnerabilities
7 Application Free Software Foundation Inc. Libtasn1 0.2.3 Version Details Vulnerabilities
8 Application Free Software Foundation Inc. Libtasn1 0.2.4 Version Details Vulnerabilities
9 Application Free Software Foundation Inc. Libtasn1 0.2.5 Version Details Vulnerabilities
10 Application Free Software Foundation Inc. Libtasn1 0.2.6 Version Details Vulnerabilities
11 Application Free Software Foundation Inc. Libtasn1 0.2.7 Version Details Vulnerabilities
12 Application Free Software Foundation Inc. Libtasn1 0.2.8 Version Details Vulnerabilities
13 Application Free Software Foundation Inc. Libtasn1 0.2.9 Version Details Vulnerabilities
14 Application Free Software Foundation Inc. Libtasn1 0.2.10 Version Details Vulnerabilities
15 Application Free Software Foundation Inc. Libtasn1 0.2.11 Version Details Vulnerabilities
16 Application Free Software Foundation Inc. Libtasn1 0.2.12 Version Details Vulnerabilities
17 Application Free Software Foundation Inc. Libtasn1 0.2.13 Version Details Vulnerabilities
18 Application Free Software Foundation Inc. Libtasn1 0.2.14 Version Details Vulnerabilities
19 Application Free Software Foundation Inc. Libtasn1 0.2.15 Version Details Vulnerabilities
20 Application Free Software Foundation Inc. Libtasn1 0.2.16 Version Details Vulnerabilities
21 Application Free Software Foundation Inc. Libtasn1 0.2.17 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Free Software Foundation Inc. Libtasn1 21

- References For CVE-2006-0645

http://secunia.com/advisories/18815
SECUNIA 18815
http://secunia.com/advisories/18794
SECUNIA 18794
http://secunia.com/advisories/18830
SECUNIA 18830
http://secunia.com/advisories/18832
SECUNIA 18832
http://secunia.com/advisories/18898
SECUNIA 18898
http://secunia.com/advisories/18918
SECUNIA 18918
http://secunia.com/advisories/19080
SECUNIA 19080
http://secunia.com/advisories/19092
SECUNIA 19092
http://securityreason.com/securityalert/446
SREASON 446
http://securitytracker.com/id?1015612
SECTRACK 1015612
http://www.debian.org/security/2006/dsa-985
DEBIAN DSA-985
http://www.debian.org/security/2006/dsa-986
DEBIAN DSA-986
http://www.frsirt.com/english/advisories/2006/0496
VUPEN ADV-2006-0496
http://www.gentoo.org/security/en/glsa/glsa-200602-08.xml
GENTOO GLSA-200602-08
http://www.mandriva.com/security/advisories?name=MDKSA-2006:039
MANDRIVA MDKSA-2006:039
http://www.osvdb.org/23054
OSVDB 23054
http://www.securityfocus.com/bid/16568
BID 16568 GNUTLS LibTASN1 DER Decoding Denial of Service Vulnerabilities Release Date:2006-12-22
http://www.redhat.com/archives/fedora-announce-list/2006-February/msg00043.html
FEDORA FEDORA-2006-107
http://www.trustix.org/errata/2006/0008
TRUSTIX 2006-0008
http://xforce.iss.net/xforce/xfdb/24606
XF gnutls-libtasn1-der-dos(24606)
http://www.ubuntulinux.org/support/documentation/usn/usn-251-1
UBUNTU USN-251-1
http://josefsson.org/cgi-bin/viewcvs.cgi/gnutls/tests/certder.c?view=markup
http://josefsson.org/gnutls/releases/libtasn1/libtasn1-0.2.18-from-0.2.17.patch
http://josefsson.org/cgi-bin/viewcvs.cgi/libtasn1/NEWS?root=gnupg-mirror&view=markup CONFIRM
http://lists.gnupg.org/pipermail/gnutls-dev/2006-February/001058.html
MLIST [gnutls-dev] 20060209 Libtasn1 0.2.18 - Tiny ASN.1 Library - Security release
http://rhn.redhat.com/errata/RHSA-2006-0207.html
REDHAT RHSA-2006:0207
http://lists.gnupg.org/pipermail/gnutls-dev/2006-February/001059.html
MLIST [gnutls-dev] 20060209 GnuTLS 1.2.10 - Security release
http://lists.gnupg.org/pipermail/gnutls-dev/2006-February/001060.html
MLIST [gnutls-dev] 20060209 GnuTLS 1.3.4 - Experimental - Security release
http://www.gleg.net/protover_ssl.shtml
http://www.securityfocus.com/archive/1/archive/1/424538/100/0/threaded
BUGTRAQ 20060209 ProtoVer SSL: GnuTLS

- Metasploit Modules Related To CVE-2006-0645

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.