CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2006-0553

PostgreSQL 8.1.0 through 8.1.2 allows authenticated database users to gain additional privileges via "knowledge of the backend protocol" using a crafted SET ROLE to other database users, a different vulnerability than CVE-2006-0678.
Publish Date : 2006-02-14 Last Update Date : 2008-09-05
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access User
Vulnerability Type(s) Gain privileges
CWE ID 264

- Vendor Statements

This issue did not affect the versions of PostgreSQL as distributed with Red Hat Enterprise Linux 2.1, 3, or 4.
Source: Redhat

- Products Affected By CVE-2006-0553

# Product Type Vendor Product Version Update Edition Language
1 Application Postgresql Postgresql 8.1.0 Version Details Vulnerabilities
2 Application Postgresql Postgresql 8.1.1 Version Details Vulnerabilities
3 Application Postgresql Postgresql 8.1.2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Postgresql Postgresql 3

- References For CVE-2006-0553

http://securitytracker.com/id?1015636
SECTRACK 1015636
http://www.openpkg.org/security/OpenPKG-SA-2006.004-postgresql.html
OPENPKG OpenPKG-SA-2006.004
http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-3 CONFIRM
http://www.securityfocus.com/bid/16649
BID 16649 PostgreSQL Remote SET ROLE Privilege Escalation Vulnerability Release Date:2006-02-22
http://www.securityfocus.com/archive/1/archive/1/425037/100/0/threaded
BUGTRAQ 20060215 PostgreSQL security releases 8.1.3, 8.0.7, 7.4.12, 7.3.14
http://xforce.iss.net/xforce/xfdb/24718
XF postgresql-setrole-privilege-elevation(24718)
http://secunia.com/advisories/18890
SECUNIA 18890
http://www.kb.cert.org/vuls/id/567452
CERT-VN VU#567452
http://www.frsirt.com/english/advisories/2006/0605
VUPEN ADV-2006-0605
http://archives.postgresql.org/pgsql-announce/2006-02/msg00008.php
MLIST [pgsql-announce] 20060214 Minor Releases 7.3 thru 8.1 Available to Fix Security Issue

- Metasploit Modules Related To CVE-2006-0553

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.