CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2005-4459

Heap-based buffer overflow in the NAT networking components vmnat.exe and vmnet-natd in VMWare Workstation 5.5, GSX Server 3.2, ACE 1.0.1, and Player 1.0 allows remote authenticated attackers, including guests, to execute arbitrary code via crafted (1) EPRT and (2) PORT FTP commands.
Publish Date : 2005-12-21 Last Update Date : 2011-10-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
10.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Execute CodeOverflow
CWE ID 119

- Products Affected By CVE-2005-4459

# Product Type Vendor Product Version Update Edition Language
1 Application Vmware ACE 1.0 Version Details Vulnerabilities
2 Application Vmware Gsx Server 2.0 Version Details Vulnerabilities
3 Application Vmware Gsx Server 2.0.1 Build 2129 Version Details Vulnerabilities
4 Application Vmware Gsx Server 2.5.1 Version Details Vulnerabilities
5 Application Vmware Gsx Server 2.5.1 Build 5336 Version Details Vulnerabilities
6 Application Vmware Gsx Server 2.5.2 Version Details Vulnerabilities
7 Application Vmware Gsx Server 3.0 Build 7592 Version Details Vulnerabilities
8 Application Vmware Gsx Server 3.0 Version Details Vulnerabilities
9 Application Vmware Gsx Server 3.1 Version Details Vulnerabilities
10 Application Vmware Gsx Server 3.2 Version Details Vulnerabilities
11 Application Vmware Player 1.0 Version Details Vulnerabilities
12 Application Vmware Workstation 3.2.1 Patch1 Version Details Vulnerabilities
13 Application Vmware Workstation 3.4 Version Details Vulnerabilities
14 Application Vmware Workstation 4.0 Version Details Vulnerabilities
15 Application Vmware Workstation 4.0.1 Version Details Vulnerabilities
16 Application Vmware Workstation 4.0.2 Version Details Vulnerabilities
17 Application Vmware Workstation 4.5.2 Build 8848 R4 Version Details Vulnerabilities
18 Application Vmware Workstation 4.5.2 Version Details Vulnerabilities
19 Application Vmware Workstation 5.0.0 Build 13124 Version Details Vulnerabilities
20 Application Vmware Workstation 5.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Vmware ACE 1
Vmware Gsx Server 9
Vmware Player 1
Vmware Workstation 9

- References For CVE-2005-4459

http://www.gentoo.org/security/en/glsa/glsa-200601-04.xml
GENTOO GLSA-200601-04
http://www.vmware.com/support/kb/enduser/std_adp.php?p_faqid=2000 CONFIRM
http://secunia.com/advisories/18344
SECUNIA 18344
http://lists.grok.org.uk/pipermail/full-disclosure/2005-December/040442.html
FULLDISC 20051221 [ACSSEC-2005-11-25-0x1] VMWare Workstation 5.5.0 <= build-18007 G SX Server Variants And Others
http://securityreason.com/securityalert/282
SREASON 282
http://secunia.com/advisories/18162
SECUNIA 18162
http://www.vupen.com/english/advisories/2005/3013
VUPEN ADV-2005-3013
http://www.securityfocus.com/archive/1/archive/1/420017/100/0/threaded
BUGTRAQ 20051221 VMware vulnerability in NAT networking
http://www.securityfocus.com/archive/1/archive/1/419997/100/0/threaded
BUGTRAQ 20051221 [Security-Advisories (at) acs-inc (dot) com [email concealed]: [Full-disclosure] [ACSSEC-2005-11-25-0x1] VMWare Workstation 5.5.0 <= build-18007 G SX Server Variants And Others]
http://securityreason.com/securityalert/289
SREASON 289
http://securitytracker.com/id?1015401
SECTRACK 1015401
http://www.securityfocus.com/bid/15998
BID 15998 VMWare Remote Arbitrary Code Execution Vulnerability Release Date:2006-01-10
http://www.kb.cert.org/vuls/id/856689
CERT-VN VU#856689

- Metasploit Modules Related To CVE-2005-4459

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.