CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2005-2458

inflate.c in the zlib routines in the Linux kernel before 2.6.12.5 allows remote attackers to cause a denial of service (kernel crash) via a compressed file with "improper tables".
Publish Date : 2005-08-23 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat low 2005-08-03 1999-06-25
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2005-2458 oval:org.opensuse.security:def:20052458 unix
inflate.c in the zlib routines in the Linux kernel before 2.6.12.5 allows remote attackers to cause a denial of service ... oval:org.mitre.oval:def:10785 unix
RHSA-2006:0101: kernel security update (Important) oval:com.redhat.rhsa:def:20060101 unix
RHSA-2006:0144: Updated kernel packages available for Red Hat Enterprise Linux 3 Update 7 (Moderate) oval:com.redhat.rhsa:def:20060144 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2005-2458

# Product Type Vendor Product Version Update Edition Language
1 OS Linux Linux Kernel 2.6 Test9 Cvs Version Details Vulnerabilities
2 OS Linux Linux Kernel 2.6.0 Test10 Version Details Vulnerabilities
3 OS Linux Linux Kernel 2.6.0 Test6 Version Details Vulnerabilities
4 OS Linux Linux Kernel 2.6.0 Test11 Version Details Vulnerabilities
5 OS Linux Linux Kernel 2.6.0 Test7 Version Details Vulnerabilities
6 OS Linux Linux Kernel 2.6.0 Test2 Version Details Vulnerabilities
7 OS Linux Linux Kernel 2.6.0 Test8 Version Details Vulnerabilities
8 OS Linux Linux Kernel 2.6.0 Test3 Version Details Vulnerabilities
9 OS Linux Linux Kernel 2.6.0 Version Details Vulnerabilities
10 OS Linux Linux Kernel 2.6.0 Test9 Version Details Vulnerabilities
11 OS Linux Linux Kernel 2.6.0 Test4 Version Details Vulnerabilities
12 OS Linux Linux Kernel 2.6.0 Test1 Version Details Vulnerabilities
13 OS Linux Linux Kernel 2.6.0 Test5 Version Details Vulnerabilities
14 OS Linux Linux Kernel 2.6.1 RC1 Version Details Vulnerabilities
15 OS Linux Linux Kernel 2.6.1 RC2 Version Details Vulnerabilities
16 OS Linux Linux Kernel 2.6.1 Version Details Vulnerabilities
17 OS Linux Linux Kernel 2.6.2 Version Details Vulnerabilities
18 OS Linux Linux Kernel 2.6.3 Version Details Vulnerabilities
19 OS Linux Linux Kernel 2.6.4 Version Details Vulnerabilities
20 OS Linux Linux Kernel 2.6.5 Version Details Vulnerabilities
21 OS Linux Linux Kernel 2.6.6 Version Details Vulnerabilities
22 OS Linux Linux Kernel 2.6.6 RC1 Version Details Vulnerabilities
23 OS Linux Linux Kernel 2.6.7 Version Details Vulnerabilities
24 OS Linux Linux Kernel 2.6.7 RC1 Version Details Vulnerabilities
25 OS Linux Linux Kernel 2.6.8 Version Details Vulnerabilities
26 OS Linux Linux Kernel 2.6.8 RC1 Version Details Vulnerabilities
27 OS Linux Linux Kernel 2.6.8 RC2 Version Details Vulnerabilities
28 OS Linux Linux Kernel 2.6.8 RC3 Version Details Vulnerabilities
29 OS Linux Linux Kernel 2.6.8.1 Version Details Vulnerabilities
30 OS Linux Linux Kernel 2.6.8.1.5 K7 Version Details Vulnerabilities
31 OS Linux Linux Kernel 2.6.8.1.5 686 Smp Version Details Vulnerabilities
32 OS Linux Linux Kernel 2.6.8.1.5 Powerpc Version Details Vulnerabilities
33 OS Linux Linux Kernel 2.6.8.1.5 K7 Smp Version Details Vulnerabilities
34 OS Linux Linux Kernel 2.6.8.1.5 Amd64 Version Details Vulnerabilities
35 OS Linux Linux Kernel 2.6.8.1.5 Powerpc Smp Version Details Vulnerabilities
36 OS Linux Linux Kernel 2.6.8.1.5 Power3 Version Details Vulnerabilities
37 OS Linux Linux Kernel 2.6.8.1.5 Amd64 K8 Version Details Vulnerabilities
38 OS Linux Linux Kernel 2.6.8.1.5 Version Details Vulnerabilities
39 OS Linux Linux Kernel 2.6.8.1.5 Power3 Smp Version Details Vulnerabilities
40 OS Linux Linux Kernel 2.6.8.1.5 Amd64 K8 Smp Version Details Vulnerabilities
41 OS Linux Linux Kernel 2.6.8.1.5 386 Version Details Vulnerabilities
42 OS Linux Linux Kernel 2.6.8.1.5 Power4 Version Details Vulnerabilities
43 OS Linux Linux Kernel 2.6.8.1.5 Amd64 Xeon Version Details Vulnerabilities
44 OS Linux Linux Kernel 2.6.8.1.5 686 Version Details Vulnerabilities
45 OS Linux Linux Kernel 2.6.8.1.5 Power4 Smp Version Details Vulnerabilities
46 OS Linux Linux Kernel 2.6.9 2.6.20 Version Details Vulnerabilities
47 OS Linux Linux Kernel 2.6.10 Version Details Vulnerabilities
48 OS Linux Linux Kernel 2.6.10 RC2 Version Details Vulnerabilities
49 OS Linux Linux Kernel 2.6.11 Rc1 Bk6 Version Details Vulnerabilities
50 OS Linux Linux Kernel 2.6.11 RC2 Version Details Vulnerabilities
51 OS Linux Linux Kernel 2.6.11 RC3 Version Details Vulnerabilities
52 OS Linux Linux Kernel 2.6.11 Version Details Vulnerabilities
53 OS Linux Linux Kernel 2.6.11 RC4 Version Details Vulnerabilities
54 OS Linux Linux Kernel 2.6.11.1 Version Details Vulnerabilities
55 OS Linux Linux Kernel 2.6.11.2 Version Details Vulnerabilities
56 OS Linux Linux Kernel 2.6.11.3 Version Details Vulnerabilities
57 OS Linux Linux Kernel 2.6.11.4 Version Details Vulnerabilities
58 OS Linux Linux Kernel 2.6.11.5 Version Details Vulnerabilities
59 OS Linux Linux Kernel 2.6.11.6 Version Details Vulnerabilities
60 OS Linux Linux Kernel 2.6.11.7 Version Details Vulnerabilities
61 OS Linux Linux Kernel 2.6.11.8 Version Details Vulnerabilities
62 OS Linux Linux Kernel 2.6.12 RC1 Version Details Vulnerabilities
63 OS Linux Linux Kernel 2.6.12 RC4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Linux Linux Kernel 63

- References For CVE-2005-2458

http://secunia.com/advisories/17826
SECUNIA 17826
http://secunia.com/advisories/17918
SECUNIA 17918
http://secunia.com/advisories/18056
SECUNIA 18056
http://secunia.com/advisories/18059
SECUNIA 18059
http://secunia.com/advisories/18510
SECUNIA 18510
http://secunia.com/advisories/18684
SECUNIA 18684
http://secunia.com/advisories/19252
SECUNIA 19252
http://www.debian.org/security/2005/dsa-921
DEBIAN DSA-921
http://www.debian.org/security/2005/dsa-922
DEBIAN DSA-922
http://www.mandriva.com/security/advisories?name=MDKSA-2005:220
MANDRAKE MDKSA-2005:220
http://www.mandriva.com/security/advisories?name=MDKSA-2005:219
MANDRIVA MDKSA-2005:219
http://www.novell.com/linux/security/advisories/2005_50_kernel.html
SUSE SUSE-SA:2005:050
http://www.redhat.com/support/errata/RHSA-2006-0101.html
REDHAT RHSA-2006:0101
http://www.redhat.com/support/errata/RHSA-2006-0144.html
REDHAT RHSA-2006:0144
http://www.redhat.com/support/errata/RHSA-2006-0190.html
REDHAT RHSA-2006:0190
http://www.redhat.com/support/errata/RHSA-2006-0191.html
REDHAT RHSA-2006:0191
http://www.securityfocus.com/archive/1/archive/1/419522/100/0/threaded
SUSE SUSE-SA:2005:068
http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.12.5 CONFIRM
http://www.securityfocus.com/bid/14719
BID 14719 Linux Kernel ZLib Invalid Memory Access Local Denial of Service Vulnerability Release Date:2006-05-26
http://www.securityfocus.com/archive/1/archive/1/428058/100/0/threaded
FEDORA FLSA:157459-2
http://www.securityfocus.com/archive/1/archive/1/428028/100/0/threaded
FEDORA FLSA:157459-1
http://secunia.com/advisories/16500
SECUNIA 16500
http://sources.redhat.com/ml/bug-gnu-utils/1999-06/msg00183.html
MLIST [bug-gnu-utils] 19990625 Re: bug in gzip: segfault when doing "gzip -t" on a broken file
http://www.securityfocus.com/archive/1/archive/1/427980/100/0/threaded
FEDORA FLSA:157459-3
http://www.ubuntulinux.org/support/documentation/usn/usn-169-1
UBUNTU USN-169-1
http://secunia.com/advisories/16355/
SECUNIA 16355

- Metasploit Modules Related To CVE-2005-2458

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.