CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2005-0605

scan.c for LibXPM may allow attackers to execute arbitrary code via a negative bitmap_unit value that leads to a buffer overflow.
Publish Date : 2005-03-02 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s) Execute CodeOverflow
CWE ID CWE id is not defined for this vulnerability

- Vendor Statements

Red Hat Enterprise Linux 5 is not vulnerable to this issue as it contains a backported patch.
Source: Redhat

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2005-02-28 2005-03-01
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2005-0605 oval:org.opensuse.security:def:20050605 unix
RHSA-2005:198: xorg-x11 security update (Moderate) oval:com.redhat.rhsa:def:20050198 unix
RHSA-2005:198: xorg-x11 security update (Moderate) oval:com.redhat.rhsa:def:2005198 unix
RHSA-2005:331: XFree86 security update (Moderate) oval:com.redhat.rhsa:def:20050331 unix
RHSA-2005:331: XFree86 security update (Moderate) oval:com.redhat.rhsa:def:2005331 unix
RHSA-2005:412: openmotif security update (Moderate) oval:com.redhat.rhsa:def:20050412 unix
RHSA-2005:412: openmotif security update (Moderate) oval:com.redhat.rhsa:def:2005412 unix
scan.c for LibXPM may allow attackers to execute arbitrary code via a negative bitmap_unit value that leads to a buffer ... oval:org.mitre.oval:def:10411 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2005-0605

# Product Type Vendor Product Version Update Edition Language
1 OS Altlinux Alt Linux 2.3 Compact Version Details Vulnerabilities
2 OS Altlinux Alt Linux 2.3 Junior Version Details Vulnerabilities
3 Application Lesstif Lesstif 0.93.94 Version Details Vulnerabilities
4 OS Mandrakesoft Mandrake Linux 10.0 Amd64 Version Details Vulnerabilities
5 OS Mandrakesoft Mandrake Linux 10.0 Version Details Vulnerabilities
6 OS Mandrakesoft Mandrake Linux 10.1 Version Details Vulnerabilities
7 OS Mandrakesoft Mandrake Linux 10.1 X86 64 Version Details Vulnerabilities
8 OS Mandrakesoft Mandrake Linux 10.2 Version Details Vulnerabilities
9 OS Mandrakesoft Mandrake Linux 10.2 X86 64 Version Details Vulnerabilities
10 OS Mandrakesoft Mandrake Linux Corporate Server 2.1 Version Details Vulnerabilities
11 OS Mandrakesoft Mandrake Linux Corporate Server 2.1 X86 64 Version Details Vulnerabilities
12 OS Mandrakesoft Mandrake Linux Corporate Server 3.0 Version Details Vulnerabilities
13 OS Mandrakesoft Mandrake Linux Corporate Server 3.0 X86 64 Version Details Vulnerabilities
14 OS Redhat Enterprise Linux 3.0 Workstation Server Version Details Vulnerabilities
15 OS Redhat Enterprise Linux 3.0 Advanced Server Version Details Vulnerabilities
16 OS Redhat Enterprise Linux 3.0 Enterprise Server Version Details Vulnerabilities
17 OS Redhat Enterprise Linux 4.0 Advanced Server Version Details Vulnerabilities
18 OS Redhat Enterprise Linux 4.0 Enterprise Server Version Details Vulnerabilities
19 OS Redhat Enterprise Linux 4.0 Workstation Version Details Vulnerabilities
20 OS Redhat Enterprise Linux Desktop 3.0 Version Details Vulnerabilities
21 OS Redhat Enterprise Linux Desktop 4.0 Version Details Vulnerabilities
22 OS Redhat Fedora Core Core 2.0 Version Details Vulnerabilities
23 OS Redhat Fedora Core Core 3.0 Version Details Vulnerabilities
24 Application SGI Propack 3.0 Version Details Vulnerabilities
25 OS Suse Suse Linux 6.1 Version Details Vulnerabilities
26 OS Suse Suse Linux 6.1 Alpha Version Details Vulnerabilities
27 OS Suse Suse Linux 6.2 Version Details Vulnerabilities
28 OS Suse Suse Linux 6.3 Version Details Vulnerabilities
29 OS Suse Suse Linux 6.3 PPC Version Details Vulnerabilities
30 OS Suse Suse Linux 6.3 Alpha Version Details Vulnerabilities
31 OS Suse Suse Linux 6.4 PPC Version Details Vulnerabilities
32 OS Suse Suse Linux 6.4 Alpha Version Details Vulnerabilities
33 OS Suse Suse Linux 6.4 Version Details Vulnerabilities
34 OS Suse Suse Linux 6.4 I386 Version Details Vulnerabilities
35 OS Suse Suse Linux 7.0 Sparc Version Details Vulnerabilities
36 OS Suse Suse Linux 7.0 Alpha Version Details Vulnerabilities
37 OS Suse Suse Linux 7.0 Version Details Vulnerabilities
38 OS Suse Suse Linux 7.0 I386 Version Details Vulnerabilities
39 OS Suse Suse Linux 7.0 PPC Version Details Vulnerabilities
40 OS Suse Suse Linux 7.1 X86 Version Details Vulnerabilities
41 OS Suse Suse Linux 7.1 Alpha Version Details Vulnerabilities
42 OS Suse Suse Linux 7.1 Version Details Vulnerabilities
43 OS Suse Suse Linux 7.1 SPA Version Details Vulnerabilities
44 OS Suse Suse Linux 7.1 Sparc Version Details Vulnerabilities
45 OS Suse Suse Linux 7.2 Version Details Vulnerabilities
46 OS Suse Suse Linux 7.2 I386 Version Details Vulnerabilities
47 OS Suse Suse Linux 7.3 PPC Version Details Vulnerabilities
48 OS Suse Suse Linux 7.3 Sparc Version Details Vulnerabilities
49 OS Suse Suse Linux 7.3 Version Details Vulnerabilities
50 OS Suse Suse Linux 7.3 I386 Version Details Vulnerabilities
51 OS Suse Suse Linux 8.0 Version Details Vulnerabilities
52 OS Suse Suse Linux 8.0 I386 Version Details Vulnerabilities
53 OS Suse Suse Linux 8.1 Version Details Vulnerabilities
54 OS Suse Suse Linux 8.2 Version Details Vulnerabilities
55 OS Suse Suse Linux 9.0 Version Details Vulnerabilities
56 OS Suse Suse Linux 9.0 X86 64 Version Details Vulnerabilities
57 OS Suse Suse Linux 9.1 Version Details Vulnerabilities
58 OS Suse Suse Linux 9.1 X86 64 Version Details Vulnerabilities
59 OS Suse Suse Linux 9.2 Version Details Vulnerabilities
60 OS Suse Suse Linux 9.2 X86 64 Version Details Vulnerabilities
61 Application X.org X11r6 6.7.0 Version Details Vulnerabilities
62 Application X.org X11r6 6.8 Version Details Vulnerabilities
63 Application X.org X11r6 6.8.1 Version Details Vulnerabilities
64 Application Xfree86 Project X11r6 3.3 Version Details Vulnerabilities
65 Application Xfree86 Project X11r6 3.3.2 Version Details Vulnerabilities
66 Application Xfree86 Project X11r6 3.3.3 Version Details Vulnerabilities
67 Application Xfree86 Project X11r6 3.3.4 Version Details Vulnerabilities
68 Application Xfree86 Project X11r6 3.3.5 Version Details Vulnerabilities
69 Application Xfree86 Project X11r6 3.3.6 Version Details Vulnerabilities
70 Application Xfree86 Project X11r6 4.0 Version Details Vulnerabilities
71 Application Xfree86 Project X11r6 4.0.1 Version Details Vulnerabilities
72 Application Xfree86 Project X11r6 4.0.2.11 Version Details Vulnerabilities
73 Application Xfree86 Project X11r6 4.0.3 Version Details Vulnerabilities
74 Application Xfree86 Project X11r6 4.1.0 Version Details Vulnerabilities
75 Application Xfree86 Project X11r6 4.1.11 Version Details Vulnerabilities
76 Application Xfree86 Project X11r6 4.1.12 Version Details Vulnerabilities
77 Application Xfree86 Project X11r6 4.2.0 Version Details Vulnerabilities
78 Application Xfree86 Project X11r6 4.2.1 Version Details Vulnerabilities
79 Application Xfree86 Project X11r6 4.2.1 Errata Version Details Vulnerabilities
80 Application Xfree86 Project X11r6 4.3.0 Version Details Vulnerabilities
81 Application Xfree86 Project X11r6 4.3.0.1 Version Details Vulnerabilities
82 Application Xfree86 Project X11r6 4.3.0.2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Altlinux Alt Linux 2
Lesstif Lesstif 1
Mandrakesoft Mandrake Linux 6
Mandrakesoft Mandrake Linux Corporate Server 4
Redhat Enterprise Linux 6
Redhat Enterprise Linux Desktop 2
Redhat Fedora Core 2
SGI Propack 1
Suse Suse Linux 36
X.org X11r6 3
Xfree86 Project X11r6 19

- References For CVE-2005-0605

ftp://patches.sgi.com/support/free/security/advisories/20060403-01-U
SGI 20060403-01-U
ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2005.57/SCOSA-2005.57.txt
SCO SCOSA-2005.57
ftp://ftp.sco.com/pub/updates/OpenServer/SCOSA-2006.5/SCOSA-2006.5.txt
SCO SCOSA-2006.5
http://lists.apple.com/archives/security-announce/2005//Aug/msg00001.html
APPLE APPLE-SA-2005-08-17
http://lists.apple.com/archives/security-announce/2005/Aug/msg00000.html
APPLE APPLE-SA-2005-08-15
http://secunia.com/advisories/14460
SECUNIA 14460
http://secunia.com/advisories/18316
SECUNIA 18316
http://secunia.com/advisories/18049
SECUNIA 18049
http://www.redhat.com/support/errata/RHSA-2005-198.html
REDHAT RHSA-2005:198
http://www.redhat.com/support/errata/RHSA-2005-044.html
REDHAT RHSA-2005:044
http://www.redhat.com/archives/fedora-legacy-announce/2006-January/msg00001.html
FEDORA FLSA-2006:152803
http://secunia.com/advisories/19624
SECUNIA 19624
http://www.redhat.com/support/errata/RHSA-2005-473.html
REDHAT RHSA-2005:473
http://www.redhat.com/support/errata/RHSA-2008-0261.html
REDHAT RHSA-2008:0261
http://www.ubuntulinux.org/support/documentation/usn/usn-92-1
UBUNTU USN-92-1
http://www.redhat.com/support/errata/RHSA-2005-412.html
REDHAT RHSA-2005:412
http://www.ubuntulinux.org/support/documentation/usn/usn-97-1
UBUNTU USN-97-1
http://bugs.gentoo.org/show_bug.cgi?id=83598 CONFIRM
https://bugs.freedesktop.org/attachment.cgi?id=1909 CONFIRM
http://bugs.gentoo.org/show_bug.cgi?id=83655 CONFIRM
http://www.gentoo.org/security/en/glsa/glsa-200503-15.xml
GENTOO GLSA-200503-15
http://security.gentoo.org/glsa/glsa-200503-08.xml
GENTOO GLSA-200503-08
http://securitytracker.com/id?1013339
SECTRACK 1013339
http://www.debian.org/security/2005/dsa-723
DEBIAN DSA-723
http://www.securityfocus.com/bid/12714
BID 12714 libXPM Bitmap_unit Integer Overflow Vulnerability Release Date:2008-07-02
http://www.redhat.com/support/errata/RHSA-2005-331.html
REDHAT RHSA-2005:331

- Metasploit Modules Related To CVE-2005-0605

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.