CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2005-0156

Buffer overflow in the PerlIO implementation in Perl 5.8.0, when installed with setuid support (sperl), allows local users to execute arbitrary code by setting the PERLIO_DEBUG variable and executing a Perl script whose full pathname contains a long directory tree.
Publish Date : 2005-02-07 Last Update Date : 2013-10-23
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute CodeOverflow
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2005-01-30 2005-02-01
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
Buffer overflow in the PerlIO implementation in Perl 5.8.0, when installed with setuid support (sperl), allows local use... oval:org.mitre.oval:def:10803 unix
CVE-2005-0156 oval:org.opensuse.security:def:20050156 unix
RHSA-2005:103: perl security update (Important) oval:com.redhat.rhsa:def:20050103 unix
RHSA-2005:103: perl security update (Important) oval:com.redhat.rhsa:def:2005103 unix
RHSA-2005:105: perl security update (Important) oval:com.redhat.rhsa:def:2005105 unix
RHSA-2005:105: perl security update (Important) oval:com.redhat.rhsa:def:20050105 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2005-0156

# Product Type Vendor Product Version Update Edition Language
1 OS IBM AIX 5.2 Version Details Vulnerabilities
2 OS IBM AIX 5.3 Version Details Vulnerabilities
3 Application Larry Wall Perl 5.8.0 Version Details Vulnerabilities
4 Application Larry Wall Perl 5.8.1 Version Details Vulnerabilities
5 Application Larry Wall Perl 5.8.3 Version Details Vulnerabilities
6 Application Larry Wall Perl 5.8.4 Version Details Vulnerabilities
7 Application Larry Wall Perl 5.8.4.1 Version Details Vulnerabilities
8 Application Larry Wall Perl 5.8.4.2 Version Details Vulnerabilities
9 Application Larry Wall Perl 5.8.4.2.3 Version Details Vulnerabilities
10 Application Larry Wall Perl 5.8.4.3 Version Details Vulnerabilities
11 Application Larry Wall Perl 5.8.4.4 Version Details Vulnerabilities
12 Application Larry Wall Perl 5.8.4.5 Version Details Vulnerabilities
13 OS Redhat Enterprise Linux 3.0 Advanced Server Version Details Vulnerabilities
14 OS Redhat Enterprise Linux 3.0 Enterprise Server Version Details Vulnerabilities
15 OS Redhat Enterprise Linux 3.0 Workstation Server Version Details Vulnerabilities
16 OS Redhat Enterprise Linux Desktop 3.0 Version Details Vulnerabilities
17 OS Redhat Fedora Core Core 3.0 Version Details Vulnerabilities
18 Application SGI Propack 3.0 Version Details Vulnerabilities
19 OS Suse Suse Linux 8.0 I386 Version Details Vulnerabilities
20 OS Suse Suse Linux 8.0 Version Details Vulnerabilities
21 OS Suse Suse Linux 8.1 Version Details Vulnerabilities
22 OS Suse Suse Linux 8.2 Version Details Vulnerabilities
23 OS Suse Suse Linux 9.0 Version Details Vulnerabilities
24 OS Suse Suse Linux 9.0 X86 64 Version Details Vulnerabilities
25 OS Suse Suse Linux 9.1 Version Details Vulnerabilities
26 OS Suse Suse Linux 9.2 Version Details Vulnerabilities
27 OS Trustix Secure Linux 1.5 Version Details Vulnerabilities
28 OS Trustix Secure Linux 2.0 Version Details Vulnerabilities
29 OS Trustix Secure Linux 2.1 Version Details Vulnerabilities
30 OS Trustix Secure Linux 2.2 Version Details Vulnerabilities
31 OS Ubuntu Ubuntu Linux 4.1 Ia64 Version Details Vulnerabilities
32 OS Ubuntu Ubuntu Linux 4.1 PPC Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
IBM AIX 2
Larry Wall Perl 10
Redhat Enterprise Linux 3
Redhat Enterprise Linux Desktop 1
Redhat Fedora Core 1
SGI Propack 1
Suse Suse Linux 8
Trustix Secure Linux 4
Ubuntu Ubuntu Linux 2

- References For CVE-2005-0156

http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=001056
CONECTIVA CLSA-2006:1056
http://fedoranews.org/updates/FEDORA--.shtml
FEDORA FLSA-2006:152845
http://secunia.com/advisories/14120
SECUNIA 14120
http://www.mandriva.com/security/advisories?name=MDKSA-2005:031
MANDRAKE MDKSA-2005:031
http://marc.theaimsgroup.com/?l=bugtraq&m=110737149402683&w=2
BUGTRAQ 20050202 [USN-72-1] Perl vulnerabilities
http://marc.theaimsgroup.com/?l=full-disclosure&m=110779721503111&w=2
FULLDISC 20050207 DMA[2005-0131b] - 'Setuid Perl PERLIO_DEBUG
http://secunia.com/advisories/55314
SECUNIA 55314
http://www.redhat.com/support/errata/RHSA-2005-103.html
REDHAT RHSA-2005:103
http://www.digitalmunition.com/DMA%5B2005-0131b%5D.txt
http://www.digitalmunition.com/DMA[2005-0131b].txt
http://www.gentoo.org/security/en/glsa/glsa-200502-13.xml
GENTOO GLSA-200502-13
http://www.redhat.com/support/errata/RHSA-2005-105.html
REDHAT RHSA-2005:105
http://www.securityfocus.com/bid/12426
BID 12426 Perl SuidPerl Multiple Local Vulnerabilities Release Date:2013-09-26
http://www.trustix.org/errata/2005/0003/
TRUSTIX 2005-0003
http://xforce.iss.net/xforce/xfdb/19208
XF perl-perliodebug-bo(19208)

- Metasploit Modules Related To CVE-2005-0156

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.