CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2004-1189

The add_to_history function in svr_principal.c in libkadm5srv for MIT Kerberos 5 (krb5) up to 1.3.5, when performing a password change, does not properly track the password policy's history count and the maximum number of keys, which can cause an array index out-of-bounds error and may allow authenticated users to execute arbitrary code via a heap-based buffer overflow.
Publish Date : 2004-12-31 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.2
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access Admin
Vulnerability Type(s) Execute CodeOverflow
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2004-12-14 2004-12-21
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2005:012: krb5 security update (Moderate) oval:com.redhat.rhsa:def:2005012 unix
RHSA-2005:012: krb5 security update (Moderate) oval:com.redhat.rhsa:def:20050012 unix
RHSA-2005:045: krb5 security update (Moderate) oval:com.redhat.rhsa:def:2005045 unix
RHSA-2005:045: krb5 security update (Moderate) oval:com.redhat.rhsa:def:20050045 unix
The add_to_history function in svr_principal.c in libkadm5srv for MIT Kerberos 5 (krb5) up to 1.3.5, when performing a p... oval:org.mitre.oval:def:11911 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2004-1189

# Product Type Vendor Product Version Update Edition Language
1 Application MIT Kerberos 5-1.2 Version Details Vulnerabilities
2 Application MIT Kerberos 5-1.3.1 Version Details Vulnerabilities
3 Application MIT Kerberos 5-1.3.5 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
MIT Kerberos 3

- References For CVE-2004-1189

http://lists.apple.com/archives/security-announce/2005//Aug/msg00001.html
APPLE APPLE-SA-2005-08-17
http://lists.apple.com/archives/security-announce/2005/Aug/msg00000.html
APPLE APPLE-SA-2005-08-15
http://marc.theaimsgroup.com/?l=bugtraq&m=110548298407590&w=2
BUGTRAQ 20050110 [USN-58-1] MIT Kerberos server vulnerability
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000917
CONECTIVA CLA-2005:917
http://www.mandriva.com/security/advisories?name=MDKSA-2004:156
MANDRAKE MDKSA-2004:156
http://www.redhat.com/support/errata/RHSA-2005-012.html
REDHAT RHSA-2005:012
http://www.redhat.com/support/errata/RHSA-2005-045.html
REDHAT RHSA-2005:045
http://www.trustix.org/errata/2004/0069
TRUSTIX 2004-0069
http://xforce.iss.net/xforce/xfdb/18621
XF kerberos-libkadm5srv-bo(18621)
http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2004-004-pwhist.txt CONFIRM
http://marc.theaimsgroup.com/?l=bugtraq&m=110358420909358&w=2
BUGTRAQ 20041220 MITKRB5-SA-2004-004: heap overflow in libkadm5srv

- Metasploit Modules Related To CVE-2004-1189

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.