CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2004-0986

Iptables before 1.2.11, under certain conditions, does not properly load the required modules at system startup, which causes the firewall rules to fail to load and protect the system from remote attackers.
Publish Date : 2005-03-01 Last Update Date : 2008-09-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access User
Vulnerability Type(s)
CWE ID CWE id is not defined for this vulnerability

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2004-0986 oval:org.opensuse.security:def:20040986 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2004-0986

# Product Type Vendor Product Version Update Edition Language
1 OS Debian Debian Linux 3.0 Mips Version Details Vulnerabilities
2 OS Debian Debian Linux 3.0 ARM Version Details Vulnerabilities
3 OS Debian Debian Linux 3.0 Mipsel Version Details Vulnerabilities
4 OS Debian Debian Linux 3.0 Hppa Version Details Vulnerabilities
5 OS Debian Debian Linux 3.0 PPC Version Details Vulnerabilities
6 OS Debian Debian Linux 3.0 Ia-32 Version Details Vulnerabilities
7 OS Debian Debian Linux 3.0 S-390 Version Details Vulnerabilities
8 OS Debian Debian Linux 3.0 Ia-64 Version Details Vulnerabilities
9 OS Debian Debian Linux 3.0 Version Details Vulnerabilities
10 OS Debian Debian Linux 3.0 Sparc Version Details Vulnerabilities
11 OS Debian Debian Linux 3.0 M68k Version Details Vulnerabilities
12 OS Debian Debian Linux 3.0 Alpha Version Details Vulnerabilities
13 OS Linux Linux Kernel 2.0.2 Version Details Vulnerabilities
14 OS Linux Linux Kernel 2.4.0 Version Details Vulnerabilities
15 OS Linux Linux Kernel 2.4.1 Version Details Vulnerabilities
16 OS Linux Linux Kernel 2.4.2 Version Details Vulnerabilities
17 OS Linux Linux Kernel 2.4.3 Version Details Vulnerabilities
18 OS Linux Linux Kernel 2.4.4 Version Details Vulnerabilities
19 OS Linux Linux Kernel 2.4.5 Version Details Vulnerabilities
20 OS Linux Linux Kernel 2.4.6 Version Details Vulnerabilities
21 OS Linux Linux Kernel 2.4.7 Version Details Vulnerabilities
22 OS Linux Linux Kernel 2.4.8 Version Details Vulnerabilities
23 OS Linux Linux Kernel 2.4.9 Version Details Vulnerabilities
24 OS Linux Linux Kernel 2.4.10 Version Details Vulnerabilities
25 OS Linux Linux Kernel 2.4.11 Version Details Vulnerabilities
26 OS Linux Linux Kernel 2.4.12 Version Details Vulnerabilities
27 OS Linux Linux Kernel 2.4.13 Version Details Vulnerabilities
28 OS Linux Linux Kernel 2.4.14 Version Details Vulnerabilities
29 OS Linux Linux Kernel 2.4.15 Version Details Vulnerabilities
30 OS Linux Linux Kernel 2.4.16 Version Details Vulnerabilities
31 OS Linux Linux Kernel 2.4.17 Version Details Vulnerabilities
32 OS Linux Linux Kernel 2.4.18 Version Details Vulnerabilities
33 OS Linux Linux Kernel 2.4.19 Version Details Vulnerabilities
34 OS Linux Linux Kernel 2.4.20 Version Details Vulnerabilities
35 OS Linux Linux Kernel 2.4.21 Version Details Vulnerabilities
36 OS Linux Linux Kernel 2.4.22 Version Details Vulnerabilities
37 OS Linux Linux Kernel 2.4.23 Version Details Vulnerabilities
38 OS Linux Linux Kernel 2.4.24 Version Details Vulnerabilities
39 OS Linux Linux Kernel 2.4.25 Version Details Vulnerabilities
40 OS Linux Linux Kernel 2.4.26 Version Details Vulnerabilities
41 OS Linux Linux Kernel 2.6.0 Version Details Vulnerabilities
42 OS Linux Linux Kernel 2.6.1 Version Details Vulnerabilities
43 OS Linux Linux Kernel 2.6.2 Version Details Vulnerabilities
44 OS Linux Linux Kernel 2.6.3 Version Details Vulnerabilities
45 OS Linux Linux Kernel 2.6.4 Version Details Vulnerabilities
46 OS Linux Linux Kernel 2.6.5 Version Details Vulnerabilities
47 OS Linux Linux Kernel 2.6.6 Version Details Vulnerabilities
48 OS Linux Linux Kernel 2.6.7 Version Details Vulnerabilities
49 OS Linux Linux Kernel 2.6.8 Version Details Vulnerabilities
50 OS Linux Linux Kernel 2.6.9 2.6.20 Version Details Vulnerabilities
51 OS Redhat Fedora Core Core 3.0 Version Details Vulnerabilities
52 Application Suse Suse Iptables 1.2.11 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Debian Debian Linux 12
Linux Linux Kernel 38
Redhat Fedora Core 1
Suse Suse Iptables 1

- References For CVE-2004-0986

http://rpmfind.net/linux/RPM/suse/updates/9.2/i386/rpm/i586/iptables-1.2.11-4.2.i586.html CONFIRM
http://www.mandriva.com/security/advisories?name=MDKSA-2004:125
MANDRAKE MDKSA-2004:125
http://www.ciac.org/ciac/bulletins/p-026.shtml
CIAC P-026
http://www.debian.org/security/2004/dsa-580
DEBIAN DSA-580
https://bugzilla.fedora.us/show_bug.cgi?id=2252
FEDORA FLSA:2252
http://xforce.iss.net/xforce/xfdb/17928
XF iptables-module-dos(17928)
http://www.securityfocus.com/bid/11570
BID 11570 Linux Kernel IPTables Initialization Failure Vulnerability Release Date:2009-07-12
http://marc.theaimsgroup.com/?l=bugtraq&m=110815247703862&w=2
UBUNTU USN-81-1

- Metasploit Modules Related To CVE-2004-0986

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.