CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2004-0748

mod_ssl in Apache 2.0.50 and earlier allows remote attackers to cause a denial of service (CPU consumption) by aborting an SSL connection in a way that causes an Apache child process to enter an infinite loop.
Publish Date : 2004-10-20 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Vendor Statements

Fixed in Apache HTTP Server 2.0.51: http://httpd.apache.org/security/vulnerabilities_20.html
Source: Apache

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat important 2004-07-07
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2004-0748 oval:org.opensuse.security:def:20040748 unix
mod_ssl in Apache 2.0.50 and earlier allows remote attackers to cause a denial of service (CPU consumption) by aborting ... oval:org.mitre.oval:def:11126 unix
RHSA-2004:349: httpd security update (Important) oval:com.redhat.rhsa:def:2004349 unix
RHSA-2004:349: httpd security update (Important) oval:com.redhat.rhsa:def:20040349 unix
SSL connection infinite loop oval:org.apache.httpd:def:20040748
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2004-0748

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Http Server 2.0 Version Details Vulnerabilities
2 Application Apache Http Server 2.0.28 Version Details Vulnerabilities
3 Application Apache Http Server 2.0.32 Version Details Vulnerabilities
4 Application Apache Http Server 2.0.35 Version Details Vulnerabilities
5 Application Apache Http Server 2.0.36 Version Details Vulnerabilities
6 Application Apache Http Server 2.0.37 Version Details Vulnerabilities
7 Application Apache Http Server 2.0.38 Version Details Vulnerabilities
8 Application Apache Http Server 2.0.39 Version Details Vulnerabilities
9 Application Apache Http Server 2.0.40 Version Details Vulnerabilities
10 Application Apache Http Server 2.0.41 Version Details Vulnerabilities
11 Application Apache Http Server 2.0.42 Version Details Vulnerabilities
12 Application Apache Http Server 2.0.43 Version Details Vulnerabilities
13 Application Apache Http Server 2.0.44 Version Details Vulnerabilities
14 Application Apache Http Server 2.0.45 Version Details Vulnerabilities
15 Application Apache Http Server 2.0.46 Version Details Vulnerabilities
16 Application Apache Http Server 2.0.47 Version Details Vulnerabilities
17 Application Apache Http Server 2.0.48 Version Details Vulnerabilities
18 Application Apache Http Server 2.0.49 Version Details Vulnerabilities
19 Application Apache Http Server 2.0.50 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Http Server 19

- References For CVE-2004-0748

http://www.gentoo.org/security/en/glsa/glsa-200409-21.xml
GENTOO GLSA-200409-21
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:096
MANDRAKE MDKSA-2004:096
http://www.novell.com/linux/security/advisories/2004_30_apache2.html
SUSE SUSE-SA:2004:030
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=130750 CONFIRM
http://www.trustix.org/errata/2004/0047/
TRUSTIX 2004-0047
http://www.redhat.com/support/errata/RHSA-2004-349.html
REDHAT RHSA-2004:349
http://xforce.iss.net/xforce/xfdb/17200
XF apache-modssl-dos(17200)

- Metasploit Modules Related To CVE-2004-0748

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.