CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register   Reset Password   Activate Account
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2004-0635

The SNMP dissector in Ethereal 0.8.15 through 0.10.4 allows remote attackers to cause a denial of service (process crash) via a (1) malformed or (2) missing community string, which causes an out-of-bounds read.
Publish Date : 2004-12-06 Last Update Date : 2010-08-21
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of Service
CWE ID CWE id is not defined for this vulnerability

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate 2004-07-06
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
CVE-2004-0635 oval:org.opensuse.security:def:20040635 unix
RHSA-2004:378: ethereal security update (Moderate) oval:com.redhat.rhsa:def:2004378 unix
RHSA-2004:378: ethereal security update (Moderate) oval:com.redhat.rhsa:def:20040378 unix
The SNMP dissector in Ethereal 0.8.15 through 0.10.4 allows remote attackers to cause a denial of service (process crash... oval:org.mitre.oval:def:9721 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2004-0635

# Product Type Vendor Product Version Update Edition Language
1 Application Ethereal Group Ethereal 0.8.15 Version Details Vulnerabilities
2 Application Ethereal Group Ethereal 0.8.16 Version Details Vulnerabilities
3 Application Ethereal Group Ethereal 0.8.17 Version Details Vulnerabilities
4 Application Ethereal Group Ethereal 0.8.18 Version Details Vulnerabilities
5 Application Ethereal Group Ethereal 0.8.19 Version Details Vulnerabilities
6 Application Ethereal Group Ethereal 0.9 Version Details Vulnerabilities
7 Application Ethereal Group Ethereal 0.9.1 Version Details Vulnerabilities
8 Application Ethereal Group Ethereal 0.9.2 Version Details Vulnerabilities
9 Application Ethereal Group Ethereal 0.9.3 Version Details Vulnerabilities
10 Application Ethereal Group Ethereal 0.9.4 Version Details Vulnerabilities
11 Application Ethereal Group Ethereal 0.9.5 Version Details Vulnerabilities
12 Application Ethereal Group Ethereal 0.9.6 Version Details Vulnerabilities
13 Application Ethereal Group Ethereal 0.9.7 Version Details Vulnerabilities
14 Application Ethereal Group Ethereal 0.9.8 Version Details Vulnerabilities
15 Application Ethereal Group Ethereal 0.9.9 Version Details Vulnerabilities
16 Application Ethereal Group Ethereal 0.9.10 Version Details Vulnerabilities
17 Application Ethereal Group Ethereal 0.9.11 Version Details Vulnerabilities
18 Application Ethereal Group Ethereal 0.9.12 Version Details Vulnerabilities
19 Application Ethereal Group Ethereal 0.9.13 Version Details Vulnerabilities
20 Application Ethereal Group Ethereal 0.9.14 Version Details Vulnerabilities
21 Application Ethereal Group Ethereal 0.9.15 Version Details Vulnerabilities
22 Application Ethereal Group Ethereal 0.9.16 Version Details Vulnerabilities
23 Application Ethereal Group Ethereal 0.10 Version Details Vulnerabilities
24 Application Ethereal Group Ethereal 0.10.1 Version Details Vulnerabilities
25 Application Ethereal Group Ethereal 0.10.2 Version Details Vulnerabilities
26 Application Ethereal Group Ethereal 0.10.3 Version Details Vulnerabilities
27 Application Ethereal Group Ethereal 0.10.4 Version Details Vulnerabilities
28 OS Gentoo Linux Version Details Vulnerabilities
29 OS Mandrakesoft Mandrake Linux 9.2 Version Details Vulnerabilities
30 OS Mandrakesoft Mandrake Linux 10.0 Version Details Vulnerabilities
31 OS Redhat Enterprise Linux 2.1 Enterprise Server Version Details Vulnerabilities
32 OS Redhat Enterprise Linux 2.1 Workstation Version Details Vulnerabilities
33 OS Redhat Enterprise Linux 2.1 Advanced Server Version Details Vulnerabilities
34 OS Redhat Enterprise Linux 3.0 Advanced Server Version Details Vulnerabilities
35 OS Redhat Enterprise Linux 3.0 Enterprise Server Version Details Vulnerabilities
36 OS Redhat Enterprise Linux 3.0 Workstation Server Version Details Vulnerabilities
37 OS Redhat Linux Advanced Workstation 2.1 AS Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Ethereal Group Ethereal 27
Gentoo Linux 1
Mandrakesoft Mandrake Linux 2
Redhat Enterprise Linux 6
Redhat Linux Advanced Workstation 1

- References For CVE-2004-0635

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=127381 CONFIRM
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000916
CONECTIVA CLA-2005:916
http://secunia.com/advisories/12024
SECUNIA 12024
http://securitytracker.com/id?1010655
SECTRACK 1010655
http://www.debian.org/security/2004/dsa-528
DEBIAN DSA-528
http://www.redhat.com/support/errata/RHSA-2004-378.html
REDHAT RHSA-2004:378
http://www.ethereal.com/appnotes/enpa-sa-00015.html CONFIRM
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:067
MANDRAKE MDKSA-2004:067
http://www.gentoo.org/security/en/glsa/glsa-200407-08.xml
GENTOO GLSA-200407-08
http://www.redhat.com/archives/fedora-announce-list/2004-July/msg00013.html
FEDORA FEDORA-2004-219
http://xforce.iss.net/xforce/xfdb/16632
XF ethereal-snmp-community-dos(16632)
http://www.redhat.com/archives/fedora-announce-list/2004-July/msg00014.html
FEDORA FEDORA-2004-220
http://www.kb.cert.org/vuls/id/835846
CERT-VN VU#835846

- Metasploit Modules Related To CVE-2004-0635

There are not any metasploit modules related to this vulnerability (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.